[RESOLVED] New Install i can't use rtlsdr

Hello friends:

I made a new install of my #255 ground station.
I have selected rtlsdr on satnogs-setup but client doesn’t use it.
It continues trying to use audio driver.
Why?

{
“versions”: {
“satnogs-client”: “1.8.1”,
“satnogs-client-ansible”: “202209101521”,
“satnogs-flowgraphs”: “1.4-1”,
“gr-satnogs”: “2.3.3.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14”,
“satnogs-config”: “0.13.2”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2022-12-19T20:12:48.140195+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 11 (bullseye)”,
“RELEASE”: “11”,
“CODENAME”: “bullseye”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.103-v7+”,
“version”: “#1529 SMP Tue Mar 8 12:21:37 GMT 2022”,
“machine”: “armv7l”
},
“memory”: {
“total”: 968052736,
“available”: 769974272,
“percent”: 20.5,
“used”: 139837440,
“free”: 226357248,
“active”: 366444544,
“inactive”: 316829696,
“buffers”: 44023808,
“cached”: 557834240,
“shared”: 618496,
“slab”: 38522880
},
“disk”: {
“total”: 61232377856,
“used”: 7858749440,
“free”: 50851659776,
“percent”: 13.4
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “rtlsdr”,
“satnogs_station_elev”: “120”,
“satnogs_station_id”: “255”,
“satnogs_station_lat”: “38.2768”,
“satnogs_station_lon”: “-0.6711”
}
}

And more info:
SoapySDRUtil --probe
######################################################

Soapy SDR – the SDR abstraction library

######################################################

Probe device
[INFO] [UHD] linux; GNU C++ version 10.2.1 20210110; Boost_107400; UHD_3.15.0.0-4+b1satnogs1
Found Rafael Micro R820T tuner


– Device identification

driver=Audio
hardware=Audio
device_id=0
origin=GitHub - pothosware/SoapyAudio: Soapy SDR plugin for Audio devices


– Peripheral summary

Channels: 1 Rx, 0 Tx
Timestamps: NO
Other Settings:
* Stereo Sample Offset - Offset stereo samples for off-by-one audio inputs.
[key=sample_offset, default=0, type=string, options=(-2, -1, 0, 1, 2)]
* Rig Control - Select hamlib rig control type.
[key=rig, type=string, options=(29001, 25016, 25017, 25013, 25018, 5008, 5006, 5005, 5004, 5014, 5003, 5015, 5002, 5001, 5013, 5016, 17001, 17002, 25006, 32001, 25003, 23003, 23004, 31002, 31001, 9002, 9003, 33001, 2021, 2029, 2043, 2047, 2044, 2045, 2038, 25001, 25007, 4, 25012, 23001, 2036, 2048, 25015, 1, 6, 2, 2046, 25019, 3054, 3002, 3003, 3072, 3004, 3006, 3007, 3060, 3055, 3085, 3009, 3010, 3011, 3012, 3070, 3013, 3061, 3014, 3015, 3016, 3017, 3073, 3019, 3020, 3021, 3022, 3067, 3023, 3046, 3024, 3026, 3027, 3047, 3057, 3063, 3028, 3078, 3029, 3062, 3030, 3045, 3056, 3031, 3075, 3032, 3034, 3044, 3068, 3065, 3035, 3081, 30001, 30003, 30002, 30004, 4002, 4001, 4003, 4004, 3036, 3058, 3080, 3077, 3040, 3037, 3041, 3038, 3039, 3079, 3043, 3066, 3069, 3042, 3083, 3082, 3084, 3071, 6005, 6006, 6007, 25011, 18001, 2015, 2033, 2042, 2017, 2019, 2020, 2023, 2026, 2034, 2027, 2030, 2025, 2014, 2002, 2003, 2028, 2001, 2004, 2016, 2031, 2037, 2024, 2005, 2006, 2007, 2008, 2009, 2010, 2041, 2022, 2011, 2012, 2013, 2039, 10004, 3074, 25014, 2040, 3053, 3052, 28001, 24001, 11005, 11003, 8004, 27002, 27001, 27003, 25002, 2032, 14004, 14002, 25009, 22001, 5, 3064, 3051, 16003, 16012, 16004, 16005, 16007, 16002, 16001, 16008, 16009, 16011, 16013, 8002, 8006, 8001, 8003, 8012, 8010, 8011, 1033, 26001, 26002, 12004, 15001, 15002, 15003, 15004, 15005, 15006, 15007, 15009, 3076, 1017, 1019, 1018, 1021, 1003, 1024, 1029, 1027, 1039, 1010, 1005, 1006, 1007, 1009, 1020, 1041, 1011, 1001, 1038, 1022, 1015, 1036, 1023, 1013, 1014, 1028, 1031, 1016, 1035, 1034, 1037, 1032, 1030, 1040, 1004, 1025, 1026, 25008)]
* Rig Serial Rate - Select hamlib rig serial control rate.
[key=rig_rate, default=57600, type=string, options=(1200, 2400, 4800, 9600, 19200, 38400, 57600, 115200, 128000, 256000)]
* Rig Serial Port - hamlib rig Serial Port dev / COMx / IP-Address
[key=rig_port, default=/dev/ttyUSB0, type=string]


– RX Channel 0

Full-duplex: YES
Supports AGC: YES
Stream formats: CS8, CS16, CF32
Native format: CS16 [full-scale=65536]
Stream args:
* Channel Setup - Input channel configuration.
[key=chan, default=mono_l, type=string, options=(mono_l, mono_r, stereo_iq, stereo_qi)]
Antennas: RX
Full gain range: [0, 0] dB
Full freq range: [0, 6000] MHz
RF freq range: [0, 6000] MHz
Sample rates: 0.008, 0.016, 0.02205, 0.032, 0.0441, 0.048, 0.096 MSps

And info from log:

Dec 19 20:51:16 raspberrypi satnogs-client[1352]: rig_init: rig does not have rx_range!!
Dec 19 20:51:16 raspberrypi satnogs-client[1352]: network_open: hoststr=127.0.0.1, portstr=4532
Dec 19 20:51:18 raspberrypi satnogs-client[2601]: [INFO] [UHD] linux; GNU C++ version 10.2.1 20210110; Boost_107400; UHD_3.15.0.0-4+b1satnogs1
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: Found Rafael Micro R820T tuner
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: Traceback (most recent call last):
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: File “/usr/bin/satnogs_amsat_fox_duv_decoder.py”, line 515, in
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: main()
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: File “/usr/bin/satnogs_amsat_fox_duv_decoder.py”, line 498, in main
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: tb = top_block_cls(antenna=options.antenna, bb_freq=options.bb_freq, bw=options.bw, dc_removal=options.dc_removal, decoded_data_file_path=options.decoded_data_file_path, dev_args=options.dev_args, doppler_correction_per_sec=options.doppler_correction_per_sec, enable_iq_dump=options.enable_iq_dump, file_path=options.file_path, gain=options.gain, gain_mode=options.gain_mode, iq_file_path=options.iq_file_path, lo_offset=options.lo_offset, other_settings=options.other_settings, ppm=options.ppm, rigctl_port=options.rigctl_port, rx_freq=options.rx_freq, samp_rate_rx=options.samp_rate_rx, soapy_rx_device=options.soapy_rx_device, stream_args=options.stream_args, tune_args=options.tune_args, udp_IP=options.udp_IP, udp_dump_host=options.udp_dump_host, udp_dump_port=options.udp_dump_port, udp_port=options.udp_port, waterfall_file_path=options.waterfall_file_path)
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: File “/usr/bin/satnogs_amsat_fox_duv_decoder.py”, line 92, in init
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: self.soapy_source_0_0 = soapy.source(1, dev, dev_args, stream_args,
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: File “/usr/lib/python3/dist-packages/soapy/soapy_swig.py”, line 131, in make
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: return _soapy_swig.source_make(nchan, device, dev_args, stream_args, tune_args, other_settings, sampling_rate, type)
Dec 19 20:51:19 raspberrypi satnogs-client[2601]: RuntimeError: soapy::source: Unsupported sample rate (2048000.000000). Rate must be in the range [8000.000000, 8000.000000] [16000.000000, 16000.000000] [22050.000000, 22050.000000] [32000.000000, 32000.000000] [44100.000000, 44100.000000] [48000.000000, 48000.000000] [96000.000000, 96000.000000]
Dec 19 20:51:21 raspberrypi satnogs-client[1352]: netrigctl_close: done status=Command completed successfully
Dec 19 20:51:22 raspberrypi satnogs-client[1352]: satnogsclient.observer.observer - ERROR - No waterfall data file found

And more info:

root@raspberrypi:/home/pi# SoapySDRUtil --probe=“driver=rtlsdr”
######################################################

Soapy SDR – the SDR abstraction library

######################################################

Probe device driver=rtlsdr
Found Rafael Micro R820T tuner
[INFO] Opening Generic RTL2832U OEM :: 00000001…
Found Rafael Micro R820T tuner


– Device identification

driver=RTLSDR
hardware=R820T
index=0
origin=GitHub - pothosware/SoapyRTLSDR: SoapySDR RTL-SDR Support Module


– Peripheral summary

Channels: 1 Rx, 0 Tx
Timestamps: YES
Time sources: sw_ticks
Other Settings:
* Direct Sampling - RTL-SDR Direct Sampling Mode
[key=direct_samp, default=0, type=string, options=(0, 1, 2)]
* Offset Tune - RTL-SDR Offset Tuning Mode
[key=offset_tune, default=false, type=bool]
* I/Q Swap - RTL-SDR I/Q Swap Mode
[key=iq_swap, default=false, type=bool]
* Digital AGC - RTL-SDR digital AGC Mode
[key=digital_agc, default=false, type=bool]
* Bias Tee - RTL-SDR Blog V.3 Bias-Tee Mode
[key=biastee, default=false, type=bool]


– RX Channel 0

Full-duplex: NO
Supports AGC: YES
Stream formats: CS8, CS16, CF32
Native format: CS8 [full-scale=128]
Stream args:
* Buffer Size - Number of bytes per buffer, multiples of 512 only.
[key=bufflen, units=bytes, default=262144, type=int]
* Ring buffers - Number of buffers in the ring.
[key=buffers, units=buffers, default=15, type=int]
* Async buffers - Number of async usb buffers (advanced).
[key=asyncBuffs, units=buffers, default=0, type=int]
Antennas: RX
Full gain range: [0, 49.6] dB
TUNER gain range: [0, 49.6] dB
Full freq range: [23.999, 1764] MHz
RF freq range: [24, 1764] MHz
CORR freq range: [-0.001, 0.001] MHz
Sample rates: 0.25, 1.024, 1.536, 1.792, 1.92, 2.048, 2.16, 2.56, 2.88, 3.2 MSps
Filter bandwidths: [0, 8] MHz

root@raspberrypi:/home/pi#

This should be driver=rtlsdr

If this doesn’t solve the issues you have, re-post any logs.

For example now you have this error:

This says that the selected sample rate isn’t supported, however by using the right sdr by changing the value above, this sample rate issue may be solved.

A lot of thank’s for your reply.

Changed to driver=rtlsdr but problem continues:

------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.8.1”,
“satnogs-client-ansible”: “202209101521”,
“satnogs-flowgraphs”: “1.4-1”,
“gr-satnogs”: “2.3.3.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14”,
“satnogs-config”: “0.13.2”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2022-12-19T21:43:37.398481+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 11 (bullseye)”,
“RELEASE”: “11”,
“CODENAME”: “bullseye”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.103-v7+”,
“version”: “#1529 SMP Tue Mar 8 12:21:37 GMT 2022”,
“machine”: “armv7l”
},
“memory”: {
“total”: 968052736,
“available”: 695902208,
“percent”: 28.1,
“used”: 204787712,
“free”: 388710400,
“active”: 255844352,
“inactive”: 261959680,
“buffers”: 40628224,
“cached”: 333926400,
“shared”: 11083776,
“slab”: 36233216
},
“disk”: {
“total”: 61232377856,
“used”: 7889756160,
“free”: 50820653056,
“percent”: 13.4
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “120”,
“satnogs_station_id”: “255”,
“satnogs_station_lat”: “38.2768”,
“satnogs_station_lon”: “-0.6711”
}
}
------------[ copy end ]-------------

can you copy paste the more recent logs from journalctl?

Also set the SATNOGS_RF_GAIN, a good starting point is the value 32.8

1 Like

Solved … I don’t know how, but it has been solved.

A lot of thank’s !!!