I have been having issues with my station, so I systematically checked (and even replaced) my rtl-sdr blog v3, LNA, etc… backed up my config file, flashed the latest image to a microsd card, and then restored the config. built the bias tee software, tested it, ran sudo satnogs-setup, viewed config, all appeared correct, applied it, and then exited.

However, my schedule passed failed. I ran sudo journalctl -f -u satnogs-client.service and noticed a connection error:

satnogs satnogs-client[386]: requests.exceptions.ConnectionError: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /api/jobs/?ground_station=315&lat=28.417091&lon=-80.709246&alt=6 (Caused by NewConnectionError(‘<urllib3.connection.HTTPSConnection object at 0x723b9040>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution’))

I have dnsutils installed on that pi, so I ran nslookup and it resolves just fine:

$ nslookup



Non-authoritative answer: canonical name =




Address: 2a01:4f8:13b:29db::1

any ideas what to try next ?