Recording not stopping

HI Community,

need some advice what might be wrong.
The error condition is as follows:

Recording starts as scheduled and an ogg file is created:
root 1638 1525 1 23:05 ? 00:00:07 oggenc --raw-endianness=0 -r -B 16 -q 4 -C 1 -R 24000 -
root 1640 1525 2 23:05 ? 00:00:18 rtl_fm -M fm -g 40 -f 145825000 -p 52.0 -s 22050

drwxr-xr-x 4 root root 4096 Aug 7 23:05 ./
drwxrwxrwt 5 root root 4096 Aug 7 23:17 …/
drwxr-xr-x 2 root root 4096 Aug 7 23:09 complete/
drwxr-xr-x 2 root root 4096 Aug 7 21:34 incomplete/
-rw-r–r-- 1 root root 3878912 Aug 7 23:17 receiving_satnogs_640_2015-08-07T21-05-39.ogg

for some reason the recording doesnt stop. only killing the supervisor allowed me to stop the rtl_fm and oggenc process.
Does someone have an idea whats causing this?

br Robert

ps: did some attempts, but no job ended as scheduled
ps1: the content is correct in the file

is it possible, that i have to set machine time zone to utc?

somehow this few lines from is suggesting this to me:
while True:
if < end:

what release or checkout of the client are you using? I’ve had this problem in the past but the bug was fixed.

i fetched the 0.2.3 version of the client and used the raspi2 manual to get it operational on my ubuntu dist.
but your indication was right.
my local file of was different to the git version file.
Did a manual copy over to get the new block:
133 def stop(self):
134 “”“Stops the receiver pipelines.”""
135‘Stop receiver’)
136 filename = self.get_output_path(receiving=False)
137 os.rename(, filename)
138 self.producer.kill()
139 self.consumer.kill()
140 self.output.close()
141 os.close(self.pipe[0])
142 os.close(self.pipe[1])

but i wonder what the correct precedure for update is.
this because i used pip install --update satnogs-client and hopped to get the last recent code.

br Robert

Ahh ok yeah that’s it. I wasn’t sure if that fix had made it in before 0.2.3 or not. I’ll poke @johngian about rolling a new release (along with the configurable ppm)

If you want to switch to the Dev tree in the meantime, uninstall the pip version and clone and install by:

python ./ build
sudo python ./ install

If you do go this route I would recommend you set your ppm offset in the satnogsclient/ file first as well.

Filed for this.

1 Like


John was too quick for me and we have this fixed in 0.2.4 now! :smile: please test this for us by upgrading with pip and ensure the bug goes away.

I am flying today but tomorrow I will update the instructions for PPM shift. You should be able to add SATNOGS_PPM_ERROR to your settings to set the ppm shift

As @kb9jhu said I just merged the PPM shift pull request and tagged/pushed v0.2.4 to PyPI.

Thanks @kb9jhu for your contribution :smile:

1 Like