Raspbian image not working

I am trying to get the raspian image up an running following the satnogs guide.


There are a load of problems i am experiencing. First of all i cant install any programs like vim or bmon as the guide says. When i try to do this it just gives me a lot of “failed to fetch” followed by some references to raspbian.raspberrypi. This seems like an internet connection issue since when i try to ping an ip adress i just get “network is unreachable”. I tried connecting to the internet with raspi-config but after finding the network and typing the password, nothing happens.

Can anyone help me getting this up and running? i am using an Rpi 3b+.

You might need to manually add some DNS nameservers

edit the dhcp conf file /etc/dhcpcd.conf and add some external DNS such as Google’s and

Find and edit the line for ‘static domain_name_servers’ and change to something like:

static domain_name_servers=

Then restart dhcpd

sudo systemctl restart dhcpcd.service

Then try your connection again and go from there.

I actually just fixed it. I have absolutely no idea what did it. Something was wrong with my internet connection. Turns out my parents did NOT in fact know what the wifi password was…

1 Like