Raspberry Pi SatNOGS station

I built my Raspberry Pi SatNOGS station as per https:// wiki.satnogs.org/Raspberry_Pi_3.
Not my first RPi project.

I got as far as Configuration where I encountered the following:
~$ touch /boot/ssh response “Cannot touch /boot/ssh Read only system”
~$ edit /boot/wpa_supplicant.conf response “no write permission”.
tried again with sudo, same response.

I was connected to my router via Ethernet and had a IP address.
I edited the /boot/config.txt file on a PC to fix overscan problem. This shouldn’t be an issue.

Of note also
Boot error messages
Failed to start Load/Safe RF Kill Switch Status. Many of these.
Failed to start Hostname Service.
Failed to start Regenerate SSH host keys.
Failed to start Advanced key-value store.

logged in with pi & raspberry
I ran ~$ passwd and got this response “Authentication token manipulation error”

I ran ~$ sudo raspi-config and got these errors

1 Change User Password
There was an error running option 1 Change User Password

2 Network Options N2 Wi-fi Enter SSID
Could not communicate with wpa_supplicant
There was an error running option N2 Wi-fi

4 Localisation Options
I1 Change Locale
There was an error running option I1 Change Locale

I suspect this may be related to the Read only file system, something I have never encountered before and it’s beyond my limited programming experience. I have tried for 2 days to find the problem myself.
Thanks for taking the time to read this and any help is appreciated.
Bob vk2byf

Probably your system mounted the sdcard as read only. You can check this with mount command, to see the options of the mounting of the sdcard.

After your connection in the rpi, sudo raspi-config should have worked fine, not sure what went wrong.

Some general suggestions:

  1. Check the hash of the image to make sure that it was downloaded right.
  2. Flash again the sdcard, put it in rpi (avoiding changing /boot in the system you flashed it) and trying again to set it up with sudo raspi-config
  3. Try with another sdcard (sometimes sdcards are faulty)
1 Like

You do not need to touch “ssh” or edit “wpa_supplicant.conf” once you have gained console access. The SSH server is already enabled. “wpa_supplicant.conf” editing steps are only for getting WiFi configured before boot by editing files on the SD card on your host computer.

I’ve updated the wiki instructions to make this more clear.


Thank you Fredy and Acinonyx

I’m not exactly sure which mount option to use. I don’t want to make it worse.
I checked the hash and both downloads where ok.
I have already flashed the SD card twice. Same results.
I may try with another SD card later if no luck with the mount command.

I couldn’t connect with putty. SSH was enabled. The Pi refused the connection.
As soon as I get some quiet time I’ll have another go with Acinonyx’s updated wiki instructions and report back. Thanks for your help.

I’m still in discovery mode for SatNOGS. What an exciting project. I hope to start contributing soon.


Update Raspian-SatNOGGS-lite.img not working

My 2018-08-03-Raspian-SatNOGGS-lite.img installed itself on the RPi SD card as 2 partitions using the sudo dd command. The boot file system was read only which was why I couldn’t change anything in raspi-config. I fixed this with # mount -o remount rw /. Now I could configure the RPi SD card with raspi-config. Couldn’t connect with Putty on ethernet. “Connection reset by peer”. On reboot, $ mount -v told me the file-sistem was read only again. I remounted it rw again and went on to do the apt-get update and upgrade via the working ethernet connection. It took quite a while. On reboot I got “Kernel panic not syncing attempting to kill init exit code = 0x00007f00” Might be time to learn a LOT more Linux or wait for a more stable release of Raspian-SatNOGGS-lite.img
I’m at a loss to go further on my own.

You do not need to mount or change anything if you can get console access to SatNOGS Raspbian via keyboard or ethernet. Just flash the image on the SD from your Desktop, put the card in a RPi 3 and it will boot. Then follow the Configuration instructions.

Also, AFAIK, raspi-config does not touch the boot partition. A common pitfall is not letting enough time for dd to flush buffers into the SD and pulling the SD just after it exits. You can avoid that by adding conv=fsync option to dd. It will make dd wait for buffers to be flushed before exiting.

hmm - any errors when you write the image? You may want to try writing it with Balena Etcher which will do a verify process after writing the SD card. Reason I ask is that it is not normal for the node to boot up with a read-only filesystem, and this can be indicative of a faulty card.

(also, hi! I just answered your laptop question before seeing this - I understand you’re struggling here, stick with us the raspberry pi truly is the easier course!)


Another update
Thank you all for your contributions to get another novice started on SatNOGS. I am now in the process of doing the satnogs-setup on my Raspberry Pi. Which means I got past all those hurdles mentioned above.

The winning entry for my self inflicted RPi problems came from Acinonyx

Hopefully soon I will have my station on line. I’m getting satisfactory results from home-brew QFH antennas with masthead LNA and rtl-sdr. I have tried many omni antennas. The QFH is the best.
73 and thanks again everyone for your much appreciated help. Bob vk2byf

1 Like