Question on Radio Control

Hello there. I’m here because I’ve run into a wall and need some help or instruction.

I’ve worked through the setup of Gpredict on Windows, and I have radio control sort of working on my Yaesu FT-991A.

By ‘sort of working’ I mean that when I engage the radio control the radio will tune to the receive (downlink) frequency, and when I select “track” the receive frequency “tracks” the doppler correction the program indicates.

What does NOT seem to happen is any required mode change setting the radio to FM, CW or whatever mode that I have selected in the program for the transponder - whatever mode the radio was in when the program takes over via CAT is where it stays unless I manually set the correct mode.

Nor does it appear that the transmit (uplink) split is created so that when the radio is keyed it transmits on the uplink frequency. Keying the radio transmits on the downlink frequency only.

Is this normal? If so then this program probably won’t work for me as I plan on actually working the birds instead of just listening to them. I can live with this if so but it would have saved me many hours of figuring out how to get to where I am now.

If the program should be appropriately setting mode and transmit/receive splits based on the GUI settings then somethings not quite right with my setup, and I can’t sort out what that might be.

Charlie (N4NVD)

Hi Charlie,

Currently, gpredict only controls the frequency and in some cases PTT. The mode has to be set manually.

As for uplink/downlink control, I simply have no idea because I am not familiar with your radio. The gpredict user manual describes the available configurations and you can try to compare that to the capabilities of the radio. Clearly, it is important to select a proper configuration for the radio (half/full duplex, VFO).


I have the same radio and am in the process of building a rotator.

Id be curious to know also. I was thinking of trying to use a remote com port and 3rd party software for the orbit software but haven’t gotten to that stage yet

KA4JWB, would you mind sharing your rigctld command line with me, as well as the interface configuration for your FT-991? I would greatly appreciate it if you could. I know that the answer is somewhere in these two. These can be bewildering to the new operator.

73 de N4NVD

Haven’t gotten to that part yet. Still building my rotator.

Cool, that makes the next task very clear - let’s ask to see if anyone else has it working!

73 de N4NVD

As you’re aware, mine does not work completely but at least I’m able to listen to the birds as they go by, so if you’d like it as a starting point (BUT NOT WORKING FULLY!) here you go:

Command line for rigctld:
rigctld.exe -m 135 -r COM9 -s 9600

very simple - FT-991 is number 135, my com port for CAT is COM9, it’s set to 9600 baud.

Here is the rig interface configuration. I know this isn’t 100% right, but I’m stumped as to how to correct - at least it works for receive:

as I said, it’s a starting point anyway.

73 de N4NVD

You should probably swet the radio into split mode and try

  • PTT status -> Read PTT
  • VFO Upo/Down -> a combination of A and B
  • Disable AOS and LOS signalling (it's a gqrx extension)

Like I have said in my first reply, the Gpredict User Manual contains useful information about setting up and testing; first using rigctl then using rigctld.

I did think of that, but according to the manual and the program tool tips this is a mode for a full duplex radio, and the FT-991A is a half duplex radio. I did turn off the AOS and LOS signalling though.

N4NVD, Im working on the same path. GPredict seems so much easier to use than SATPC32. I found this source that seems to cover your issue.
I just saw your post then found this site so i have not verified it will workd but wanted to share before i moved on good luck.

1 Like

After getting all the moving pieces together i can say that vk4tmz’s blog post works perfectly. Even tho the rig is not full duplex the full duplex settings work since the uplink vfo can be changed while transmitting.

from the blog post and a good note to keep in mind:
Before we move on, one of the little limitation / feature lack of GPredict is when you select the different “transponder” to monitor and have GPredict track it only tracks the up and downlink frequencies. DOES NOT automatically select / change the rig modes for both RX and TX .

To overcome this I created 3 simple commands which I run as needed to changes the modes quickly:

# For Voice
rigctl.exe -m 2 -r localhost:4532 M USB 0 X LSB 0
rigctl.exe -m 2 -r localhost:4532 M FM 0 X FM 0
rigctl.exe -m 2 -r localhost:4532 M USB 0 X USB 0

# For Digital Mode (ie APRS, etc)
rigctl.exe -m 2 -r localhost:4532 M PKTUSB 0 X PKTLSB 0
rigctl.exe -m 2 -r localhost:4532 M PKTFM 0 X PKTFM 0
rigctl.exe -m 2 -r localhost:4532 M PKTUSB 0 X PKTUSB 0

Thanks for the update!

We might add mode setting to the gpredict interface in the future, but first we need to make the radios and rotator interfaces more stable.

1 Like