Problem SDR_TEST

sdr

#1

Hello all,
I have a problem with my rtlsdr key (R2832U and R820T) The rtl_test is not correct (see screenshot). I have the same problem with another key of the same type. When I do a second test the key is no longer recognized.
I turn around…

Thanks for your help

pi@raspberrypi:~ $ rtl_test
Found 1 device(s):
0: , , SN:

Using device 0: Generic RTL2832U OEM
rtlsdr_write_reg failed with -1
Resetting device…
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
…………………………………
Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…
Failed to submit transfer 0!

Library error -5, exiting…
rtlsdr_write_reg failed with -4


#2

Have you tried re-plunging the rtlsdr?


#3

Maybe a faulty USB cable, or a too long USB cable.
For long usb cable it’s better to use 12V power, and then use a LM7805 near the RTLSDR


#4

Thank you for your reply.
A second test tells me that I have no sdr but if I unplug and reconnect, rtl_test gives me the same error as on the screenshot …
F6HDW Jean Claude


#5

Hello jujun,
Thank for your reply.

You are right. the cable is faulty and when I replaced it with another one, the test is ok !!
Thanks a lot for your help.
I finished going around in circles. :star_struck:
F6HDW Jean Claude