Problem adding ground station

While trying to add a ground station, the form at always responds with an error. Filling in each field still results in “Some fields missing on the form”. The Antenna field is read-only for some reason. I tried this with several browsers on Linux and even Edge on Windows 10.

The client software installed ok on the Raspberry Pi 2B, and works up to the point where it wants the ground station.

Thank you,

Fred Jan

Hey @fjkraan !

I just created a new station in dev network without a problem. Have you tried selecting one antenna at least? Do you see a list?

Let me know, so we can guide you through the process. Thanks!

1 Like

Hi @pierros,

Thanks for the reply. Attached is an image just before I press Submit and get the error message. I did select an antenna (without really having one yet). The frequency is still 0.000 MHz and I do not see a way to change that. I also tried adding an Image; same result.

Fred Jan

Were you able to find a solution? I’m trying to add a ground station to dev and get the same error.

No, sorry, I did not find a solution. I tried with several browsers and operating systems, and consider it a server side issue. But it is good to know I am not the only one having the problem :-).

Fred Jan

We are unable to reproduce the error on our side (I 've been trying with a combination of browsers and OSes)

@comzeradd or @johngian Any ideas?

Just now I succeeded in creating a groundstation on dev with a VHF antenna (otherwise the same data as above), but cannot reproduce it :-(. The frequency was ok in the overview.

Fred Jan

Tried it again with Firefox and Edge on Windows 10.

This problem is when the altitude has a decimal value.

It happens when you try to edit the station as well with a non-integer altitude value. I think the following diagram from the overview shows where the potential error might be. Adding input validation and feedback might be a good step in resolving this issue properly.

In network/base/ line 46, the following is resulting in the request message yielding an error:

alt = models.PositiveIntegerField(help_text=‘In meters above ground’)

Indeed, an integer altitude does the trick. Creating a ground station works now. Thanks!

Greetings and happy 2016,

Fred Jan

That was it. I was able to add a ground station now.

Nice catch @blackbird ! Please feel free to submit a patch (or just open an issue) so we can track this :smile: for fixing.