Observation 1408137: KKS-1 (33499) CW Morse Issues, Question, Colon Fix

Regarding Observation 1408137

CW is not decoded well and I understand it is not binary with a checksum, etc. Even after filtering and amplifying, I’ve tried local decoder multimon-ng which is worse; the best decoder https://morsecode.world/international/decoder/
even has issues with weak or noisy signals.

I had to manually decode a couple words for this observation.

A. My process for manually decoding in audacity.

  1. Open and select a small quiet portion of noise and choose Effect: Noise Reduction, press get noise profile.
  2. Select all and get to the same menu: Effect: Noise Reduction, with the following settings and apply.
  3. Select all and choose Effect: Amplify, which settings as default, loudest as possible (with no clipping).
    Then one can zoom in and see the characters easily:
  4. I create a new text document, first copying the ogg file name. (data_ at the start) I note the ending time of where the pattern ended and add those minutes and seconds to the timestamp.
  5. Save the file(s), remove .txt extension and scp them to the ground station tmp dir, etc.
  6. Doing another noise reduction can clean up the signal even more sometimes.
    It’s an opportunity to learn Morse.

B. Modify CW profile globally for my station, or for my station, per transmitter?
As my station is weaker, it seems the gain is too low on the satnogs decoder in general. Is there a way that I can modify my local station’s profile or settings for per-sat-transmitter instance, or for my station globally CW decoder settings, to do the two steps I do manually in audacity? I already have RF gain maxed and an LNA introduces more noise. I’m sure that other FSK signals could also be decoded with the same two steps, noise reduction and gain.

C. Support colon for KKS-1 CW
KKS-1 uses the colon character but our settings do not include it, looking at other observations with strong signals; colon is - - - . . . but is decoded as the nearest pattern 8( - - - . . ). If one can point me to the per-transmitter instance profile settings code area I will try to fix it. The Example wav file can be used to test a fix:
09821800 should be

Maybe there is an existing issue to add colon and other characters globally to the base CW decoder?


1 Like