Not the Full 12 volts, Steppers not working

I am building a SatNOGS rotator and it is basically done except for the wire running and the skinning of the unit. I am currently doing testing to make sure everything works. I am running the v2.4 board with a SparkFun Pro Mini (5v model) and Pololu DRV8825 stepper drivers. I did the pre-flight check and I am getting 11.95v at C9 (which says I should get 12v). I figured there was voltage drop and that it was fine. I plugged the Pro Mini in and that powered up. Next I test 5v which was good. The steppers are getting 11.95v, although I sometimes get some odd readings on the right driver location (even more so with the vref when setting the pot for the steppers). The end stops are wired up in NC mode.

The motors wouldn’t turn most of the time (sometimes they did). I though it was due to the code being for 1/8 step, so I changed it for full step and it worked once (although I needed to adjust the end stop). After that, the steppers wouldn’t work correctly. I eventually set the jumpers for 1/8 step and reset the code back to 1/8. Still not functioning correctly. I am worried the voltage might be too low, but I am not sure why the voltage is low. I check the resisters for the voltage divider (which I think controls what the output voltage is), and that all seems good. Off the chip, I am getting 11.95v out (48v into the chip) on pin 8.

Does anyone have any thoughts on what the issue could be? Is 11.95v normal for the v2.4 board or do I have a possible problem somewhere? Everything else seems to be working except the steppers.

6 threads on the same subject, please refrain from creating a ton of threads, it gets very hard for any discussion to be useable.
The lack of answers is probably because it is a bit rare topic here, it has more in common with the 3d printer scene.

I have used DRV8825 a bit, they will happily work on 12V supply. a voltage drop of 50mV is nothing.
The driver does not work in the same way the old darlington drivers did, so measuring voltage means very little, especially when using a DMM. They work in PWM mode and switch for higher efficiency and regulate on current.
You also mention 48V ? This is way out of spec and will likely toast the driver. 12V and 24V is very common.

Regarding the pulses, the only difference is how many pulses the controller has to create for a whole step. If this is wrong, the only consequence is the motors running faster or slower than intended.
There is however a limit, steppers cannot run fast, if pushed they stall and squeal.

Basic questions:
Does the drivers hold the stepper when standing still, can you easily turn it by hand ?
Is the steppers 4 wire or 6 ?
Are both windings hooked up properly ?
Have you tried configuring everything for full step to make it easier to debug ?

Thank you for the reply. If you could post the threads you mentioned, that would be helpful. When I do a search for “stepper”, I have only seen people having code issues, noise issues, are using a Arduino CNC Shield board for the steppers, or never solved the issue and went back to v1.2 board. I did not see any that talk similar to the issues I am having with a resolution.
I am happy to report, I might have figured the issue out. It seems the order in which the wires are put in matters (something that has not been talked about on this forum and I didn’t find much information on through Google, all it seems is if you found the correct wire pairs you were good). It wasn’t an issue of mixing the pairs, but the order (A vs B) they need to go in. I figured this out when a set of steppers arrived that were already wired for a control system.

Onto the DRV8825, again any post I found on this forum about the DRV8825 were with the Arduino and CNC Shield board. Nothing related to the SatNOGS Controller Board of any version. I did readjust the DRV8825 to be close to 1A total (vref was about 400mv). The board in M1 spot though would jump between 700mv and 400mv while I was trying to set it up. It is specific to that spot as swapping the boards has the one in that spot have the same issue. After the wire issue, I was able to make it move for homing. I sent “AZ10 EL00\n” and it move the AZ (which is M1). After that, the motor stopped working. I reset the board and it still would not respond. I checked the voltage of the vref for M1 DRV8825 and it was show over 2v. While I would also think this is a bad board, swapping them yields the same result (and it shows the 400mv vref on M2).

As for the 48v, this is the input to the board (which is what is called out in all of the documents). It goes through a TPS54360DDA chip (U3) and it should bring it down to 12v (which I noted shows 11.95v when I test it). At no point did the driver get 48v (I should have clarified that it was U3 I was referring to when I said 48v to the chip, my mistake).

Now for the questions:
-Yes, the steppers hold even when they wouldn’t move to home. No I could not turn it by hand easily.
-It is 4 wire.
-That seems to have been the issue, although there isn’t much information about what is the “proper hookup” for the steppers. Some manufactures use a different color cable and the order does matter (again, something that I did not find much information on outside of making sure you have the correct pairs).
-Yes, everything was configured for full step to start with (on the board at least). If you are asking about the Firmware, I did not change the settings within the firmware (which seemed to be basing the information on 1/8 step). I did change it to be closer to full step and it did move, but stopped after that (I mentioned this in another post in software, but have not gotten any replies yet).

At this point, I am not sure why the DRV8825 vref is showing 2v when it should be 400mv. Could this be an indicator of a bad Cap (C14, 100u for M1)? Or could this be an issue coming from the Arduino?

I swapped them around again, and now everything seems to be functioning correctly (previous swaps did not resolve the issue). I think the main issue was the wire sequence for the motors that seemed to have mainly been my issue. I am not sure why the one driver would have a high vref though, but it hasn’t appeared again after some more testing.

I did adjust the firmware for full step (removed the 0 ohm resisters to set it to 1/8 step). With the default settings in the firmware (for 1/8 step) and running full step caused some interesting results. The Elevation seemed to work correctly regardless. The Azimuth though had some interesting homing issues. The movement seemed normal, but when it hit to limit switch the motor ramped up (stalling), and started winding down (causing it to rotate a little). It would then high speed move back over shooting the home switch and setting 0 not at the limit switch. Switching the firmware to be full step resolved that issue.

I used the settings mentioned in A new version of 5.18 geared nema rotator - #3 by iz5rzr for the full step (which is speed 300 step/s, acceleration 100 step/s^2, and SPR 200L, I also set the microstep to 1 even though I don’t think it is used in the firmware). This corrected the Azimuth homing issue.

Sometimes I just need to post about the issue and I soon find the solution, or information provided helps resolve the issue. Like I mentioned, a set of steppers that had just arrived yesterday really help figure out the main issue with the wiring. I had planned to use the new steppers, but the holding torque is a little low (listed as 76 compared to the ones already installed from STEPPERONLINE (which is listed as 92 This was interesting as the newer ones are sold by OpenBuild which have builds for DIY CNC machines.