Newbie with New Station 3218 - blank waterfalls

Hi all-
Setting up a new station 3218.

Antenna: 2M EZ Lindenblad (1.5 meters above the ground) from AA2TX in the ARRL satellite handbook
Rig: No LNA at present with 30M of RG59 connected to an RTL-SDR v3 running on a RPi3

Software: install went fine, config was a bit confusing as some of the parameters on SatNOGS Client Setup - SatNOGS Wiki didn’t match the config app.

As a side test I connected the coax from the antenna to a Yaesu FT-60 and listened to good audio during a NOAA 9 pass.

Running systemctl status satnogs-client I get:

bwitte@raspberrypi:~ $ systemctl status satnogs-client
● satnogs-client.service - SatNOGS client
Loaded: loaded (/etc/systemd/system/satnogs-client.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2023-08-30 02:02:05 UTC; 1min 36s ago
Main PID: 456 (satnogs-client)
Tasks: 3 (limit: 1595)
CPU: 10.471s
CGroup: /system.slice/satnogs-client.service
└─456 /var/lib/satnogs/bin/python /var/lib/satnogs/bin/satnogs-client

Aug 30 02:02:05 raspberrypi systemd[1]: Started SatNOGS client.

For observation 8093886 I see

bwitte@raspberrypi:~ $ systemctl status satnogs-client
● satnogs-client.service - SatNOGS client
Loaded: loaded (/etc/systemd/system/satnogs-client.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2023-08-30 02:02:05 UTC; 33min ago
Main PID: 456 (satnogs-client)
Tasks: 5 (limit: 1595)
CPU: 15min 10.272s
CGroup: /system.slice/satnogs-client.service
└─456 /var/lib/satnogs/bin/python /var/lib/satnogs/bin/satnogs-client

Aug 30 02:26:45 raspberrypi satnogs-client[456]: rig_init: rig does not have rx_range!!
Aug 30 02:26:45 raspberrypi satnogs-client[456]: network_open: hoststr=, portstr=4532
Aug 30 02:26:54 raspberrypi satnogs-client[706]: Found Rafael Micro R820T tuner
Aug 30 02:26:55 raspberrypi satnogs-client[706]: [INFO] Opening Generic RTL2832U OEM :: 00000001…
Aug 30 02:26:55 raspberrypi satnogs-client[706]: Found Rafael Micro R820T tuner
Aug 30 02:26:55 raspberrypi satnogs-client[706]: [R82XX] PLL not locked!
Aug 30 02:26:55 raspberrypi satnogs-client[706]: [INFO] Using format CF32.
Aug 30 02:26:56 raspberrypi satnogs-client[706]: Allocating 15 zero-copy buffers
Aug 30 02:34:48 raspberrypi satnogs-client[706]: OsO
Aug 30 02:34:48 raspberrypi satnogs-client[456]: netrigctl_close: done status=Command completed successfully

Stupid question: How do I set the rx range?

Gain Mode = Settings Field (same blank with “Overall”)
Gain = 32.8

Thanks in advance for any help
KL4TQ Bill

Looking at obs 8088287 the signal is there, but very weak.

Has the antenna been swept and checked that it works like it is supposed ?
Is the cable and all connectors ok ? DC measurement acceptable, open/short.
Any connectors and adapters should be kept down to a minimum, as they’re a source of faults and losses.
30m RG59 is theoretically 6dB loss, that length is a bit much for VHF on a ~6mm coax. The rtl-sdr and antenna is probably 50ohm so I would not recommend using 75ohm coax.
If you use a LNA at the antenna feedpoint the cable losses would not be a problem, do not place it at the receiver.


Allright, there’s hope (:
I try to stay away from RG58, main reason being there’s a lot of cables produced that is named that and nowhere close to the specs.
If you find one that is decent coverage (tinned)copper shielded you are lucky, most of the ones I find these days are loosely and sparsely covered shield, sometimes with foil under it. The worst being the ones that is not solderable :smiley:
Filtered mast preamps are a safe bet, the more naked LNA blocks out there do work but are sensitive to strong transmitters close by like ~100MHz FM etc.

1 Like

Additionally some FM and AM filtering ahead of the LNA (or just RTL-SDR if not using an LNA) wouldn’t hurt.

1 Like

Added an LNA on the mast (Nooelec LANA). Checked antenna is connected to “input”, feed to SDR is “output”, little LED power light is illuminated. Observations still show blank waterfall.

Next steps:
Rechecking continuity.
I’ll test the SDR-RTL on a laptop and verify it is working.
I have an SDRplay RSPdx unit - is there a config setting for that receiver?

Any other ideas? Any setup/config settings I should look at? (gain?, freq range?) I get the rig_init rxrange error, but I see in postings that that’s ignorable).

New observation tests

Hi Bwitte,

Another way to test your RPi/RTL-SDR hardware is to grab another micro SD card and put a copy of PiSDR on it. I use that method when setting up SatNOGS stations (mainly to find the optimum gain) but it tests out your hardware fairly easily without upsetting your SatNOGS SD card.

PiSDR has a Desktop GUI and has heaps of ham radio software including GQRX. It does need a display, keyboard and mouse – just temporarily.

Once you configure the device GQRX works out of the box with RTL-SDR’s, including turning on the biast. Just Scan for devices……Then select the RTL device and set the Device String to ‘rtl=0’ or ‘rtl=0,biast=1’ to turn on the Bias-Tee.

PiSDR and GQRX will also work with RSPdx’s but it has a quirk. The RSPdx has switchable hardware filters and you need to get them right.

The GQRX Sample Rate value sets the displayed bandwidth and the Bandwidth value sets the switchable RF Bandwidth of the signal within the display. The SDRPlay sample rates only partially match the RF Bandwidths. Most people would probably set the RF Bandwidth = Sample Rate (aka display bandwidth) or leave it at 0.0MHz as I did initially. This defaults to 200kHz of RF Bandwidth. If you set the Sample Rate = 2000 kHz then set the Bandwidth = 1536kHz (ie next lowest value) and you should be right.

SDRPlay Valid Sample Rates (ksps): 62.5, 96, 125, 250, 384, 500, 768, 1000, 2000, 3000, 4000, 5000, 6000, 7000, 8000, 9000, 10000

SDRPlay Valid RF Bandwidths (kHz): 200 300 600 1536 5000, 6000, 7000, 8000

Hope this helps debug your hardware.

John - VK4JBE

Hi Bill,

Your satnogs-client config looks fine.

My guess is a bad cable/connector due to poor ground. I’d take the antenna down so you can work with it with really short cables using SDR# software – toggle the LNA on and off – does the noise floor jump? Trying tuning in NOAA weather radio in the MHz range (continuous broadcasts) and start working each connection from the SDR → LNA → antenna.


Hey John-
Creating a PiSDR instance and running it on the same hardware was a brilliant idea. Brought everything inside and connected the rtl-sdr directly to the antenna I had a good signal from a local FM broadcast station. Adding bits of the signal path in I found a couple of sma connectors which were touchy. No single bad connection but I built back the antenna, LNA, feedline, & connectors still receiving a good signal from the broadcast station. We’ll see if that works – GQRX was a great testing tool.
Bill KL4TQ

1 Like

Thanks Scott,
A combination of your suggestion to check the parts of the system and John’s suggestion of GQRX worked great.
Bill KL4TQ



Glad that worked out. I think the PiSDR package is an extremely useful package. I hope Luigi Cruz and his fellow maintainers continue to update it.

The other thing I wish is that the SatNOGS Client package was as easy to get going as PiSDR. I recently updated my SatNOGS station and worked through all the issues and documented the fixes for them. If you do the fixes first then the install flows very easily. I am always surprised that first-timers and non-linux users can get a SatNOGS station up and running. It took me ages the first time. Now I can do it in about 1-2 hours including download time.

I have been thinking about how I could contribute to the SatNOGS Wiki to improve things. The Omnidirectional Howto section of the Wiki is the best place to start but it needs a few improvements as things have changed over time. One of the improvements is to use PiSDR instead of SoapySDRServer + CubicSDR to get the RF gains. Others include fixing the EXPSIGKEY error in the Ansible Release (or at least documenting properly how to fix it). There are some other confusing things like the “Kernel Needs Updating” error and the way to get ‘rtl_biast’ working. When you know how to fix them they are simple.

I will continue my work documenting what I think needs changing and hope that I can make things better if I can.

Glad to help.

John - VK4JBE