New station went offline after unwanted update

Hello everybody,

two days ago i set up my satnogs station, # 2136. Everything went fine, station went online immediately after installation process, i scheduled several passes that came out ok. So, really a good start, considering that I’ve never used a Raspberry Pi before and I have no knowledge of Linux environment.

Today i wanted to change the RF gain to test with other values, in the satnogs-setup main window, after changing the gain value, i mistakenly hit the ‘Update’ instead of the ‘Apply’ selection. Realising the mistake, I quit (ctrl-C) the ‘Update’ session and did the ‘Apply’. From the dashboard I soon realised the station went offline after that.

So, i did a full ‘Update’, that took a long while, during the process i was asked to confirm few step and i did, at the end i performed the ‘Apply’ again (plus rebooting), but nothing happened. Station is offine.
If I try to ‘Update’ again, nothing is done because I’m told that ‘the repository didn’t change’ and i’m back at the satnogs-setup main window.
If I run the scheduler I get the following situation:

pi@raspberrypi:~ $ journalctl -f -u satnogs-client.service
– Logs begin at Sat 2021-04-03 20:33:22 UTC. –
Apr 03 20:38:34 raspberrypi satnogs-client[333]: satnogsclient.scheduler.tasks - ERROR - 401 Client Error: Unauthorized for url: https://network.satnogs.org/api/jobs/?ground_station=2136&lat=44.988234&lon=9.124798&alt=177

Honestly, i’m really frustrated because I don’t know what to do more. If anyone can help me.
Thanks

Maurizio iu2jwg

Hello @morinmau !

Sorry to hear your trouble. Can you please post here the results of the menu “Advanced >> Support” so we can help you better? Thanks!

Hello pierros,

here it is:

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.4”,
“satnogs-client-ansible”: “202012231828”,
“satnogs-flowgraphs”: “1.3-1”,
“gr-satnogs”: “2.2.0.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14satnogs2”,
“satnogs-config”: “0.11”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2021-04-03T21:17:38.241726+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.17-v7+”,
“version”: “#1403 SMP Mon Feb 22 11:29:51 GMT 2021”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 969105408,
“available”: 800751616,
“percent”: 17.4,
“used”: 101711872,
“free”: 619347968,
“active”: 156770304,
“inactive”: 130383872,
“buffers”: 32038912,
“cached”: 216006656,
“shared”: 6504448,
“slab”: 42496000
},
“disk”: {
“total”: 31172087808,
“used”: 3535900672,
“free”: 26315218944,
“percent”: 11.8
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_post_observation_script”: “/home/pi/rtl_biast/build/src/rtl_biast -b 0”,
“satnogs_pre_observation_script”: “/home/pi/rtl_biast/build/src/rtl_biast -b 1”,
“satnogs_rf_gain”: “32.6”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “177”,
“satnogs_station_id”: “2136”,
“satnogs_station_lat”: “44.988234”,
“satnogs_station_lon”: “9.124798”
}
}
------------[ copy end ]-------------

ERROR - 401 Client Error: Unauthorized for url:

Hi Maurizio,

Double check your station’s API token just in case that somehow got changed/corrupted.

Also, enable DEBUG level logging if you haven’t done so already
sudo satnogs-setup and then goto Advanced --> Debugging -->SATNOGS_ LOG_LEVEL

set this to DEBUG (I think this is case sensitive ) and then apply the settings.

Now you should have more verbose logging in /var/log/syslog for satnogs-client

tail -100 /var/log/syslog | grep satnogs-client

Search through the fresh logs for error messages and post them here.

PS don’t forget to turn off DEBUG logging when you are done troubleshooting!

1 Like

Hello ! thanks for your suggestions. Yesterday i re-installed everything from scratch and the station is working well. I’ve scheduled many passes, in the process of analysing them and i think in a short while i’ll leave the testing mode.

73 Maurizio iu2jwg

3 Likes