New setup help no waterfall

Hi, all I have installed satnogs on a raspberry pi 3B using a RTL-SDR v3 dongle I am having a problem with it not getting any date no audio no waterfall here is the log

pi@raspberrypi:~ $ journalctl -f -u satnogs-client.service
-- Logs begin at Tue 2020-03-31 15:07:09 UTC. --
Mar 31 15:20:23 raspberrypi systemd[1]: Started SatNOGS client.
Mar 31 15:23:42 raspberrypi systemd[1]: Stopping SatNOGS client...
Mar 31 15:23:42 raspberrypi systemd[1]: satnogs-client.service: Main process exited, code=killed, status=15/TERM
Mar 31 15:23:42 raspberrypi systemd[1]: satnogs-client.service: Succeeded.
Mar 31 15:23:42 raspberrypi systemd[1]: Stopped SatNOGS client.
Mar 31 15:23:42 raspberrypi systemd[1]: Started SatNOGS client.
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: rot_init called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: dummy: _init called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: rot_register (1)
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: rot_register (2)
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: dummy_rot_init called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: rot_open called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: dummy_rot_open called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: rot_get_position called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: dummy_rot_get_position called
Mar 31 15:43:21 raspberrypi satnogs-client[6398]: rot_set_position called
Mar 31 15:43:27 raspberrypi satnogs-client[6398]: [INFO] [UHD] linux; GNU C++ version 8.3.0; Boost_106700; UHD_3.15.0.0-2
Mar 31 15:43:27 raspberrypi satnogs-client[6398]: Found Rafael Micro R820T tuner
Mar 31 15:43:27 raspberrypi satnogs-client[6398]: Traceback (most recent call last):
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:   File "/usr/bin/satnogs_fsk_ax25.py", line 491, in <module>
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:     main()
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:   File "/usr/bin/satnogs_fsk_ax25.py", line 476, in main
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:     tb = top_block_cls(antenna=options.antenna, baudrate=options.baudrate, bb_freq=options.bb_freq, bw=options.bw, dc_removal=options.dc_removal, decoded_data_file_path=options.decoded_data_file_path, dev_args=options.dev_args, doppler_correction_per_sec=options.doppler_correction_per_sec, enable_iq_dump=options.enable_iq_dump, file_path=options.file_path, gain=options.gain, gain_mode=options.gain_mode, iq_file_path=options.iq_file_path, lo_offset=options.lo_offset, other_settings=options.other_settings, ppm=options.ppm, rigctl_port=options.rigctl_port, rx_freq=options.rx_freq, samp_rate_rx=options.samp_rate_rx, soapy_rx_device=options.soapy_rx_device, stream_args=options.stream_args, tune_args=options.tune_args, udp_IP=options.udp_IP, udp_port=options.udp_port, waterfall_file_path=options.waterfall_file_path)
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:   File "/usr/bin/satnogs_fsk_ax25.py", line 92, in __init__
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:     tune_args, settings, samp_rate_rx, "fc32")
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:   File "/usr/lib/python3/dist-packages/soapy/soapy_swig.py", line 166, in make
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:     return _soapy_swig.source_make(nchan, device, dev_args, stream_args, tune_args, other_settings, sampling_rate, type)
Mar 31 15:43:27 raspberrypi satnogs-client[6398]: RuntimeError: soapy::source: Unsupported sample rate.  Rate must be in the range [8000.000000, 8000.000000] [16000.000000, 16000.000000] [22050.000000, 22050.000000] [32000.000000, 32000.000000] [44100.000000, 44100.000000] [48000.000000, 48000.000000] [96000.000000, 96000.000000]
Mar 31 15:43:30 raspberrypi satnogs-client[6398]: satnogsclient.observer.observer - ERROR - No waterfall data file found

This is the settings that I have set up

any help would be grateful.

@fixitdaz why did you choose to put rtlsdr in satnogs_soapy_rx_device? Iā€™m asking because the right one is driver=rtlsdr as it is noted at https://wiki.satnogs.org/SatNOGS_Client_Setup. What instructions did you follow and ended up with the rtlsdr value?

yes, I did set it up with driver=rtlsdr to start with and changed it after doing some digging it was a post on here and he had rtlsdr in his settings so I tried it it never made a difference. I have put it back as it should be with the same problem I have the antenna set to RX is that correct

new output from log

pi@raspberrypi:~ $ journalctl -f -u satnogs-client.service
-- Logs begin at Tue 2020-03-31 15:07:09 UTC. --
Mar 31 15:43:27 raspberrypi satnogs-client[6398]:     return _soapy_swig.source_make(nchan, device, dev_args, stream_args, tune_args, other_settings, sampling_rate, type)
Mar 31 15:43:27 raspberrypi satnogs-client[6398]: RuntimeError: soapy::source: Unsupported sample rate.  Rate must be in the range [8000.000000, 8000.000000] [16000.000000, 16000.000000] [22050.000000, 22050.000000] [32000.000000, 32000.000000] [44100.000000, 44100.000000] [48000.000000, 48000.000000] [96000.000000, 96000.000000]
Mar 31 15:43:30 raspberrypi satnogs-client[6398]: satnogsclient.observer.observer - ERROR - No waterfall data file found
Mar 31 16:29:13 raspberrypi satnogs-client[6398]: Assertion 'close_nointr(fd) != -EBADF' failed at ../src/basic/fd-util.c:67, function safe_close(). Aborting.
Mar 31 16:29:17 raspberrypi satnogs-client[6398]: satnogsclient.observer.observer - ERROR - No waterfall data file found
Mar 31 16:35:13 raspberrypi systemd[1]: Stopping SatNOGS client...
Mar 31 16:35:13 raspberrypi systemd[1]: satnogs-client.service: Main process exited, code=killed, status=15/TERM
Mar 31 16:35:13 raspberrypi systemd[1]: satnogs-client.service: Succeeded.
Mar 31 16:35:13 raspberrypi systemd[1]: Stopped SatNOGS client.
Mar 31 16:35:13 raspberrypi systemd[1]: Started SatNOGS client.
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: rot_init called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: dummy: _init called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: rot_register (1)
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: rot_register (2)
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: dummy_rot_init called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: rot_open called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: dummy_rot_open called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: rot_get_position called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: dummy_rot_get_position called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: rot_set_position called
Mar 31 16:41:50 raspberrypi satnogs-client[7842]: dummy_rot_set_position called: 109.73 0.96
Mar 31 16:41:53 raspberrypi satnogs-client[7842]: Found Rafael Micro R820T tuner
Mar 31 16:41:53 raspberrypi satnogs-client[7842]: Found Rafael Micro R820T tuner
Mar 31 16:41:53 raspberrypi satnogs-client[7842]: [R82XX] PLL not locked!
Mar 31 16:41:53 raspberrypi satnogs-client[7842]: [INFO] Using format CF32.
Mar 31 16:42:05 raspberrypi satnogs-client[7842]: /var/lib/satnogs/.gnuradio/prefs/vmcircbuf_default_factory: No such file or directory
Mar 31 16:42:05 raspberrypi satnogs-client[7842]: vmcircbuf_createfilemapping: createfilemapping is not available
Mar 31 16:42:05 raspberrypi satnogs-client[7842]: gr::vmcircbuf_sysv_shm: shmat (2): Invalid argument
Mar 31 16:42:05 raspberrypi satnogs-client[7842]: Allocating 15 zero-copy buffers

ok i think its started working in the sense it up loaded data thanks all

2 Likes