New rapspberry 4 pi install

Hi I’m trying to install sat nogs on a new raspberry pi 4.
I have tryied looking at all the wiki’s, looking at poeples posts & getting no where. I have also down loaded a number of img’s & these didn’t work. The image is what I get at start up.
I don’t have access to linux, so what ever I do needs to be windows based :frowning:

Help please as I leave this site in 24hrs.

Pete vk2pet


1 Like

Hello @vk2pet
Can you please let us know which steps have you followed and what fails from here?

1 Like

Back ground, I have 2 Raspberry pi4 that are doing the same thing.If I put a normal raspberry pi image onto the SD card, it works for both machines. So it’s software related issues.

Steps I have done,

  1. Downloaded a fresh copy of sat nogs from Satnogs wiki, using the link provided by the wiki.
  2. Data integrity verification, I can’t do this on a windows machine. Unless someone knows of a why?
  3. Flashing, I have used both Balena Etcher, raspberry pi imager for windows & windows version for img burner for SD as described in raspberry pi wiki. All had fresh SD.
  4. I can’t get into the Pi as it doesn’t see an IP address. I used a hdmi cable to see the image that I have pictured.
    This is where I’m stuck.



Hi Pete,

Lets see if we can give you some information so you will be able to get further.
I will try to also support your operating system challenge.

The following program can be used to check the file integrity.

Unzip the downloaded file, this will give you the following directory structure:


Now you can check the two files if you like with the above program.

Now unzip the and use the output file 2020-12-27-Raspbian-SatNOGS-lite.img as input for Balena Etcher.

When this is done try to boot from the SD card you just created.


The error message in the first image reads:

start4.elf: is not compatible
This board requires newer software

According to this thread the firmware of your Rasperry Pi 4 is not backward-compatible to the image on the sd card, so that it can’t be booted.

An image with updated firmware&kernel is needed. Unfortunately we do not have such an updated image yet. So, until we were able to provide an updated SatNOGS RaspbianOS Image, I am afraid to tell you that it’ not possible to easily use this Raspberry Pi for SatNOGS.

Of course, a manual installation of all the SatNOGS tools onto a base Raspbian Image would work, but is a quite complicated endeavor.

@Acinonyx @fredy : Please have a look here too. ^


1 Like

Ok, it might be possible to update the image manually, by following this comment.

I can’t test this (no RPi 4 here), but those would be the steps:

  1. Dowload the following files:

  2. Mout the SD card with your PC and copy the downloaded files into the boot partition on the SD card (there will already be older versions of some or all of the files on the card, overwrite them).

  3. Retry booting the Raspberry Pi with the modified SD card.

1 Like

I just installed a Pi 4 and had the exact same problem when I burned from a W 10 machine. I reburned a few times with different SD and got the same result. However, I burned from my Ubuntu machine, and it worked with no problem.

1 Like

Thanks for information @kerel

Lets see if I can mount the image on a loop device and add the files to the image.
I will let you know if I was successful and if so, share the updated image.

Fingers crossed

1 Like

We are getting somewhere.

sudo fdisk -l 2020-12-27-Raspbian-SatNOGS-lite.img 

Disk 2020-12-27-Raspbian-SatNOGS-lite.img: 3.5 GiB, 3758096384 bytes, 7340032 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xdfcd88e4

Device                                Boot  Start     End Sectors  Size Id Type
2020-12-27-Raspbian-SatNOGS-lite.img1        8192  532479  524288  256M  c W95 F
2020-12-27-Raspbian-SatNOGS-lite.img2      532480 7340031 6807552  3.2G 83 Linux

512 X 8192 = 4194304

sudo mount -o loop,rw,offset=4194304 2020-12-27-Raspbian-SatNOGS-lite.img /mnt

Now copy all the downloaded files to /mnt

-rwxr-xr-x  1 root root      145 Dec 27  2020 issue.txt
drwxr-xr-x 24 root root     4096 Apr  5 15:34 ..
-rwxr-xr-x  1 root root  2981160 Apr  5 15:51 start4x.elf
-rwxr-xr-x  1 root root  2228768 Apr  5 15:51 start4.elf
-rwxr-xr-x  1 root root  3722504 Apr  5 15:51 start4db.elf
-rwxr-xr-x  1 root root   793084 Apr  5 15:51 start4cd.elf
-rwxr-xr-x  1 root root     8452 Apr  5 15:51 fixup4x.dat
-rwxr-xr-x  1 root root     8454 Apr  5 15:51 fixup4db.dat
-rwxr-xr-x  1 root root     5446 Apr  5 15:51 fixup4.dat
-rwxr-xr-x  1 root root     3191 Apr  5 15:51 fixup4cd.dat

Check the files and umount the image.
Zip the image and copy it to a location that you can use to give this a try.

The new image can be download ~for a limited time~ via the following link

Please let me know if you where successful so I can remove the file, otherwise there is a chance my ISP will block my IP access due to using to much uplink bandwidth.

The file is now shared on a more permanent location.

1 Like

Well we re half way there. Image is what I get now from doing a sudo satnogs-setup.

Thanks for your help.


Update: router had an issue on that previous pic, now I’m in.

You will see 2 new satnogs in Western Australia, on a very quite site.

Thanks everyone.



Hi everyone,

I would like to thank everyone who put suggestions in & to PE0SAT who rebuilt the install software. The last issue was on my end with the network I using.
The site is a fully remote site, hence I’m now heading home on the aircraft as I write this. This is very quite in the SNR. Looking forward to some great results from that site.
Again thanks heaps tho everyone.