New fresh install - on existent raspian


I want to do a new fresh install on my latest raspian. Q: What do I need? Where are my keys etc. p. p.?

Where can I see an info for fresh install again?

I’m lost…

Is there a reason you’d rather do an install from raspbian over the pi image that we generate?

(if so… its a process of pip install satnogsclient, grab the gr-satnogs deb and install it, and pick your preferred way of managing the client as a service and set that up (systemd w/defaults file, or supervisord w/environment vars, etc).

Hello friends:
My raspbian is being used some time ago and i don’t want begin with a new pi image.
How can i install it in my existing raspbian?
Thank’s a lot.

Tried pip install and:

arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -fno-strict-alias ing -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-secu rity -fPIC -DFREETYPE_BUILD_TYPE=system -DPY_ARRAY_UNIQUE_SYMBOL=MPL_matplotlib_ ft2font_ARRAY_API -DNPY_NO_DEPRECATED_API=NPY_1_7_API_VERSION -D__STDC_FORMAT_MA CROS=1 -I/usr/local/lib/python2.7/dist-packages/numpy/core/include -I/usr/includ e/freetype2 -I/usr/local/include -I/usr/include -I. -I/usr/include/python2.7 -c src/ft2font.cpp -o build/temp.linux-armv7l-2.7/src/ft2font.o

arm-linux-gnueabihf-gcc: error trying to exec ‘cc1plus’: execvp: No existe el fi chero o el directorio

error: command ‘arm-linux-gnueabihf-gcc’ failed with exit status 1

I thinki it is looking for cc1plus
What package has it included?

using last raspbian.

@runahue If I remember correctly, the package “build-essential” should pull in g++ and give you that compiler. As a rule, apt-cache search will help out in this situation. ( However, it really will be a lot simpler to start with the Raspian images…)


I know, but my rasp is being used now with my weather station.
I want install it under my existing raspbian.

In order to install a satnogs station using an existing debian/raspbian, it’s recommended to use ansible as described here:

This will take care of the installation of required dependencies, installs satnogs-client, gr-satnogs, rtl-sdr, etc. and the configuration tool satnogs-setup.

The configuration tool satnogs-setup allows you to configure your station correctly and keep it up-to-date, as described by the wiki page linked above.

If you have further questions, just open a new thread here or chat with us via Matrix/IRC:

Hi kerel. I tried to install with instructions 6 times with and I cannot get playbook to run. Since playbook did not work, satnogs-setup did not exist, according to the error message.

I am not a programmer, so probably cannot follow instructions either.

If anyone can install with full version of Stretch, please comment if you had problems and how you resolved them.

1 Like

Do you have the latest version of Ansible installed?

No, it does not install, nor does playbook, nor does satnogs-setup. Apparently it is not included in the downlink or does not download correctly.

Has anyone successfully installed using the instruction in the wiki with full version of Stretch?

Yes, I’ve installed satnogs using the Ansible guide successfully on two systems: armbian stretch and raspbian jessie (a while back).

Can you elaborate on what “it does not install” mean? Please send what you did and what the printed results were. Maybe we can solve your issue. :slight_smile:
On which system did you try to install latest ansible?

Using Stretch full version. First error is that “playbook” not found.

I will take the gs off line and try again so that I can make some screen shots to post.

Using Stretch Lite with client downloaded from the link in the wiki works great and has been rnning three weeks.

Will post a step-by-step sequence tomorrow.

I have even used the directions on Debian Strech on x86-64

running RPI3a; Fresh flash with latest Rasbian Stretch.

Stretch is updated with:
sudo apt-get update
sudo apt-get upgrade
sudo reboot

sudo apt-get dist-upgrade
sudo reboot

SSH from Windows desktop to RPI.

All looks good. Now will start the install from the wiki.

Will post each step and errors, if any.


$ git clone

Completed with no errors.

$ cd satnogs-client-ansible

completed with no errors

cp -r production.dist production

no errors

must take a break now. Will finish soon.

Next step is:

vi production/inventory/hosts

This is the original file contents:

satnogs ansible_host= ansible_user=pi ansible_ssh_pass=raspberry





I changed first line to:
satnogs ansible_host=192.168,254.1 ansible_user=pi ansible_ssh_pass=raspberry

This is the RPI SSH IP with the default user name and password.

Is this correct? Should I change any other in this file?

Next step

$ ssh youruser@yourtargetsystem true

pi@raspberrypi:~/satnogs-client-ansible $ ssh pi@ true
The authenticity of host ‘ (’ can’t be established.
ECDSA key fingerprint is SHA256:ajEQc1rM545RC34X1ljjR37jKqI/+xwKewNsldnDtiI.
Are you sure you want to continue connecting (yes/no)?

input yes

pi@raspberrypi:~/satnogs-client-ansible $ ssh pi@ true
pi@’s password:

input password

pi@raspberrypi:~/satnogs-client-ansible $

no errors

Next step:

ansible-playbook -i production/inventory -K site.yml

pi@raspberrypi:~/satnogs-client-ansible $ ansible-playbook -i production/inventory -K site.yml
bash: ansible-playbook: command not found
pi@raspberrypi:~/satnogs-client-ansible $

I get the same error each time I install.

Apparently, I am not finishing the following line:

$ vi production/inventory/hosts # Update file with your own target host, user and SSH password

I am not sure that “own target host” is my local RPI.

Maybe I am making a typographical error?

Maybe I have the inventory file wrong?

I seldom use LINUX, and use Windows daily. So I get terms mixed at times.

When I said ‘did not install’, I meant that the function is not found when I run a command that calls that function.