Network is terribly slow

It seems that more and more, it is taking very long to vet my observations. Sometimes a single observation will take over 30 seconds to load the full waterfall. I know this is being worked on, so at this point are there any things that I can do on my end to speed this up?

For example, if I load 30 observations for vetting, generally only 5 waterfalls will completely load. The rest will stall, and any progress made on the downloading of the waterfall seems to get “lost” to the internet. Is there any setting that I can make on my browser to “keep” what is already downloaded (and hopefully continue the download from that point when refresh is clicked)? Any other suggestions?


Seems like Satnogs network is growing, so it may be outgrowing its current hardware or bandwidth capabilities along with the user growth. Could a real solution to this be a network or bandwidth upgrade? Perhaps a funding campaign with a fixed goal would cover the costs to upgrade the infrastructure. It wouldn’t be bad to point out how much funding is needed to keep the operation going for 1 month, 6 months and a full year.

LSF patreon exists and that’s great, but campaigns with clear goals would probably bring in more funds. I’m sure there are those would would prefer to make larger donations once or twice a year, instead of smaller amount every month.

I had no idea there even was a Patreon. Having said that, looks like not many others know about it, either (current take is $8 a month). I prefer straight donations over “subscription” donations, but I’ll look into this.

Can anybody confirm that the link above is legit?

It is legit linked at Libre Space Foundation’s donate page, there are links for Patreon (for regular donations) or Paypal for lump-sum donation.


@K3RLD have you experienced this within the last week? We fixed some issues on 2019-12-21 which should have helped performance…

1 Like

No, it’s still slow. I’m coming up on 15 minutes trying to vet 25 observations. Even after an observation is fully loaded, sometimes just selecting the vet button will result in 10 to 15 seconds of wait time until the vet results are shown.

[edit] I just loaded a single observation. 26 seconds to load the full waterfall.

oof… ok, back to the drawing board. Thanks for reporting.

The worst I can produce is 5s. If you are familiar with developer tools in Firefox or Chrome could you send a screenshot of the Network tab when loading a slow page, along with any errors that come up in the console?

Thanks Roy!

No errors popped up. Here’s the network tab with likely the most pertinent information highlight. This observation also took about 30 seconds to load the waterfall.

Roy can you please while keeping the Network tab open, reload the observation page? Then post the results here. Thanks!

I thought that’s what I did before, but apparently not. See attached.

1 Like

As an update, it has taken roughly 45 minutes of loading, reloading, reloading, etc. to vet 30 observations.

In the last few months, this has been the case for only certain parts of the day. However, lately - it seems that no matter when I try and vet observations, it takes ages to load the waterfalls. I will also add that I have no problem streaming HD movies, or slow loading speeds on any other pages - so I don’t think this is a connection issue on my end.

Is anybody else experiencing slow load speeds?


Ok so its the waterfall image that was slow to transfer… that’s bizarre…

I’ll PM you for more details.

I have experienced the very same thing during certain times of the day, but not right now. However I only had two observations to vet.

Kind regards, 73

Glenn, KJ7SU

FWIW, I’ve been able to vet 50+ tabs loading using “Open all tabs” and they’ve been loading fine. I’m even on a pretty mediocre Internet connection. So it may not be the SatNOGS server itself. It could be your path from your location to the server. You could do a traceroute to to find out more.

Yep, I sent traceroute data to Corey…


New symptom. Now, when the page loading times out - the vet buttons don’t work. I have to reload the page and then the vet works.

Just took 48 seconds to load a single observation. It’s always the waterfall .png holding up the download.

If this continues I will not be able to vet observations anymore (vacation ends today… can’t spend 40 minutes every day vetting observations, unfortunately).

[edit - here’s the traceroute for anybody that’s interested]

traceroute to (, 30 hops max, 60 byte packets
 1  _gateway (  3.855 ms  3.789 ms  3.750 ms
 2  * * *
 3 (  19.991 ms  20.524 ms  20.497 ms
 4  * * *
 5  0.ae2.BR1.PHIL.ALTER.NET (  14.183 ms  17.867 ms 0.ae1.BR1.PHIL.ALTER.NET (  19.023 ms
 6  1-1-2 (  18.687 ms  9.155 ms  7.389 ms
 7  * (  115.709 ms *
 8 (  115.695 ms  115.682 ms  115.631 ms
 9 (  109.575 ms  111.763 ms  108.354 ms
10 (  106.645 ms  104.666 ms  106.239 ms
11 (  122.174 ms  121.886 ms  108.391 ms
12 (  113.082 ms  115.146 ms  119.930 ms
13 (  118.506 ms (  119.904 ms (  118.209 ms
14 (  115.893 ms !X  115.838 ms !X  115.257 ms !X
1 Like lives! Anyhoo.

The traceroute is pretty normal for crossing the ocean. Any chance you could try your workstation on another connection or try another computer at your current connection? I just say this because I haven’t seen the issues you encounter and I vet observations every day. If it was on the server end, I would occassionally see it slow too (I’m in USA too). If you just download an image with wget or similar, is it also slow? You could right click on a waterfall, and wget that URL to see if it is fast or slow.

You could also try using a VPN proxy or similar. Proxies usually slow things down, but if you have a bad route, it may actually speed it up, since the route will be different.

Happy Hacking,


1 Like

Hate to say it, but I have been on vacation as well and have been vetting up a storm.
Done a few hundred and have noticed no slow down at all. Just as snappy as usual (so love those ‘link bombs’ that open 50 tabs at once, what an awesome feature!).
I am in Southern California.

1 Like

I can’t use the link bomb at all, anymore. It will load one waterfall and every single other waterfall will time out.

Just tried on another computer here at my house, and it took 42 seconds to load one observation. I will try again at work tomorrow.

Also, just tried to load the following page (the unvetted observations page):

And it took 10 seconds just to load that!

Here’s a result of a “wget” (26 seconds):

--2020-01-01 17:15:14--
Resolving (, 2a01:4f8:13b:29db::1
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1718689 (1.6M) [image/png]
Saving to: ‘waterfall_1466548_2020-01-01T20-03-28.png’

waterfall_1466548_2020-01-01T20-03 100%[==============================================================>]   1.64M  65.9KB/s    in 26s     

2020-01-01 17:15:41 (64.9 KB/s) - ‘waterfall_1466548_2020-01-01T20-03-28.png’ saved [1718689/1718689]