Need help in satnogs-client

Ok, so i’ve set up my stationary ground station. I’m using 137Mhz - 145Mhz Turnstile antenna. I’ve received images from NOAA 19 and decoded it with WXtoimg. I need to connect my station to the network using the satnogs-client. I don’t have any programming knowledge in python. I’ve read the Satnogs documentation and understood only little about satnogs-client. I was able to install it thu but that’s it i don’t know how to use it to connect my G.S. My O.S is Ubuntu 16.04 LTS. I’m not using RasPi as my client I’m using my Laptop.
my station ID in network-dev is (238) UQU

What to do next?

Hi @lazzyrabbit – looking at the page for your station, it seems that your station has been able to connect to the SatNOGS network. Thus, you should be able to schedule your first observation. Can you give that a try?

If you run into problems, please be sure to include details about what you’re trying to do and the problems you’re running into.

[EDIT: Doh, I’m an idiot and missed the “never seen” banner on the station page. Thanks for catching that, @csete.]

It doesn’t look like the station has been connected to the network, status says “Never seen”.

@lazzyrabbit After installation, some ground station settings need to be configured? Have you done that?

No. I didnt do these settings. i know that i have to download satnogs-client and configure it but i dont know how to do that exactly. I’ve seen some tutorials about installing the satnogs-client but they all suggested that i need raspberry pi. I don’t have a raspberry pi. I’m working from my laptop (Ubuntu 16.04 LTS). @csete

1 Like

I’ve installed satnogsclient on my linux pc. now i need to know how to run it???

$ pip insatll satnogsclient

everything went smoothly and no dependency issues were raised.
but when i try to run satnogsclient

    lazzyrabbit@lazzy-pc:~$ satnogsclient
    satnogsclient: command not found

    lazzyrabbit@lazzy-pc:~$ satnogs
    satnogs: command not found

Creat a .env file with all station’s details like that:

export SATNOGS_API_TOKEN="1234567890qwertyuiopasdfghjklzxcvbnm1234"
export SATNOGS_STATION_LAT="40.662"
export SATNOGS_STATION_LON="23.337"

And then run:
source .env && satnogs-client

@lazzyrabbit have you read our documentation for how to install the client? It is not as simple as pip install, you also need gr-satnogs (expect if you are doing something really custom)

I suggest you follow the standard documentation for RaspberryPi 3 or generally for Ansible assisted client installation.

@lazzyrabbit as @pierros said you can try the ansible way following the instructions for debian.

We are in progress of adding instructions for ubuntu, but you will be probably ok with these for debian.

If you want to go the hard way and install everything from scratch then you can take a look on an old guide for fedora for rpi but you will need to find the ubuntu dependencies for gr-satnogs. However there are several changes from then, so not suggested.

Anyway whatever you choose, It would be more than welcome if you could document your attempt in order to be easier for the next ones who will try to install satnogs in ubuntu. :slight_smile:

1 Like

Hey, everyone:

Attempting to follow the Ansible assisted client installation on Ubuntu 16.04 LTS. However, when running ansible-playbook -i production/inventory -K site.yml -e 'ansible_python_interpreter=/usr/bin/python3' I am getting the following error message:

[DEPRECATION WARNING]: The TRANSFORM_INVALID_GROUP_CHARS settings is set to allow bad characters in 
group names by default, this will change, but still be user configurable on deprecation. This feature 
will be removed in version 2.10. Deprecation warnings can be disabled by setting 
deprecation_warnings=False in ansible.cfg.
[WARNING]: Invalid characters were found in group names but not replaced, use -vvvv to see details
/home/dan/.local/lib/python2.7/site-packages/requests/ RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
  warnings.warn(warning, RequestsDependencyWarning)
Executing playbook site.yml

- satnogs-setups on hosts: satnogs-setups -
Gathering Facts...
Configure needrestart for Raspbian...
Install or remove satnogs-setup system dependencies...
Install Ansible repository keys...
Install Ansible repository...
Install Ansible package...
Get system Python version...
Get virtualenv Python version...
Remove virtualenv of old Python version...
Install or remove PyPI dependencies...
Install satnogs-config...
Configure satnogs-setup...
Set up inventory...
Create host variables directory...
Check if host variables file exists...
Create host variables file...
Create satnogs-setup share directory...
Install satnogs-setup scripts...
[WARNING]: Could not match supplied host pattern, ignoring: satnogs_setups

- satnogs_setups on hosts: satnogs_setups -
  No hosts found!

- satnogs-clients on hosts: satnogs-clients -
Check Ansible version...
Check distribution...
  satnogs failed: {
    "assertion": "dict(, codename=ansible_lsb.codename) in lsb_compatibility", 
    "changed": false, 
    "evaluated_to": false, 
    "msg": "This role does not support Ubuntu xenial."

- Play recap -
  satnogs                    : ok=16   changed=0    unreachable=0    failed=1    rescued=0    ignored=0  

Initially I had tried running the command without -e 'ansible_python_interpreter=/usr/bin/python3', same results.

Is Ubuntu 16.04 LTS not supported? I’m reluctant to follow the Linux Desktop guide since it says it is deprecated/obsolete, although that page does state it works for Ubuntu 16.04…

Any help you could give me would be great, I wouldn’t like to default to an RPi because my whole setup is already working on Ubuntu (GNURadio, GQRX, Gpredict, etc), but I’d like to automate the station with SatNOGS because manual tracking is a pain (haha).

Edit: would totally be willing to writing a guide for this if I am able to install it successfully.

Best wishes,


With the latest updates on client software (satnogs-client, gr-satnogs, satnogs-flowgraphs) I doubt that Ubuntu 16.04 is supported. Maybe the new LTS version is better candidate.

1 Like

Okay, I will look into updating to 18.04 LTS… Or maybe even 20.04 which has just been released. I’ll post here if I succeed.



1 Like

shamika@shamika-HP-Laptop-15-da2xxx:~$ source .env && satnogs-client
Traceback (most recent call last):
File “/home/shamika/.local/bin/satnogs-client”, line 5, in
from satnogsclient.main import main
File “/home/shamika/.local/lib/python3.9/site-packages/satnogsclient/”, line 4, in
from satnogsclient.scheduler.tasks import status_listener, exec_rigctld
File “/home/shamika/.local/lib/python3.9/site-packages/satnogsclient/scheduler/”, line 14, in
from satnogsclient.upsat.large_data_service import downlink
File “/home/shamika/.local/lib/python3.9/site-packages/satnogsclient/upsat/”, line 97
except Exception, e:
SyntaxError: invalid syntax

my debain os is crash
i installed ubuntu
i follow instruction of satnogs-client install on ubuntu
its install succesful but it not running
source .env && satnogs-client
Traceback (most recent call last):
File “/home/shamika/.local/bin/satnogs-client”, line 5, in
from satnogsclient.main import main
File “/home/shamika/.local/lib/python3.9/site-packages/satnogsclient/”, line 4, in
from satnogsclient.scheduler.tasks import status_listener, exec_rigctld
File “/home/shamika/.local/lib/python3.9/site-packages/satnogsclient/scheduler/”, line 14, in
from satnogsclient.upsat.large_data_service import downlink
File “/home/shamika/.local/lib/python3.9/site-packages/satnogsclient/upsat/”, line 97
except Exception, e:
SyntaxError: invalid syntax

how run it
plese sent instuctions or code for run it

Which python version do you have?

Python 3.9.7 (default, Sep 10 2021, 14:59:43)

This obsolete component was removed 4 years ago from the satnogs-client. While this removal is not the cause of the error (potentially the error is caused by a wrong Python version), I strongly recommend to get a fresh installation of all SatNOGS components.

There are the following options:

  • (best) If intend to run on a Raspberry PI, follow this guide to install the station software using a pre-built image
  • (much more complicated) Use a fresh Debian Buster installation and then follow the guide linked in the next alternative
  • (much more complicated) Use a fresh Ubuntu 20.04 LTS installation and follow along those steps (by @PE0SAT, thanks that you compiled this list!)


1 Like

i have alredy downloaded Ubuntu 20.04 LTS

1 Like

Only if you have a lot of Linux and compiling sources experience go for the Ubuntu installation.

If you want to go the save way, use this installation description.


Perhaps that Debian install doc could be copied to the wiki to help with doc fragmentation.