My VHF ID 568 station stopped working


#1

My 568 VHF station stopped working. I tried the usual reboot the RPi check the ID and API Token etc.
Everything appears to be working as normal but after I have scheduled some observations and later I see my list of observation for vetting, I see only a speaker icon and no waterfall icon. I select the observation for vetting but there is no waterfall or audio.

In desperation I downloaded, verified the integrity and flashed a new RPi image on a brand new virgin micro SD card according to https://wiki.satnogs.org/Raspberry_Pi_3 and https://wiki.satnogs.org… and /SatNOGS_Client_Ansible#Updating_SatNOGS_…

Everything went as per the book. I updated & upgraded the RPi. I remembered to “Apply” the changes I made in satnogs.setup.

In the client install setup I noticed running $ cp -r production.dist production then $ vi production/inventory/hosts, I had 10.1.1.66 but my RPi’s WiFi IP is 10.1.1.161 so I changed it to .161

Also $ ansible-playbook -i production/inventory -K site.yml did not work.

It returned ERROR the playbook: site.yml could not be found. (in red)

Running journalctl -u satnogs-client.service showed no errors.

I’m clearly out of my depth here and don’t know how to diagnose this further.
A push in the right direction would be greatly appreciated.
73 Bob vk2byf


#2

More on the above frustrating problem
I ran on the RPi3B+
$ cd /tmp
$ satnogs_fm_demod.py --rx-sdr-device=rtlsdr --rx-freq=444000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat
It found the rtl-sdr and it created the 3 files mentioned

I tested the rtl-sdr with gqrx and it works fine.
I was able to ‘ping’ the network
I added SATNOGS_NETWORK_API_URL https://network.satnogs.org/api/ as this set-up field was empty.
I ran $ less /var/log/supervisor/satnogs-error.log there was no such file.

Everything works normally but there is no waterfall or icon after the observation.

I tried almost everything. I surrender to the experts. I’m convinced it’s software not hardware.
Putty will not allow me to cut and paste. I followed the suggested method, click & drag then paste but it pastes whatever was on the clipboard before. There is no opportunity to copy.

I assume I can reuse the old station ID 568 and the old API with the newly created image SD card?
A push in the right direction would be very much appreciated. I’m not a programmer.
73 Bob


#3

Please check for files present in /tmp/.satnogs/data and /tmp/.satnogs/data/incomplete! If there are files please don’t reboot! If you’re waiting for files to be uploaded to the observations before your reboot: you’re lost, because /tmp is in RAM and this is cleared on a reboot each time!

$ ls -al /tmp/.satnogs/data
$ ls -al /tmp/.satnogs/data/incomplete

There is a special sequence necessary to copy and paste on Windows hosts that I don’t recall, unfortunately!


#4

There are files in ```
$ ls -al /tmp/.satnogs/data

directories in blue no files

satnogs satnogs .
root root …
satnogs satnogs files
satnogs satnogs incomplete

$ ls -al /tmp/.satnogs/data/incomplete
satnogs satnogs .
satnogs satnogs …

Re copy & paste in Putty, I’m running Linux Mint. Gave Windows the flick a long time ago.


#5

lol, alright, ok, didn’t expect that :smiley:
So C&P should be as easy as mark the text with depressing left mouse-button, release, change application and paste with using the third mouse button (often emulated by depressing mb1&mb2 synchronously)


#6

I had files in there earlier when I ran satnogs manually from the /tmp/ directory.
It created a /tmp/audio-out.ogg file, a /waterfall.dat file and a iq.dat file.

No luck with the 3rd mouse button, the wheel.

Thanks for your help, I’ll get back to you in the morning. My wife is demanding my time at the moment.

73 Bob


#7

I scheduled some observations last night and today I ran
$ sudo ls -la /tmp/.satnogs/data
It returned 6 lines like this
-rw-r–r-- 1 satnogs satnogs 4100 May 18 15:52 receiving_waterfall_676539_2019-05-18T15-52-03.dat

One for each scheduled observation but when I go to vet the observation I see a speaker icon, no waterfall icon and when I select the observation for vetting I see no waterfall. Not an empty waterfall but no waterfall at all.
I did have it all working once and then it suddenly stopped.

Thanks for trying to help, 73 Bob vk2byf


#8

Finally figure out how to do a screenshot for the above Putty screen in Linux

image

Bob


#9

Please try the following:

$ python -c "import matplotlib; print(matplotlib.__version__)"

It should return the matplotlib version installed on your RasPi!


#10

First I tried as you have it typed above and I got an error so I left off the _ after the word version and tried again and got this.

image

Thanks for helping Patrick


#11

Ok, you are still having problems with copy and paste I guess!?
Anyway: there are two underscores each!

I’ll have a look at Putty also, maybe I can clarify that issue. If not, try using a simple terminal and ssh to connect to the pi…


#12

I think I have fixed my problem. A typo in my SATNOGS_NETWORK_API_URL address.
ID 568 is back on line. Now I will try to get my UHF system ID-724 working again. Thank you all for your patience an willingness to help a newbi.
Thanks Bob vk2byf