My UHF ID-724 station is off the air

My UHF station 724 is off the air following several failed attempt to upgrade from Raspbian stretch to buster. Both update methods from the wiki page failed so I decide to start from scratch by downloading
artifacts.zip from here https://wiki.satnogs.org/Raspberry_Pi the big blue download button.

After verifying and unzipping I ended up with 2019-09-11-Raspbian-SatNOGS-lite.img (3.4GB) which I burned to an 8GB microSD card using sudo dd if=2019-09-11-Raspbian-SatNOGS-lite.img of=/dev/dsd conv=fsync I also tried with etcher with similar results which varied from No boot at all. Start booting but kernel panic. Booting and ending up with Raspbian buster and able to do sudo raspi-config but satnogs- setup would not run.

In desperation I cloned my ID-568 station SD card which worked but satnogs-setup wouldn’t let me change any of the parameters to configure it as station ID-724

Well I really tried 5 or 6 time to sort this mess out by myself by starting with downloading and religiously following the https://wiki.satnogs.org/Raspberry_Pi instructions. Clearly I’m strictly hardware and will never be a programmer nor do I want to be a programmer.
I guess I’ll just have to wait for the next upgrade to come along and try again. I have run out of ideas.

Thank you, those who have responded to my previous posts.
I thought my 724 UHF station performed reasonably well considering the small home made UHF QFH antenna. 73 Bob vk2byf

@vk2byf there was an issue in the wiki page, if you clicked the image (blue button) then you ended up with the old version (2019-09-11-Raspbian-SatNOGS-lite.img), but the “Download” text was linking to the new one. The error is fixed now in the wiki page, thanks for noting that you hit the button, that helped me to find the issue.

Not sure why the old image wouldn’t boot, it should have boot normally. The kernel issues could be result of corrupted sd-card, or something that went wrong with the writing of the image (which I doubt given the command you ran).

Hm… that’s sounds as something was wrong with the permissions, maybe it was result of the clone, but it is just guess.

My suggestion is to try with the new image and maybe try another sd-card if you have a spare one.

Thanks fredy. I’ll try again and report back soon.
Bob

1 Like

Good news and bad news
The image in the corrected link worked. I now have a lite buster OS installed on the RPi and I can connect to it via SSH & putty. After installing the Satnogs client, when I run this
$ systemctl status satnogs-client

I get something similar to this below from the wiki page

● satnogs-client.service - SatNOGS client
Loaded: loaded (/etc/systemd/system/satnogs-client.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2020-03-04 19:30:56 GMT; 6min ago
Main PID: 6309 (satnogs-client)
Tasks: 11 (limit: 2200)
Memory: 37.9M
CGroup: /system.slice/satnogs-client.service
└─6309 /var/lib/satnogs/bin/python3 /var/lib/satnogs/bin/satnogs-client

Mar 04 19:30:56 raspberrypi systemd[1]: Started SatNOGS client.

With my dates etc. I had no antenna connected to the rtl-sdr

So it would appear to be working however… When doing the satnogs-setup, I only provided the basic information I had before with the old version before the upgrade. When I left the satnogs menu it complained about an incomplete setup
I gave the API key, the station id, rtlsdr, altitude, lat & lon. Is the API key the same for both stations?

When I go to my 724 dashboard i get a warning about being off line (I’m in testing mode) and It won’t let me schedule any Observations for testing.

I have the feeling we are almost there. I may just need to fill in some more boxes in the advanced section but what has to go in which box?

I definitely have internet access as I downloaded lots of data during the build and upgrade.

I must still be missing something but I just can’t see it.

Thank you all for your guidance, Bob

There are several parameters changed or required with the new updated client, please take a look at https://wiki.satnogs.org/SatNOGS_Client_Setup and make sure you have all the necessary parameters filled.

Yes, API key is assigned to user no to stations.

if systemctl status satnogs-client says that the client is running you should see the station either with testing or online status.

There is a new option in Advanced settings which is Support, please copy paste the result here, may it will reveal missing parameters. If you use Putty check this guide how to copy paste.

1 Like

I set SATNOGS_NETWORK_API_URL to https://network.satnogs.org/api/ in the advanced section. I also renamed The basic settings as per the the wiki.

I used to run without rf gain setting so default. Now there is no SATNOGS_RF_GAIN option in Basic. I don’t know what to do in Advanced SATNOGS_GAIN_MODE so I left it alone.

I run a masthead 20db gain LNA so a gain of 10 used to be where the noise floor started to rise but I never set any gains on the old system and it worked just fine with the default or no settings.

I can now schedule observations but I don’t get any icons after the observation time so I must still have something wrong in the Advanced section of the Satnogs configuration. I also notice the rtl-sdr is cold compared to the other 2 sdrs on my RPi stack.

I did manage to get this report. The trick is to press the middle scroll wheel to paste the putty highlighted text into a document or here.

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “3.8.1.0~rc1-2”,
“satnogs-config”: “0.10.1”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: true,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971055104,
“available”: 801050624,
“percent”: 17.5,
“used”: 109502464,
“free”: 680464384,
“active”: 168640512,
“inactive”: 60538880,
“buffers”: 26181632,
“cached”: 154906624,
“shared”: 6533120,
“slab”: 39530496
},
“disk”: {
“total”: 7489372160,
“used”: 3782815744,
“free”: 3354746880,
“percent”: 53.0
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_bb_freq”: “-1”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “30”,
“satnogs_station_id”: “724”,
“satnogs_station_lat”: “-34.85”,
“satnogs_station_lon”: “150.6”
}
}
------------[ copy end ]-------------

Press Enter to continue…

What do you think?

Thanks fredy, 73 bob

1 Like

Except that it seems there are some pending updates, that you can get them by hit update and then apply, I don’t see something wrong, except SATNOGS_BB_FREQ which to be honest I’m not sure what it does, maybe @surligas or @Acinonyx can give us some hint.

This can be found now at Advanced --> Radio --> SATNOGS_RF_GAIN.

As the client is now online and you can schedule, then next step is to check the logs while an observation is running, if something is wrong will throw an error there. To check the logs run:

sudo journalctl -f -u satnogs-client.service

This will give you some lines of the latest logs and will wait for new lines to show them to you, use CTRL + C for exiting. If you want just to check the previous logs just run it without the -f option:

sudo journalctl -u satnogs-client.service

satnogs_bb_freq should be 0, unless you known what you are doing. It is a digital frequency offset that can be performed on the device, if it supported, or on host.

1 Like

Removing the option completely will revert to the default (which is 0).

Thank you all for your input
fredy “pending-updates”: true,
surligas & Acinonyx “satnogs_bb_freq”: “-1”, got rid of the -1,
did update and apply.
I’ll leave SATNOGS_RF_GAIN for now until I see observations.

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1.1-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “3.8.1.0~rc1-2”,
“satnogs-config”: “0.10.1”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971055104,
“available”: 782471168,
“percent”: 19.4,
“used”: 115204096,
“free”: 376025088,
“active”: 406360064,
“inactive”: 93491200,
“buffers”: 43343872,
“cached”: 436482048,
“shared”: 6524928,
“slab”: 73142272
},
“disk”: {
“total”: 7489372160,
“used”: 3764490240,
“free”: 3373072384,
“percent”: 52.7
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “30”,
“satnogs_station_id”: “724”,
“satnogs_station_lat”: “-34.85”,
“satnogs_station_lon”: “150.6”
}
}
------------[ copy end ]-------------

Press Enter to continue…

I’ll schedule some observations in Testing mode and report back

Apr 07 03:22:45 raspberrypi satnogs-client[7019]: Found Rafael Micro R820T tuner
Apr 07 03:22:46 raspberrypi satnogs-client[7019]: Found Rafael Micro R820T tuner
Apr 07 03:22:46 raspberrypi satnogs-client[7019]: [R82XX] PLL not locked!
Apr 07 03:22:46 raspberrypi satnogs-client[7019]: [INFO] Using format CF32.
Apr 07 03:22:59 raspberrypi satnogs-client[7019]: /var/lib/satnogs/.gnuradio/pre fs/vmcircbuf_default_factory: No such file or directory
Apr 07 03:22:59 raspberrypi satnogs-client[7019]: vmcircbuf_createfilemapping: c reatefilemapping is not available
Apr 07 03:22:59 raspberrypi satnogs-client[7019]: gr::vmcircbuf_sysv_shm: shmat (3): Invalid argument
Apr 07 03:22:59 raspberrypi satnogs-client[7019]: Allocating 15 zero-copy buffer s

Is there a problem here? No such file or directory

That’ll happen the first time to flowgraphs run. You shouldn’t see it again.

@vk2byf I’ve just checked the latest observations and it seems that client works fine now! It uploads both waterfall and audio. Now you need to fine-tuning it for better results. :slight_smile:

Thanks fredy. I’ve seen the observation icons but nothing in the waterfall. Might have to add some gain. I’ll experiment and see. Should I put it on line so I can observe others scheduling observations?

I would suggest you keep it in testing while you experiment to get better results. If you want some observations scheduled in your station while in testing let me know and we can add several for each day.

I’ve gone in there and set the gain to 30 what is the correct syntax? I ended up with [30].
I have and will schedule observations for testing but go ahead and schedule for yourself if you want. I’m going for those which have more than 50% green for now until I find the sweet spot.
What time zone are you in? 1hr ahead of UTC?

30 is a good value, with gr-soapy you don’t need to go with specific values for rtl-sdr. Ok I’ll take a look and schedule a couple of observations. My current timezone is +3 UTC.

Ok thanks fredy. Daylight savings started already?