Motors not turning for a pass

Hi. We are setting up a new station. We have a satnogs rotator controller v2. Its a pure satnogs build image_2020-03-04-Raspbian-SatNOGS-lite
If I do: sudo rotctl -m 204 -s 19200 -r /dev/ttyUSB0 -vvvvv
and rotator command: P 020 020 - the motors move ok
I set up a pass [Observation 2225317] in https://network.satnogs.org/observations/ and got the pending screen ok, but at the time of the pass the motors do not move. Any ideas anyone?
After the pass I get:
sudo systemctl status satnogs-client
● satnogs-client.service - SatNOGS client
Loaded: loaded (/etc/systemd/system/satnogs-client.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2020-05-16 15:34:06 CEST; 1h 1min ago
Main PID: 1021 (satnogs-client)
Tasks: 22 (limit: 2200)
Memory: 126.5M
CGroup: /system.slice/satnogs-client.service
└─1021 /var/lib/satnogs/bin/python3 /var/lib/satnogs/bin/satnogs-client

May 16 15:53:23 raspberrypi satnogs-client[1021]: dummy_rot_open called
May 16 15:53:23 raspberrypi satnogs-client[1021]: rot_get_position called
May 16 15:53:23 raspberrypi satnogs-client[1021]: dummy_rot_get_position called
May 16 15:53:23 raspberrypi satnogs-client[1021]: rot_set_position called
May 16 15:53:30 raspberrypi satnogs-client[1021]: Found Rafael Micro R820T tuner
May 16 15:53:31 raspberrypi satnogs-client[1021]: Found Rafael Micro R820T tuner
May 16 15:53:31 raspberrypi satnogs-client[1021]: [R82XX] PLL not locked!
May 16 15:53:31 raspberrypi satnogs-client[1021]: [INFO] Using format CF32.
May 16 15:53:32 raspberrypi satnogs-client[1021]: Allocating 15 zero-copy buffers
May 16 15:58:57 raspberrypi satnogs-client[1021]: 4

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1.2-1”,
“gr-soapy”: “2.1.3-1”,
“gnuradio”: “3.8.1.0~rc1-2”,
“satnogs-config”: “0.10.1”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: true,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971059200,
“available”: 763920384,
“percent”: 21.3,
“used”: 139444224,
“free”: 442736640,
“active”: 237924352,
“inactive”: 213671936,
“buffers”: 30519296,
“cached”: 358359040,
“shared”: 6561792,
“slab”: 56553472
},
“disk”: {
“total”: 29424611328,
“used”: 3774439424,
“free”: 24407347200,
“percent”: 13.4
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “180”,
“satnogs_station_id”: “1312”,
“satnogs_station_lat”: “49.872”,
“satnogs_station_lon”: “8.622”
}
}
------------[ copy end ]-------------

Regards
Mark

Hi @esoc_cyb,

Make sure you have enabled and set up correctly the variables related to rotctld. You will find more details on how to set them up at https://wiki.satnogs.org/SatNOGS_Client_Setup#Advanced_Setup. Don’t forget to apply any changes you do.

PS It seems you have some pending updates, after solving the issue with rotator, please update and apply these changes too.

Thanks very much using satnogs-setup I changed the Advanced, Rotator default option to SATNOGS_ROT_MODEL: ROT_MODEL_EASYCOMM3 which seems to work for the Satnogs Rotator Controller V2 board

1 Like