Motors not turning after software updates

Hi. I have updated the operating system with sudo apt update and then sudo apt upgrade and now have:
uname -a Linux raspberrypi48 5.10.11-v7+ #1399 SMP Thu Jan 28 12:06:05 GMT 2021 armv7l

I used sudo satnogs-setup to update everything there:
Satnogs-client-ansible-202012231828, satnogs-client-1.4, satnogs-flowgraphs-1.3-1

I looked through the instructions on https://wiki.satnogs.org/SatNOGS_Client_Setup#Advanced_Setup
but I do not see a ttyACM0 in my devices folder /dev

The motors no longer turn if I setup a pass on the satnogs web page.

sudo rotctl -m 204 -s 19200 -r /dev/ttyAMA0 -vvvv gives me:
rotctl, Hamlib 3.3
Report bugs to hamlib-developer@lists.sourceforge.net
rotctl Test
rot_init called
initrots3_easycomm called
rot_register (201)
rot_register (202)
rot_register (204)
rot_open called
serial_open called
serial_setup called
Opened rot model 204, ‘EasycommIII’
rig_strstatus called
Backend version: 0.4, Status: Alpha
Rotator command:

but typing in p to get a position gives me :
Rotator command: p
rotctl_parse: input_line: p
rot_get_position called
easycomm_rot_get_position called
easycomm_transaction called: AZ EL

serial_flush called
write_block called
write_block(): TX 7 bytes
0000 41 5a 20 45 4c 20 0a AZ EL .
read_string called
read_string(): RX 2 characters
0000 e2 e2 …
easycomm_transaction read_string: ▒▒
easycomm_rot_get_position got response: ▒▒
easycomm_rot_get_position: unknown response (▒▒)
get_pos: error = Command rejected by the rig

My configuration is:
SATNOGS_SOAPY_RX_DEVICE: driver=rtlsdr
SATNOGS_ANTENNA: RX
SATNOGS_RXSAMP_RATE: 2.048e6
SATNOGS_ELEV: 180
SATNOGS_STATION_ID: 1312
Satnogs installation: SATNOGS_STATION_LAT: 49.872
SATNOGS_STATION_LON: 8.622
Advanced:
network: none
radio:
SATNOGS_RIG_IP Define Hamlib rigctld IP [127.0.0.1]
SATNOGS_RIG_PORT Define Hamlib rigctld port [4532]
SATNOGS_DOPPLER_CORR_PER_SEC
SATNOGS_PPM_ERROR
SATNOGS_LO_OFFSET
SATNOGS_GAIN_MODE
SATNOGS_RF_GAIN [20]
SATNOGS_RX_BANDWIDTH
SATNOGS_ANTENNA [RX] already set in Basics
SATNOGS_SOAPY_RX_DEVIC [driver=rtlsdr] already set in Basics. Apparently not needed in newer software
SATNOGS_RX_SAMP_RATE [2.048e6] already set in basics
SATNOGS_DEV_ARGS
SATNOGS_STREAM_ARGS
SATNOGS_TUNE_ARGS
SATNOGS_OTHER_SETTINGS
SATNOGS_DC_REMOVAL
SATNOGS_BB_FREQ
ENABLE_IQ_DUMP
IQ_DUMP_FILENAME
DISABLE_DECODED_DATA
Rotator:
SATNOGS_ROT_MODEL: ROT_MODEL_EASYCOMM3
SATNOGS_ROT_BAUD: 19200
SATNOGS_ROT_PORT: /dev/ttyAMA0
SATNOGS_ROT_THRESHOLD 4
SATNOGS_ROT_FLIP False
SATNOGS_ROT_FLIP_ANGLE 75
Waterfall
Artifacts
Scripts
Paths
Hamlib:
HAMLIB_UTILS_ROT_ENABLED: True
HAMLIB_UTILS_ROT_OPTS : -m 204 -s 19200 -r /dev/ttyAMA0 -C timeout=200
HAMLIB_UTILS_RIG_DISABLED : False
HAMLIB_UTILS_RIG_OPTS : -T 127.0.0.1 -m 1
SNMP
GPS
Software
Debug

Can anyone see any errors in my settings that is stopping the motors turning?

Incidently if I move the pulley belt so that the position is away from the end stop and power up rotator controller board (V2) the arduino correctly sends the motors to the end stop position.

Regards
Mark

I had a further look and it seems to be to do with a ethernet driver for Port 1 rather than the CP21x driver I need for the USB-TTL interface board that is between the Raspberry Pi and the Satnogs Rotator Controller Board. Not sure how I change this in Satnogs-Setup.

lsusb -t
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
|__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M

Regards
Mark

I had to fix an issue after the upgrade, I’m using a DCU-1 rotator but this may work for you.

I set the SATNOGS_ROT_MODEL to NETROTCTL and SATNOGS_ROT_BAUD (mine matches the DCU-1). In the SATNOGS_ROT_PORT I configured this to send commands to localhost:4533 not the /dev/tty port (mine was /dev/USB0 so not sure if this will work the same for you).

I did the same as you and set the HAMLIB_UTILS_ROT_ENABLE to True which starts the rotctl daemon (I used reboot to stop and start services after applying changes).

Inkedsatnogsconfig_LI

Thanks.
Additional info:
Hardware:
Arduino Pro Mini - ATmega328p
Raspberry Pi 3B+
Raspi-config:
Interface:
Camera-disable,
SSH-enable,
VNC-enable,
SPI-enable,
I2C-enable,
Serial Port–shell-enable, hardware-enable,
1-Wire–disable,
Remote GPIO–disable

I tried your suggested setup changes:
SATNOGS_ROT_MODEL:ROT_MODEL_NETROTCTL
SATNOGS_ROT_BAUD: 4800
SATNOGS_ROT_PORT:localhost:4533
HAMLIB_UTILS_ROT_ENABLED:True
HAMLIB_UTILS_ROT_OPTS :-m 204 -s 4800 -r /dev/ttyAMA0 -C timeout=200
In satnogs-setup I noticed the Hamlib fields have a asterix by them, not sure if this signifies an error or unacceptable value?


Anyway after a reboot still the same - no motor movement under satnogs web control and similar error if I try running Rotator control from the command line.
sudo rotctl -m 204 -s 4800 -r /dev/ttyAMA0 -vvvvv
rotctl, Hamlib 3.3
Report bugs to hamlib-developer@lists.sourceforge.net

rot_init called
initrots3_easycomm called
rot_register (201)
rot_register (202)
rot_register (204)
rot_open called
serial_open called
serial_setup called
Opened rot model 204, ‘EasycommIII’
rig_strstatus called
Backend version: 0.4, Status: Alpha

Rotator command: p
rotctl_parse: input_line: p
rot_get_position called
easycomm_rot_get_position called
easycomm_transaction called: AZ EL

serial_flush called
write_block called
write_block(): TX 7 bytes
0000 41 5a 20 45 4c 20 0a AZ EL .
read_string called
read_string(): Timed out 0.200260 seconds after 0 chars
easycomm_transaction read_string failed with status -5
easycomm_rot_get_position got error: -5
get_pos: error = Communication timed out

The motor control has worked and seemed to stop after the software update but I will also try some hardware checks. Maybe the arduino did not like the cold temperatures, snow ice and rain lately and has got damaged or corrupted despite quite a good double housing.

ok,I see you used 4800 baud whereas you need 19200 on yours, try the 19200 baud and not 4800 as that is what my rotator controller accepts. Don’t forget to reboot after applying changes. The asterix just means you’ve changed the config from the default settings

Hi thanks. I tried with 19200, still the same results.
It seems to be to do with the the raspberry pi not seeing the CP2101 USB-TTL interface board and the Satnogs Rotator Controller Board (V2) behind it. I checked the three voltages on the controller board 19V in, 12V and 5V regulated with a voltmeter they are ok. I checked the 4 wires between the TTL out of the CP2101 board and the input of the Satnogs Controller Board for continuity with a meter and they are ok. So I am still fairly certain its a software problem. As mentioned before if I move the axis away from their end stop the arduino sends them back to their 0 position so the end stop detectors and motor drive logic seems ok.

With no USB devices plugged in if I do lsusb somewhat confusingly the Raspberry Pi shows 4 devices (on Port 1):
lsusb
Bus 001 Device 009: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If I plug in RTL SDR stick I get 5 devices:
lsusb
Bus 001 Device 020: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 001 Device 009: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t shows the RTL stick is on port 3
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 1: Dev 3, If 0, Class=Hub, Driver=hub/3p, 480M
|__ Port 1: Dev 9, If 0, Class=Vendor Specific Class, Driver=lan78xx, 480M
|__ Port 3: Dev 20, If 0, Class=Vendor Specific Class, Driver=, 480M
|__ Port 3: Dev 20, If 1, Class=Vendor Specific Class, Driver=, 480M

If I plug in the CP2101 aswell, lsusb it still only shows 5 devices:
Bus 001 Device 020: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 001 Device 009: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Is there another simple command to talk to the CP2101 and Satnogs Controller Board to test things out?

Regards
Mark