Missing globalstar satellites

Since version 1.3 the globalstar satellites have been missing from the default install. How can I add them? I’ve already tried adding their TLE files but they don’t show up.

I feel pretty dumb that I can’t figure this out.


Hi Berwyn,

In recent versions, under Edit → Preferences → General, select the TLE Update tab. Click on “Add TLE source” and enter http://celestrak.com/NORAD/elements/globalstar.txt


Thanks, Alex. But I already had https://www.celestrak.com/NORAD/elements/globalstar.txt in there.

I just added http://celestrak.com/NORAD/elements/globalstar.txt as you suggest, but it makes no difference. There are still no globalstar satellites listed in the module’s satellite selection:

Try searching by NORAD number… perhaps the names changed and thats why there are no search results?

Nope. That doesn’t help, either.

It just seems like Gpredict is totally ignoring the TLE file I put in.

Incidentally, what does the satellites list look like for one of you when you put in the globalstart tle file? Does it has globalstar satellites listed?


This is very strange… Do you have “Add new satellites to local database” enabled in the preferences?

Ah. Your screenshot clued me in to the problem. I also had the globalstar TLE URL in the proxy field.
The shape of the UI fooled me into thinking that I was supposed to enter my URL in that box and then click (Add TLE source). Of course, it didn’t work that way and I wondered why. But I didn’t clue in to the fact that the URL in the proxy box was actually preventing my TLEs from updating.

Thanks a lot,