It's time to upgrade the software of your stations

Performed these steps again specifically and still having same error.

Dec 19 11:35:36 satnogs1 systemd[359]: satnogs-client.service: Failed to execute command: No such file or directory
Dec 19 11:35:36 satnogs1 systemd[359]: satnogs-client.service: Failed at step EXEC spawning /var/lib/satnogs/bin/satnogs-client: No such file or directory
Dec 19 11:35:36 satnogs1 systemd[1]: satnogs-client.service: Main process exited, code=exited, status=203/EXEC
Dec 19 11:35:36 satnogs1 systemd[1]: satnogs-client.service: Failed with result 'exit-code'.
Dec 19 11:35:36 satnogs1 systemd[1]: satnogs-client.service: Service RestartSec=100ms expired, scheduling restart.
Dec 19 11:35:36 satnogs1 systemd[1]: satnogs-client.service: Scheduled restart job, restart counter is at 5.
Dec 19 11:35:36 satnogs1 systemd[1]: Stopped SatNOGS client.
Dec 19 11:35:36 satnogs1 systemd[1]: satnogs-client.service: Start request repeated too quickly.
Dec 19 11:35:36 satnogs1 systemd[1]: satnogs-client.service: Failed with result 'exit-code'.
Dec 19 11:35:36 satnogs1 systemd[1]: Failed to start SatNOGS client.
pi@satnogs1:~ $ ls -l /var/lib/satnogs/bin/
total 3040
-rw-r--r-- 1 satnogs satnogs    2075 Sep 17 04:08 activate
-rw-r--r-- 1 satnogs satnogs    1017 Sep 17 04:08 activate.csh
-rw-r--r-- 1 satnogs satnogs    2171 Sep 17 04:08 activate.fish
-rw-r--r-- 1 satnogs satnogs    1137 Sep 17 04:08 activate_this.py
-rwxr-xr-x 1 satnogs satnogs     222 Oct 22 00:44 dotenv
-rwxr-xr-x 1 satnogs satnogs     245 Sep 17 04:08 easy_install
-rwxr-xr-x 1 satnogs satnogs     245 Sep 17 04:08 easy_install-2.7
-rwxr-xr-x 1 satnogs satnogs     223 Sep 17 04:08 flask
-rwxr-xr-x 1 satnogs satnogs   35110 Sep 17 04:08 miniterm.py
-rw-r--r-- 1 satnogs satnogs   36151 Sep 17 04:08 miniterm.pyc
-rwxr-xr-x 1 satnogs satnogs     227 Sep 17 04:08 pip
-rwxr-xr-x 1 satnogs satnogs     227 Sep 17 04:08 pip2
-rwxr-xr-x 1 satnogs satnogs     227 Sep 17 04:08 pip2.7
lrwxrwxrwx 1 satnogs satnogs       7 Sep 17 04:07 python -> python2
-rwxr-xr-x 1 satnogs satnogs 2984816 Sep 17 04:07 python2
lrwxrwxrwx 1 satnogs satnogs       7 Sep 17 04:07 python2.7 -> python2
-rwxr-xr-x 1 satnogs satnogs    2334 Sep 17 04:08 python-config
-rwxr-xr-x 1 satnogs satnogs     223 Sep 17 04:08 wheel

Can you paste your configuration (without the API key) as returned by Show dialog?

│ disable_decoded_data: false                                                                                                                                     
│ gpsd_enabled: false                                                                                                                                             
│ hamlib_utils_rig_enabled: false                                                                                                                                 
│ satnogs_api_token: ***snip***                                                                                                     
│ satnogs_dev_args: airspy,bias=1                                                                                                                                 
│ satnogs_rf_gain: 30                                                                                                                                             
│ satnogs_rx_device: airspymini                                                                                                                                   
│ satnogs_station_elev: 1004                                                                                                                                      
│ satnogs_station_id: 1003                                                                                                                                        
│ satnogs_station_lat: ***snip***                                                                                                                                  
│ satnogs_station_lon: ***snip***                                                                                                                                 
│ snmpd_enabled: true     

Have you ever installed satnogs-client using pip on the system?

Potentially. I did test out the satnogs-client when it was in beta before in Ansible but reverted later.

That could be it. Try pip uninstall satnogsclient or/and pip uninstall satnogs-client. Also, does Ansible show any error when you hit Apply?

This didn’t work at all, but if I add /home/pi before the first part, I get this:

2019-12-19 21:51:15,294 - root - INFO - Requesting information for ground station 272
2019-12-19 21:51:16,962 - root - INFO - Ground station information retrieved!
2019-12-19 21:51:16,965 - root - INFO - Updating transmitters and TLEs for station
2019-12-19 21:51:16,967 - root - INFO - Fetching transmitter information from DB.
2019-12-19 21:51:21,043 - root - INFO - Transmitters received!
2019-12-19 21:51:21,110 - root - INFO - Transmitters filtered based on ground station capability.
2019-12-19 21:51:21,112 - root - INFO - Fetching transmitter information from DB.
2019-12-19 21:51:29,119 - root - INFO - Transmitters received!
2019-12-19 21:51:29,185 - root - INFO - Transmitters filtered based on ground station capability.
2019-12-19 21:51:29,187 - root - INFO - Fetching satellite information from DB.
2019-12-19 21:51:30,337 - root - INFO - Satellites received!
2019-12-19 21:51:30,355 - root - INFO - Requesting transmitter success rates.
2019-12-19 21:52:08,321 - root - INFO - Transmitter success rates received!
2019-12-19 21:52:08,323 - root - INFO - Fetch from http://mstl.atl.calpoly.edu/~ops/keps/kepler.txt
2019-12-19 21:52:08,768 - root - INFO - Fetch from https://www.amsat.org/amsat/ftp/keps/current/nasabare.txt
Traceback (most recent call last):
  File "/home/pi/autosked/gitclone/satnogs-auto-scheduler/schedule_single_station.py", line 395, in <module>
    main()
  File "/home/pi/autosked/gitclone/satnogs-auto-scheduler/schedule_single_station.py", line 246, in main
    tles = fetch_tles(norad_cat_ids)
  File "/home/pi/autosked/gitclone/satnogs-auto-scheduler/scheduler_env/lib/python3.7/site-packages/satellite_tle/fetch_tles.py", line 53, in fetch_tles
    new_tles = fetch_tles_from_url(url=url, verify=verify)
  File "/home/pi/autosked/gitclone/satnogs-auto-scheduler/scheduler_env/lib/python3.7/site-packages/satellite_tle/fetch_tle.py", line 88, in fetch_tles_from_url
    if (lines[i + 1][0] == "1") & (lines[i + 2][0] == "2"):
IndexError: string index out of range

I tried this: pip install --upgrade satellitetle , but it didn’t seem to change the results.

From 7d829f9c 06 Dec, 2019 commit :

  • Force use of python3 instead of system default python version (goes wrong if default is python2)

For my station (Buster) with python2 and python3 installed :
cd satnogs-auto-scheduler
git pull
pip3 install ephem
pip3 install satellitetle
pip3 install requests
pip3 install lxml
pip3 install tqdm
pip3 install python-decouple

after that, this ok

1 Like

I believe this has fixed my issues. I was able to manually run the command and the scheduling worked. The true test will be tonight at 00:00z, but generally I think I am back on track! Thank you everbody!

Ran pip uninstall for both of those, with and without sudo, nothing was there to uninstall.

Also, Ansible doesn’t show any errors or failed. I do see a couple of warnings. Here’s the output:

pi@satnogs1:~ $ sudo satnogs-setup
Applying configuration...
[WARNING]: Could not match supplied host pattern, ignoring: satnogs-setups


PLAY [satnogs-setups] *******************************************************************************************************************************************************************************************************************************************
skipping: no hosts matched

PLAY [satnogs_setups] *******************************************************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [satnogs-setup : Configure satnogs-setup] ******************************************************************************************************************************************************************************************************************
ok: [localhost]
[WARNING]: Could not match supplied host pattern, ignoring: satnogs-clients


PLAY [satnogs-clients] ******************************************************************************************************************************************************************************************************************************************
skipping: no hosts matched

PLAY [satnogs_clients] ******************************************************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [satnogs-client : Install satnogs-client configuration] ****************************************************************************************************************************************************************************************************
ok: [localhost]
[WARNING]: Could not match supplied host pattern, ignoring: satnogs-radios


PLAY [satnogs-radios] *******************************************************************************************************************************************************************************************************************************************
skipping: no hosts matched

PLAY [satnogs_radios] *******************************************************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************************************************************************************************
ok: [localhost]
[WARNING]: Could not match supplied host pattern, ignoring: hamlib-utils


PLAY [hamlib-utils] *********************************************************************************************************************************************************************************************************************************************
skipping: no hosts matched

PLAY [hamlib_utils] *********************************************************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [hamlib-utils : Install hamlib utilities configuration] ****************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [hamlib-utils : Start/stop rigctld service] ****************************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [hamlib-utils : Start/stop rotctld service] ****************************************************************************************************************************************************************************************************************
ok: [localhost]

PLAY [snmpds] ***************************************************************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [snmpd : Setup snmpd listen configuration] *****************************************************************************************************************************************************************************************************************
skipping: [localhost]

TASK [snmpd : Setup snmpd rocommunity configuration] ************************************************************************************************************************************************************************************************************
skipping: [localhost]

TASK [snmpd : Start/stop snmpd service] *************************************************************************************************************************************************************************************************************************
ok: [localhost]

PLAY [gpsds] ****************************************************************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************************************************************************************************
ok: [localhost]

TASK [gpsd : Start/stop gpsd service] ***************************************************************************************************************************************************************************************************************************
ok: [localhost]

PLAY RECAP ******************************************************************************************************************************************************************************************************************************************************
localhost                  : ok=13   changed=0    unreachable=0    failed=0    skipped=2    rescued=0    ignored=0   

Press enter to continue...

did the stub for rtlsdr also change? did two passes with a new and old long running client on pi. Since the update there is no reception anymore (did not change params).
According the logs the qrg did not lock and the campaign failed :frowning:

pi@oe8rke-satnogs:~ $ journalctl -f -u satnogs-client.service
– Logs begin at Thu 2016-11-03 17:16:43 UTC. –
Dec 21 17:42:30 oe8rke-satnogs satnogs-client[374]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown
Dec 21 18:23:54 oe8rke-satnogs satnogs-client[374]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: gr-osmosdr 0.1.4 (0.1.4) gnu radio 3.7.10
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy soapy redpitaya
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: Using device #0 Realtek RTL2 838UHIDIR SN: 00000001
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: Using 32 buffers of size 163 84.
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: Found Rafael Micro R820T tun er
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: [R82XX] PLL not locked!
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: Exact sample rate is: 100000 0.026491 Hz
Dec 21 18:23:58 oe8rke-satnogs satnogs-client[374]: [R82XX] PLL not locked!

Any clue how to fix this or how to revert back? Target qrg was 437200000

br Robert

Hit Update and then Apply. This will retrigger a runof the whole playbook. Focus on the part where satnogs-clients hosts are provisioned.

rtl-sdr has not changed since the last update. What has changed it that rigctld is not executed by the client any more Instead it is started with a systemd service. Failure to start rigtctld could explain why the tuner remains unlocked (if it does cause I don’t see the rest of the logs).

This version of SatNOGS Client Ansible should have taken care of starting rigctld without requiring any user intervention. Can you make sure it did by running systemctl status rigctld?

From what I can see from the log it only shows the sample rate as 1 MSPS it doesn’t say anything about where its tuned.

1 Like

many thanks for your effort so far. the rigctld is running (after reception and also after reboot).

did some further debugging according the troubleshooting wiki page and kicked in following stuff which is pretty interessting. After an reception this message turns up:
pi@oe6xug-satnogs-pi:/tmp $ sudo satnogs_fm_demod.py --rx-sdr-device=rtlsdr --rx-freq=438000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.13.4
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp
Using device #0 Generic RTL2832U SN: 77771111153705700
Using 32 buffers of size 16384.
Found Rafael Micro R820T tuner
[R82XX] PLL not locked!
Exact sample rate is: 1000000.026491 Hz
[R82XX] PLL not locked!
/root/.gnuradio/prefs/vmcircbuf_default_factory: No such file or directory
vmcircbuf_createfilemapping: createfilemapping is not available
gr::vmcircbuf_sysv_shm: shmat (2): Invalid argument
gr::vmcircbuf_sysv_shm: shmat (2): Invalid argument
gr::vmcircbuf_sysv_shm: shmat (2): Invalid argument
Allocating 32 zero-copy buffers


after a clean reboot this:
pi@oe6xug-satnogs-pi:/tmp $ sudo satnogs_fm_demod.py --rx-sdr-device=rtlsdr --rx-freq=438000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.13.4
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp
Using device #0 Generic RTL2832U SN: 77771111153705700
Using 32 buffers of size 16384.
Found Rafael Micro R820T tuner
[R82XX] PLL not locked!
Exact sample rate is: 1000000.026491 Hz
[R82XX] PLL not locked!
Allocating 32 zero-copy buffers

This concludes to me that somehow i suffer by buffer issues probably. But regardless the message .ogg and .dat file is generated but with no real recepted content. I know for sure that qrg was active and placed some signal on.
maybe the gain parameter gets lost. is there a way to debug and read the exact params to the rtl suite binaries?

br Robert

since i’ve the impression that the receiver got numb by parameters i also configured if-gain and bb-gain as well with no real sucess.

Can anyone please, who migrated already successful with rpi3 + rtl-dongle setup, paste the configuration params here (of course without api key or other sensitive material).
This would help me to step forward to gain back old sensitivity.

many thanks in advance, br Robert

Check this issue: https://gitlab.com/librespacefoundation/satnogs/gr-satnogs/issues/161

Now that you have executed the script as pi user, you will hit the above bug. Remove /tmp/iq.dat file to fix it.

Regarding the gains, just remove the options completely (make them blank) and they will revert to the default.

I recently did an “in place” upgrade of my RPi3 from Stretch to Buster. I believe I followed the instructions at https://wiki.satnogs.org/SatNOGS_Client_Ansible#Upgrading_from_.27stretch.27_to_.27buster.27, with the result that satnogs-client-1.0 and gr-satnogs-1.5.1-1 are indicated at the top of the satnogs-setup UI. When I go to check the logs using journalctl -u satnogs-client.service, I get a bunch of warnings of the type

-- Logs begin at Thu 2020-01-16 12:24:24 UTC, end at Thu 2020-01-16 12:34:25 UTC. --

Jan 16 12:24:26 rpi3bp systemd[1]: Started SatNOGS client.

Jan 16 12:25:33 rpi3bp satnogs-client[280]: /usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:849: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings

Jan 16 12:25:33 rpi3bp satnogs-client[280]: InsecureRequestWarning)

I gather that there is a python2 vs. python3 issue here? Would anyone know how I can fix this?

Many thanks!
Andreas

1 Like

@va2wbt

See if this helps:

sudo update-ca-certificates

Thanks @jebba. I just tried it, but it looks like those are already up-to-date? See here:

sudo update-ca-certificates

Updating certificates in /etc/ssl/certs...

0 added, 0 removed; done.

Running hooks in /etc/ca-certificates/update.d...

done.
1 Like