Introduction + Satnogs client installation problem

client

#1

Hi guys,
first of all, congratulations for this interesting project!
I’m an Italian radio hamateur, (callsign IZ7BOJ) and I work in an Italian private Company which is involved in the deisng, assembly and test of microsatellites.
I’m using an RTL-SDR dongle and a home-made turnstile antenna (https://iz7boj.wordpress.com/2018/12/02/double-turnstile-construction-for-satellites-receiving-in-435mhz-band/ )for my first experiments in satellites decoding. I already decoded some 9k telemetries with Windows Software and I posted some data on satnogs DB by DK3WN telemetry forwarder.
Now I would like to contribute to satnogs netowrk, so I registered my station and started to configure my Raspberry pi3 with satnogs client.
I didn’t use the satnogs image just because my raspberry runs other applications and I prefer to keep the actual configuration.
I followed the satnogs instructions and I installed the client using Ansible.
I run satnogs-setup and I completed the basic configuration.
If I run “journalctl -u satnogs-client.service”, I got an error, which is reported below.
Can anyone help me?
Thanks in advance
Alfredo IZ7BOJ

Dec 18 07:34:13 raspberrypi systemd[1]: Started SatNOGS client.
Dec 18 07:34:13 raspberrypi satnogs-client[2103]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: Unable to init server: Could not connect: Connection refused
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: Unable to init server: Could not connect: Connection refused
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: gdk_cursor_new_for_display: assertion ‘GDK_IS_DISPLAY (display)’ failed
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: Traceback (most recent call last):
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/var/lib/satnogs/bin/satnogs-client”, line 7, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: from satnogsclient.main import main
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/var/lib/satnogs/local/lib/python2.7/site-packages/satnogsclient/main.py”, line 4, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: from satnogsclient.scheduler.tasks import status_listener, exec_rigctld
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/var/lib/satnogs/local/lib/python2.7/site-packages/satnogsclient/scheduler/tasks.py”, line 21, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: from satnogsclient.observer.observer import Observer
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/var/lib/satnogs/local/lib/python2.7/site-packages/satnogsclient/observer/observer.py”, line 13, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: import matplotlib.pyplot as plt
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/usr/local/lib/python2.7/dist-packages/matplotlib/pyplot.py”, line 115, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: _backend_mod, new_figure_manager, draw_if_interactive, _show = pylab_setup()
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/usr/local/lib/python2.7/dist-packages/matplotlib/backends/init.py”, line 62, in pylab_setup
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: [backend_name], 0)
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/usr/local/lib/python2.7/dist-packages/matplotlib/backends/backend_gtk3agg.py”, line 9, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: from . import backend_agg, backend_gtk3
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: File “/usr/local/lib/python2.7/dist-packages/matplotlib/backends/backend_gtk3.py”, line 32, in
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: cursors.MOVE : Gdk.Cursor.new(Gdk.CursorType.FLEUR),
Dec 18 07:34:19 raspberrypi satnogs-client[2103]: TypeError: constructor returned NULL
Dec 18 07:34:20 raspberrypi systemd[1]: satnogs-client.service: Main process exited, code=exited, status=1/FAILURE
Dec 18 07:34:20 raspberrypi systemd[1]: satnogs-client.service: Unit entered failed state.
Dec 18 07:34:20 raspberrypi systemd[1]: satnogs-client.service: Failed with result ‘exit-code’.
Dec 18 07:34:20 raspberrypi systemd[1]: satnogs-client.service: Service hold-off time over, scheduling restart.
Dec 18 07:34:20 raspberrypi systemd[1]: Stopped SatNOGS client.


#2

I’ve never seen this before…

Not sure if it would help but could you share the satnog-setup configuration with us (of curse by hiding the API key). You can see it by running sudo satnogs-setup and choose show configuration option.


#3

Hi Freddy,
thanks for your answer:
Here below I attached my simple config file:
satnogs_api_token: xxxxxx
satnogs_app_path: /home/pi/Applications/satnogs-client/
satnogs_network_api_url: https://network.satnogs.org/api/
satnogs_rx_device: rtlsdr
satnogs_station_elev: 30
satnogs_station_id: 377
satnogs_station_lat: 41.248
satnogs_station_lon: 16.421
satnogs_verify_ssl: True


#4

Can you update the system with apt, reboot and then update with satnogs-setup again?


#5

Thanks Acinonyx,
just done, but the error is the same :frowning: