Install the satnogs_gr-satellites "addon" and use your station more!

I’m sure I checked whether construct is installed or not. But it was not installed.
gr_satellites --version is working now.

Thanks!

1 Like

I’m using the Satnogs Raspberry Pi image, which only has Gnuradio 3.7. gr_satellites requires Gnuradio 3.8+. I tried installing the Gnuradio repository (sudo add-apt-repository ppa:gnuradio/gnuradio-releases) but got “Error: could not find a distribution template for Raspbian/buster”. https://wiki.gnuradio.org/index.php/InstallingGR#Raspberry_Pi suggests installing Gnuradio from source. Is that what you did, or is there a better way to get gr_satellites running?

A big thanks to https://community.libre.space/u/sa2kng!

This is the 1st observation with gr_satellites on my satnogs stn: https://network.satnogs.org/observations/4265966/

Very nice! 73, DL8LAQ

2 Likes

My satnogs client version is 1.5.1 and I just followed this installation procedure https://github.com/kng/satnogs_gr-satellites/blob/main/INSTALL.md

That’s all I did to get gr_satellites running!

Thanks. That’s the guide I used as well, but cmake .. resulted in

By not providing "FindGnuradio.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "Gnuradio",
but CMake did not find one.

which lead me down the path of trying to get a more recent version of gnuradio.

But just now I tried clearing the build directory and running cmake again. This time it was successful. I don’t know what has changed, but something of all the stuff I tried the last day seems to have fixed it. Currently running make which will take a while. I’ll report back.

Everything seems to be working now.

The script overwrote my existing post observation script but after editing /usr/local/bin/satnogs-post to call my script as well as the gr-satellites script, everything seems to be in order. gr-satellites logs the following:

gr-satellites: Observation: 4269435, Norad: 43743, Name: REAKTOR_HELLO_WORLD, Script: satnogs_reaktor_hello_world_fsk9600_decoder.py
gr-satellites: Starting observation 4269435
gr-satellites: running at 57600 sps
1 Like

Also for me it works fine. Only had to replace some spaces with tabs in a Makefile. But it shows a suggestion.

Observation:
https://network.satnogs.org/observations/4271692/

Thanks people for the hard work! :smiley:

Best regards Eelke.

I forgot to mention this too!

Me too :smiley: I used sed -i Makefile -e 's/ /\t/g' (8 spaces between the first and second /)

For those with UHF-only ground stations (like me!), satnogs_gr_satellites does not currently include active UHF satellites although this will probably change in the future.

SELECTED="39444 44830 43803 42017 44832 40074"

These two inactive UHF satellites were recycled by the Earth’s upper atmosphere:

ALT-1 44830 on 437.175 Mhz (successful atmospheric re-entry Oct 2020)
SMOG-P 44832 on 437.175 Mhz (successful atmospheric re-entry late Sept 2020)

Time to rebuild my VHF QFH :grinning:

And thanks for the tips on the makefile!

You can edit the SELECTED parameter and add (or remove) the satellites you would like to process with satnogs_gr_satellites.
/Lars

Thanks, Lars. My understanding is limited for this software.

Was satnogs_gr_satellites meant to be an alternative way of decoding frames (IQ stream → UDP)? That is, can this add-on be used to decode all the satellites that satnogs-client already decode but uses a different flowgraph? Or is it meant to fill the gap of satellites that the satnogs-client (v1.4x or v1.5.x) cannot currently decode?

I think better @SA2KNG answer that question. I just happy for this super add-on and all the work that has been done.
/L

1 Like

Agreed, thanks to the SatNOGS community for this and all that is contributed!

1 Like

I get to the “cmake …” command and get this:

CMake Error at CMakeLists.txt:97 (find_package):
  By not providing "FindGnuradio.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Gnuradio",
  but CMake did not find one.

  Could not find a package configuration file provided by "Gnuradio"
  (requested version 3.8) with any of the following names:

    GnuradioConfig.cmake
    gnuradio-config.cmake

  Add the installation prefix of "Gnuradio" to CMAKE_PREFIX_PATH or set
  "Gnuradio_DIR" to a directory containing one of the above files.  If
  "Gnuradio" provides a separate development package or SDK, be sure it has
  been installed.


-- Configuring incomplete, errors occurred!

I just realized this is the same error as mfalkvidd, however simply clearing out the build folder and retrying the cmake gave me the same results…

I’ll review my command history tmoorrow to see what I did and report back.

2 Likes

This is my history file:

2021-06-13 19:00:15 - PKGLIST="libqwt6 libfontconfig1-dev libxrender-dev libpulse-dev swig g++ libtool python-dev libfftw3-dev it-dev libboost-all-dev libusb-dev libusb-1.0-0-dev fort77
2021-06-18 13:18:06 - -wxgtk2.8 git-core
2021-06-18 13:18:06 - -numpy ccache python-opengl libgsl0-dev
2021-06-18 13:18:06 - -cheetah python-mako python-lxml doxygen qt4-default qt4-dev-tools libusb-1.0-0-dev
2021-06-18 13:18:06 - wtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4
2021-06-18 13:18:06 - -docutils gtk2-engines-pixbuf r-base-dev python-tk
2021-06-18 13:18:06 - d2-dev python-gtk2 libzmq libzmq-dev libzmq1 libzmq1-dev python-requests
2021-06-18 13:18:06 - -sphinx comedi-dev python-zmq libncurses5 libncurses5-dev python-wxgtk3.0"
2021-06-13 19:00:26 - echo $PKGLIST
2021-06-14 07:03:25 - cd gr-satellites/build/
2021-06-14 07:03:28 - cmake ..
2021-06-14 07:03:34 - cmake clean
2021-06-14 07:03:39 - ls
2021-06-14 07:03:44 - rm -rf *
2021-06-14 07:03:47 - cmake ..
2021-06-14 07:06:47 - rm -rf *
2021-06-13 19:01:45 - for pkg in $PKGLIST; do sudo apt-get -y install $pkg; done
2021-06-14 12:10:10 - cd gr-satellites/build/
2021-06-14 12:10:12 - cmake ..
2021-06-14 12:16:16 - sudo apt-get install gnuradio-dev
2021-06-14 12:16:29 - apt-cache show gnuradio-dev
2021-06-14 12:17:27 - sudo add-apt-repository ppa:gnuradio/gnuradio-releases
2021-06-14 12:17:46 - apt-cache search add-apt
2021-06-14 12:19:46 - sudo apt-get install software-properties-common
2021-06-14 12:34:47 - sudo apt-get update
2021-06-14 12:36:06 - sudo apt-get upgrade
2021-06-14 12:40:33 - sudo add-apt-repository ppa:gnuradio/gnuradio-releases
1 Like

Ok, now I am stuck at this step:

Copy the grsat-wrapper.sh, kiss_satnogs.py, find_samp_rate.py, satnogs-pre and satnogs-post to /usr/local/bin

Where are these files located? The instructions are little bit difficult to follow… for example, why does it ask you to git gr-satellites twice?

They all should be in should be in ~/satnogs_gr-satellites/
or search via

 find ~/ -name grsat-wrapper.sh

to home in on the directory.