How to request an account?

I would like to have an account, may I have one?

Since SatNOGS Network is still in active development

If you are interested in testing the SatNOGS Client I would suggest you check out signing up on SatNOGS’s Network Dev instance
If you are interested in testing the SatNOGS Rotator then you can set hamlib (rotctld) and control it with a desktop satellite program e.g. gPredict

source

Hey @elkos,
We have successfully gone live on the dev-instance and we’ll be doing a few tests with the whole assembly in place to see if everything is fine.
How do we now, get access to the production instance?

Hey @adureha ! Once you are ready on dev with successful passes, please link to them here and I will be creating an account for you on production.

Thanks!

1 Like

Hey guys(@elkos @pierros), we have built a ground station but we are having troubles in make it live at the dev-instance. When we run satnogs-poller we run into an exception in the jobs request. We aren’t actually really sure how to verify if the whole ground station(radio+client+rotators) is working. The main issue now is on the radio+client side that we don’t know if they are talking with each other or not.
In following the ouput that we are getting when running satnogs-poller:

2016-07-07 03:39:48,086 - apscheduler.executors.default - ERROR - Job “get_jobs (trigger: interval[0:05:00], next run at: 2016-07-07 08:44:46 UTC)” raised an exception
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/apscheduler/executors/base.py”, line 125, in run_job
retval = job.func(*job.args, **job.kwargs)
File “/usr/local/lib/python2.7/dist-packages/satnogsclient/scheduler/tasks.py”, line 114, in get_jobs
raise Exception(‘Status code: {0} on request: {1}’.format(response.status_code, url))
Exception: Status code: 500 on request: https://network-dev.satnogs.org/api/jobs/

Any thoughts?

Thanks in advance!

Is CapTech_alpha your station?

From the network logs I see a request in the form of ?ground_station=CapTech_alpha. This is wrong and probably what’s causing the error. You should use your station id number as GROUND_STATION_ID on client settings. In your case that’s 61.

Yes, that’s the station. I will fix it.
Thanks!

It worked! :smiley:
Okay, now that I know that the client is connected to the network, how can we run a full test?

Is the client running? I’m asking because I see Last seen 3 hours, 31 minutes ago, so it probably connected once.

Depending on the antenna you have on your station you could try schedule a satellite observation for a specific transmitter to see if it can complete the full circle (follow the satellite, receive data, post it back to the network).

I stopped it in order to run tests with Gpredict (I don’t if I can run both simultaneously). i will try to run a full circle.

I am trying to schedule an observation, but the API doesn’t give me my ground station, it points do the station 24 instead. I am tracking my target (CHUBUSAT-3) with gpredict, and we are under the coverage area of the satellite. However, it keeps pointing me to schedule with other station than ours.

Well, now I am not connecting anymore, and it is giving me another error:
File “/usr/local/lib/python2.7/dist-packages/satnogsclient/scheduler/tasks.py”, line 114, in get_jobs
raise Exception(‘Status code: {0} on request: {1}’.format(response.status_code, url))
Exception: Status code: 401 on request: https://network.satnogs.org/api/jobs/

Checking at stuffin.space I dont’t see CHUBUSAT-3 going over CapTech_alpha. I’ll do a cross check with gpredict.

This probably means authentication error. Are you sure you added your API key from Network correctly on client settings?

Are you by chance trying to schedule the observation while the satellite is overhead or close? By default the earliest start time that the network will offer for an observation is 15 mins from the present time. You can set this earlier but keep in mind that the default polling interval from the client is every 5 minutes. So, any “currently overhead” pass or pass within 5 minutes time would not be picked up by the client.

@comzeradd Yes. I double checked the client settings. When I verify the processes being executed on my terminal it says satnogs-poller is running.
Comment: I think would be interesting inform if the Ground Station is connected and/or operational. The web API says we are on line, but also says we were last saw 4 days ago. What exactly does that mean?

@cshields Probably is it. I wasn’t trying to schedule for satellite already flying over us, but just about to reach us. We could get an observation scheduled for our ground station just now. We are waiting for the satellite (5min).

I will keep you updated with the results. Thank you guys!

UPDATE: The observation failed. Neither the antenna nor the rotator worked with the client. As the satellite ITAMSAT(IO-26) was flying by and the antenna wasn’t moving at all, we switched to Gpredict to make sure the controller board was working and we successfully tracked the satellite (although no data was downloaded, the solder joint in the ground plate was broken). We scheduled a second observation, but again we got no success.
We are calibrating the antenna again and will go for another try.
Doubt: Since the antenna was built for 437MHz, is the calibration procedure specified on the readthedocs page right for us?

UPDATE 2: I erroneously set verified the data payload from our observation (#553). However, no data was download at all.

That’s the last time the client successfully authenticated through the API.