Hamlib: LX-200 protocol

Newbie here… I downloaded the Pi image and the first couple of observations went without a hitch. Thanks for all the hard work you guys put into this.

I am trying to figure out whether I can use a telescope rotor (LX-200) with satnogs. It seems that HAMLIB has the LX-200 protocol included. The latest version on GITHUB is 3.3. The version included with the santnogs image is 3.0.1 and does not seem to have the LX-200 included. I guess I have to download the latest version from GITHUB and compile from scratch? Anything I can screw up by compiling the latest version?

I’ve done that (installing latest master from git) for hamlib on my dev station. Worked without any problems.

  • clone
  • build
  • install


I’m wondering if it will get overwritten by any further apt package updates?

Thanks for the reply. After hunting down all the prerequisites I was able to compile/install hamlib 3.3.
I am also able to talk to the rotor through the CLI.
I enabled the rotor via satnogs-setup and applied the changes. Verified that changes were applied:

hamlib_utils_rot_enabled: True
hamlib_utils_rot_opts: -m 1801 -r /dev/ttyUSB0 -s 9600
satnogs_api_token: ******* redacted ********
satnogs_rf_gain: 25.4
satnogs_rx_device: rtlsdr
satnogs_station_elev: 1635
satnogs_station_id: 549

So far so good but the rotor did not engage during my last observation.
What am I missing?

@Pinebeetle did you try to run rotctl locally and test movement by issuing commands to the mount? (Things like P 0 0 or P 90 90 etc)

Yes I did… talking through the command line to the controller seemed to work just fine…