HackRF with SatNOGS - installation needed?

if I would like to use a HackRF with SatNOGS, do I need to build this?

/Lars SM0TGU

No, you can install the hackrf Soapy module from the repository.

sudo apt-get install soapysdr0.7-module-hackrf

After this, check if the udev rule is also installed ls -l /etc/udev/rules/*hackrf*

1 Like

Thank you Jan for info.

Jan, I think I need your help again.
I remembered something about the “rules” but can not find the post.
I do not have any hackrf under /etc/udev/rules.d/ or /etc/udev/rules/

Where can I find these files for HackRF?

I followed this: Fedora Installation - SatNOGS Wiki

Also, I changed the USB connection to the HackRF from USB3 to USB2, and then the unit is found by SoapySDRUtil --probe I’m not sure why it is not working with USB3 port.

Of course,

Remove the hackrf and create the following file:

cat /etc/udev/rules.d/53-hackrf.rules

# HackRF Jawbreaker
ATTR{idVendor}=="1d50", ATTR{idProduct}=="604b", SYMLINK+="hackrf-jawbreaker-%k", MODE="660", GROUP="plugdev"
# HackRF One
ATTR{idVendor}=="1d50", ATTR{idProduct}=="6089", SYMLINK+="hackrf-one-%k", MODE="660", GROUP="plugdev"
# rad1o
ATTR{idVendor}=="1d50", ATTR{idProduct}=="cc15", SYMLINK+="rad1o-%k", MODE="660", GROUP="plugdev"
# NXP Semiconductors DFU mode (HackRF and rad1o)
ATTR{idVendor}=="1fc9", ATTR{idProduct}=="000c", SYMLINK+="nxp-dfu-%k", MODE="660", GROUP="plugdev"
# rad1o "full flash" mode
KERNEL=="sd?", SUBSYSTEM=="block", ENV{ID_VENDOR_ID}=="1fc9", ENV{ID_MODEL_ID}=="0042", SYMLINK+="rad1o-flash-%k", MODE="660", GROUP="plugdev"
# rad1o flash disk
KERNEL=="sd?", SUBSYSTEM=="block", ENV{ID_VENDOR_ID}=="1fc9", ENV{ID_MODEL_ID}=="0082", SYMLINK+="rad1o-msc-%k", MODE="660", GROUP="plugdev"

Then execute the following command:

sudo udevadm control --reload-rules && sudo udevadm trigger

Now reconnect the HackRF and with sudo dmesg -T you should see similar to this:

[Tue Dec 12 20:55:12 2023] usb 2-1.2: Product: HackRF One
[Tue Dec 12 20:55:12 2023] usb 2-1.2: Manufacturer: Great Scott Gadgets
[Tue Dec 12 20:55:12 2023] usb 2-1.2: SerialNumber: 0000000000000000088869dc2488771b

And hackrf_info should give some information on the hackrf used.

Thank you! I think I have it running now. Will do some observations.

1 Like

I have had it running for some observations on VHF and UHF and I’m getting almost no signals at all in the waterfall. I have tested the HackRF on my PC with SDR-Console and it is working OK.

It just like the gain settings are not working at all on the SatNOGS setup. I have used “Settings Field” and the same settings as stations 1868, 1433 and 1696. Now I will try “Overall” gain and see how the result will be.

Please share your settings, Overall gain will not solve the issue.

Currently my SatNOGS S-band station using a HackRF is offline, but via the following link, you can find the settings used.

S-band hackrf meta data

You are correct, Overall gain did not solve it.
As an example, I have this observation (settings in metadata):

Are you using a LNA with this setup?

If not, try the following values "AMP=14,LNA=40,VGA=48" and maybe also reset gain: "80", to 0
It shouldn’t be used, it is a leftover from your Overall gain test.

And keep in mind that FUNcube-1 is currently in transponder mode and that also means TLM is in low power mode

No LNA connected right now. I have change to the values you suggested, valid from UTC 17:00.
Station observations: https://network.satnogs.org/observations/?station=2830

Now I see signals. It needed the extra VGA gain I guess. I will use LNA at antenna later.
This is a GRIFEX observation with a Disconne antenna: