Gr-soapy installation

Hello,
I am not sure that I am writing to the right category, if not sorry about that.

I have a clean ubuntu 20 installation. I installed gnuradio and I follow the instructions of this page (Files · master · librespacefoundation / gr-soapy · GitLab) to install gr-soapy so as to can use hackRF with gnuradio.

I created a new flowgraph to test a simple FM receiver, but I got no module named soapy error.
I tried pip install soapy and now the error is “AttributeError: module ‘soapy’ has no attribute ‘source’”.
Moreover, I followed these instructions (Home · pothosware/SoapyHackRF Wiki · GitHub) to install SoapyHackRF, and the hackRF is recognized by computer.

Can anyone help me? Thanks in advance I upload a photo of my flowgraph.

Hello! Try adding to the Device Arguments field: hackrf=0 Also you can just replace this with osmocom source

Thank you for your reply.
Unfortunately hackrf=0 didn’t work.
installation of osmocom source solves the problem, but I am planning to use limeSDR and plutoSDR can I use osmocom for any hardware? If no, any other thoughts?

Is the Soapy hackrf module installed ?

SoapySDRUtil --info will show all available modules.
If installed you can also query the hackrf with the following command SoapySDRUtil --probe="driver=hackrf"

Yes, it is installed.
Both SoapySDRUtil --info and SoapySDRUtil --probe="driver=hackrf" gives right responses in cli.

Installing with source has it’s issues, one bring the default install path.
If you use the instructions, make sure you use cmake -DCMAKE_INSTALL_PREFIX=/usr .. as specified in the advanced instruction…
Otherwise you need to pay attention to PYTHONPATH Installing from source — gr-satellites 5.6.0-git documentation
Installing soapy with pip probably made it a mix of the two that probably made it worse.
Building a .deb and installing that is a bit safer, as the packaging system has control of all the files.
dpkg-buildpackage -us -uc -b would be a decent start, it will warn if unmet dependencies exist.

Update: I tried this on a fresh Ubuntu 20 on a VM, built the deb package and installed.
I changed debian/changelog with:

-gr-soapy (0.0-1) unstable; urgency=medium
+gr-soapy (2.1.3-1) unstable; urgency=medium

to make the package version make sense.