Gr-satnogs OOT module installation errors

Dear all,
I have tried many times to install the gr-satnogs OOT module with no success. I am not a linux expert, i am just a user of GNU Radio. This is the first OOT module I will ever install.

I have followed this guide but did not seem to work for me, and I tried Ubuntu 22.04.1 and Debian 11, in all cases with fresh installs.

I can setup a virtual machine and install the most convenient OS in order to get gr-satnogs OOT module up and running, including any version of GNU radio. Would you please help me with the simplest case to do it?

For example, in ubuntu 22.04.1, I did the following process. Errors shown at the end

To run a command as administrator (user “root”), use “sudo ”.
See “man sudo_root” for details.

ubuser@ubhost:~$ sudo add-apt-repository ppa:gnuradio/gnuradio-releases
sudo apt-get update

ubuser@ubhost:~$ sudo apt install -y \ libboost-desudo apt install -y
libitpp-dev -time-dev
libboost-date-time-dev \
libboost-filesystem-dev \dev
swig \
cmake \ssential
pkg-config \
gnuradio-dev \v
libgmp-dev \
liborc-0.4-0 \
liborc-0.4-dev \in
libpng+±dev \

ubuser@ubhost:~$ git clone librespacefoundation / SatNOGS / gr-satnogs · GitLab
cd gr-satnogs
mkdir build
cd build
cmake …
make -j $(nproc --all)
sudo make install

– Found PythonLibs: /usr/lib/x86_64-linux-gnu/ (found version “3.10.6”)
CMake Error at swig/CMakeLists.txt:36 (include):
include could not find requested file:


CMake Error at swig/CMakeLists.txt:84 (GR_SWIG_MAKE):
Unknown CMake command “GR_SWIG_MAKE”.

– Configuring incomplete, errors occurred!
See also “/home/ubuser/gr-satnogs/build/CMakeFiles/CMakeOutput.log”.
make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target ‘install’. Stop.

You need to use GNURadio 3.8.x all newer versions will fail.

That’s ok, thank you for your help. Howver, when trying specific gnuradio 3.8.2 installs, the problems turn out to be others, like prefixes etc.

Would you please help me indicate which command will install gnuradsio 3.8.x version and still the exact same commands used above will work?

Alternatively, which would be all the steps to install gnuradio 3.8.2 and after that gr-satnogs.

thanks in advance

Good day,

Currently, If you want to use a x86 system then use Debian bullseye as you distribution.

Here a scratchpad with some steps that I used to get it up and running.

If you want to go the hard way and keep using Ubuntu, then have a look at this log file I created some time ago enabling a SatNOGS client on Ubuntu 20.04. (This still uses GNURadio 3.8)

Information sources: