Firmware upload problems

rotator
electronics

#1

My team has run into problems with the satnogs rotator controller firmware upload process. We are particularly unsure about how to properly deal with the ISP and FTDI connection methods.

What we have tried has been using an Arduino Uno connected with ISP to an Ardunio Pro Mini and running the various upload commands. ‘make ispload’ says that it uploads correctly using ISP, and so does ‘make upload’ which is odd since the instructions state to use FTDI. When FTDI is tried for make upload, it fails. The last command, ‘make burn_bootloader’ fails using either method. The error that came when it failed was always ‘recipe for target failed’ which has led us to think it could be a wiring issue.

Attached is a pic of the error message, as well as the setups used for ISP and FTDI that we used. If someone who has successfully uploaded this firmware could provide some insight into this problem, perhaps with correct pictures or a video of the installation process, that would be much appreciated.

make burn_bootloader error message

ISP connection setup (https://www.arduino.cc/en/Tutorial/ArduinoISP)

FTDI connection setup (https://www.instructables.com/id/Program-Arduino-Pro-Mini-Using-Arduino-Uno/)


#2

Looks like you can’t establish programming mode at all.
There are several possibilities that can cause this, eg: ISP Fuse disabled to get some IO Pins working, wrong flashing mode (HV/LV mode), clock fuse messed up etc, pp.

There are a lot of infos on either https://www.avrfreaks.net or https://embdev.net (same as https://www.mikrocontroller.net). I think you will be successfull on solving this with these sources.
If not, I could spend some time to help you searching, but without hardware this will be a mess.

HTH,
Patrick


#3

Thank you for the response. We have looked into the resources you have sent us and have realised that its probably a connection issue. However, we have been unable to get it to work. ‘make ispload’ works now, but when we run ‘make upload’ the following error message is given.

We think the issue is still our connection setup, or possibly a baud rate mismatch, but we aren’t sure. We would greatly appreciate any more help you could give us.


#4

I seem to be having a similar issue. Did you ever solve your problem?