Feedback on New Stations de noob

Good morning,

I’ve been working on bringing up two omnidirectional stations based on the Raspbian image. Both stations are running RPi3 and connected to turnstiles at about 10m. Both stations have the Amsat amplifier ( at the antenna.

They both seem to be receiving well, but I haven’t noticed any decoded data as of yet. If anyone has the time, I’d appreciate some input and feedback on some of the observations. I think the gain is mostly under control, but it could probably use some fine tuning.

RF 33.4
IF 0
BB 0

RF 49.6
IF 0
BB 0

I have been able to decode some in DireWolf, but am yet to have any luck with the client directly. Is what I’m seeing normal with this hardware and setup?



Welcome Malcolm!!

Right now the only decoders that we have working in the client are for APT* and FSK9k6. CW is in the works and others will come soon.

Now, that said, there is an issue in the APT script and the new raspbian image, in that the waterfall generation takes too much memory and chokes. So if you try out APT observations don’t fret when you see a missing waterfall, but you should see imagery under the Data tab.

Now, I notice in your UHF station that there is quite a lot of shift. Your signals are about -12kHz off center. That will cause the decoding to not work also. I would suggest re-running satnogs-setup and adjusting your PPM shift but that’s a LOT of drift to be PPM related (in my opinion). What SDR are you using?

Thanks for the observation on the UHF side! I’m running the nooelec sdr:

While I haven’t corrected for ppm, it was < 5 on both stations. I may try rotating this SDR with my ARISS I hate to see if it behaves any differently. I hadn’t noticed the significance of the drift there, but agree it’s way too much for a ppm correction.

Thanks for the info on decoding too! I was mistakenly under the impression that CW and 1200 were working. So, I was going a little nuts trying to get it just right and hunting for errors.


Try a PPM correction of 30 and see if that gets you closer to centerline.

Thanks Corey.

I’ll give that a shot and see how it looks before inducing another variable into the mix.

For the record, more eyes are always better…

When I was testing with a different sdr I set the ppm…apparently…

So, the -25 here plus the actual 5 comes out right on to adding 30 as you suggested!


1 Like

Pardon my ignorance, but is that screenshot taken from a web client?
Is this in the latest Raspbian image?

It’s okay, I just found it too. it is, If you browse to port 5000 you can access it.

1 Like

Oh that is so cool :slight_smile:

So does that mean I can change configuration via the web page, save, and the station will comply?

It looks like it, but it didn’t work for mine. That’s one of the bug reports I made on gitlab earlier today.

Not quite yet… but that’s the eventual intent. Right now manual observations can be scheduled through the UI.

1 Like

You can schedule through the UI today? I assume that’s under ground station control, but that’s blank for me.

On the top-right where it says network mode click and switch it to standalone mode.

1 Like

Awesome… that makes testing much easier! Thanks!

@cshields @nb3t Since we are on this standalone discussion, Can you or someone show a screen shot or setting to capture a pass in this mode? More importantly the “Arguments” section(some doppler settings?). I would appreciate this very much.

Hi Malcolm. Looks like you are using my station ID of 144. If this is correct, please correct it.

Also, the header of your gs page shows that you are using the test mode and has a warning at the top in a red ribbon that you need to change to network mode.

I think you’re mixing up things: Malcolm uses station #144 in network-dev, while yours should be active in the production instance of network!

Thanks for the correction. Your are correct, my station is active in the network.

Sorry for the mistake.