Failure invalid signature I can't seem to get my ground station online

I am pretty inexperienced in many aspects of this project. My apt update for the satnogs client is failing because of an invalid signature. I have followed the troubleshooting suggestions at which has not worked for me. I gather from other sources online that apt-key is deprecated but alternatives I have found online have not worked. Any help? Thanks

Is the error exactly the same with the one in Troubleshooting - SatNOGS Wiki?

If not add the error here, so we can troubleshoot it more.

Note, if/when you run this command from the wiki, it is all on one line, not on two:

wget -qO - | sudo apt-key --keyring /etc/apt/trusted.gpg add -

Not sure if that’s the fix you need though. Best is if you can cut & paste exact errors and surrounding lines to help with debug.

Happy hacking! :slight_smile:

1 Like

I did realize that it is all one line, yes and thank you. So I have managed to download the key (according to instructions from elsewhere on the internet) The error I was getting was: gpg: No valid OpenPGP data found That is, by the way the same error you get if you make a mistake in the url for the key. I resolved my problem by downloading the key then adding it to the keychain, but in hind sight there is a good chance I fat-fingered the original command. I have now figured out why an ssh connection to the little computer on the other end of my desk is a good thing. I ran apt update and upgrade and rebooted but I am still on on the network. I am sure I will get it if I carefully step through the docs. Thanks so much for your support and help

1 Like