Failed SatNOGS update

I decided, as advised here "SatNOGS client March 2020 update

The time has come for a brand new update! We would like to announce that a new upgrade is available for the SatNOGS Client software. You are advised to check the SatNOGS Client Setup wiki page"https://wiki.satnogs.org/SatNOGS_Client_Setup?utm_source=SatNOGS+Updates&utm_campaign=4827018877-EMAIL_CAMPAIGN_2019_08_27_05_54_COPY_01&utm_medium=email&utm_term=0_29409b0533-4827018877-162158353#Updating_SatNOGS_Client_Software"
From the wiki page I followed the instructions

Updating SatNOGS Client Software but I still ended up with “stretch”

So I followed these instructions " Upgrading from Debian ‘stretch’ to ‘buster’ Method 2"
It all worked fine but lsb_release -a told me I had Release 9.11 Codename stretch

What are my options besides download and burn a new image for the RPi?
can I do sudo apt-get update && sudo apt-get upgrade? Then upgrade Satnogs client?

My station ID-724 is off the air while I’m in this pickle.
I’m NOT a programmer and I normally believe if it’s not broken, don’t fix it but the message sounded like a pretty important upgrade was necessary.

Thanks for taking the time to read this and your efforts to help a hardware man.

1 Like

Honestly, I think you will be better off re-flashing the microSD card.

Where can I find the latest image? The one I downloaded from the wiki link is dated 2019-09-11 and the zip file is named image-2019-09-11-Raspian-SatNOGS-lite.zip. Probably the old, now redundant upgrade.

I also found this on gitlab satnogs-pi-gen-2020030400 by following another wiki link.

A better date but is it for Raspian? I’ll find and read some readable files and see if that clears it up.

Did some reading. From what little I understand, satnogs-pi-gen-2020030400 is not an image but is used to build an image if you know what you are doing. I know just enough to be dangerous. I run Linux Mint 19.3 with MATE desktop. Mint is based on debian right? so it should work but they mention debian buster. I thought buster is the latest Raspian version? Clearly I’m in it way over my head. Looks like I’ll have to wait until someone smarter than me creates a downloadable Raspian buster image.

It also looks like the wiki page needs some deleting or clarification of older obsolete information to reduce confusion for us noobs.
A good thing I didn’t try to update both my stations. Lesson learned from doing the last update where I ended up having to burn a new image. 568 still working.

Thanks, Bob vk2byf

I think the 2019 image is OK, as it will be the latest raspbian version.

The latest satnogs software is obtained by running sudo satnogs-setup and running an update.

73
Mark VK5QI

The latest rpi image can be found here:

https://gitlab.com/librespacefoundation/satnogs/satnogs-pi-gen/-/jobs/artifacts/2020030400/download?job=release

Indeed the satnogs-pi-gen repository is the one responsible for building those images. Images can be found as tags here:

https://gitlab.com/librespacefoundation/satnogs/satnogs-pi-gen/-/tags (and then select to download the “zipped image”)

On the https://wiki.satnogs.org/Raspberry_Pi wiki page I found the correct recent link. @Acinonyx did the last edit to it to update the image url. Where did you find the old image URL @vk2byf ?

Thanks for your help Pierros & Mark
I found the old image from the big download button on the wiki page which now points to the new image.
This is really weird.
I recently destroyed my main HDD partition and had to re-install Linux Mint 19.3 from scratch. I can’t see how this would matter, unless somehow the old wiki page was cached somewhere on the data partition?

I shall try again and report back when it all works again.
Thanks Bob vk2byf

It looks like ID-724 is working again on Raspbian stretch minus the upgrade.

It looks like stretch is preventing the upgrade and wiki method 2 is not updating the distro to buster even though I enabled it in the Advanced section of satnogs-setup.

Unless I can come up with a method to easily upgrade to Raspbian buster without flashing a new Micro SD card, it will have to keep running as is.

The confusion came about because the unzipped archive extracted to 3 files with the 2019 09 11 date which led me to believe I downloaded the wrong archive.

Thank you all for your support. Bob vk2byf

2 Likes

Can you please follow these steps?

  1. Run sudo satnogs-setup
  2. Hit Update
  3. Reboot
  4. Run sudo satnogs-upgrade and follow the prompts.

P.S. Have you manually modified the environment in any way?

2 Likes

I did all of that but it didn’t work. I think the update doesn’t work because my RPi OS is still stretch.
wiki Method 2 does not update stretch to buster even though I have enabled it in the advanced section of satnogs-setup. I have changed nothing else.

I had similar problems updating my ID-568 station. Ended up corrupting the SD card and had to burn a new September 2019 image which is still working.

The Update updates the configuration tool only. If you do that on stretch, Ansible will then complain about unsupported release and exit.

But running sudo satnogs-upgrade manually, should start the upgrade process. Be aware that this method of upgrading requires a lot of time (even more than an hour) and requires a fast internet connection.

Yes I noticed it didn’t take long at all, just a few seconds, so it failed satnogs-upgrade. I have fiber to the the house and usually download 1.3Mb/S.
Unfortunately I can’t cut and paste the output here because Putty won’t let me. 7 lines
Hit:1 http://archive.raspberrypi.org/debian stretch in release
Get:2 http:// raspbian.raspberrypi.org/raspbian stretch inrelease [15.0kB]
Hit:3 http://download.opensuse.org/repository/home:/librespace:/satnogs/raspbian_9.0 ./ InRelease
Hit:4 http://ppa.launchpad.net/ansible/ansible/ubuntu trusty InRelease
Fetched 15.okB in 2s (7,065 B/s
Reading package lists… Done

It’s working so I won’t worry about it too much until I’m forced to update. Maybe others will have similar problems and a solution will be found.
Thanks, Bob