Error using rtl-sdr

i always get this error message when i try to make an observation:

Mai 04 14:53:14 SATNOGS satnogs-client[2461]: rot_open called
Mai 04 14:53:14 SATNOGS satnogs-client[2461]: dummy_rot_open called
Mai 04 14:53:14 SATNOGS satnogs-client[2461]: rot_get_position called
Mai 04 14:53:14 SATNOGS satnogs-client[2461]: dummy_rot_get_position called
Mai 04 14:53:14 SATNOGS satnogs-client[2461]: rot_set_position called
Mai 04 14:53:14 SATNOGS satnogs-client[2461]: dummy_rot_set_position called: 144.60 9.96
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: Traceback (most recent call last):
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: File “/usr/bin/satnogs_fsk_ax25.py”, line 491, in
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: main()
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: File “/usr/bin/satnogs_fsk_ax25.py”, line 476, in main
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: tb = top_block_cls(antenna=options.antenna, baudrate=options.baudrate, bb_freq=options.bb_freq, bw=options.bw, dc_removal=options.dc_removal, decoded_data_file_path=options.decoded_data_file_path, dev_args=options.dev_args, doppler_correction_per_sec=options.doppler_correction_per_sec, enable_iq_dump=options.enable_iq_dump, file_path=options.file_path, gain=options.gain, gain_mode=options.gain_mode, iq_file_path=options.iq_file_path, lo_offset=options.lo_offset, other_settings=options.other_settings, ppm=options.ppm, rigctl_port=options.rigctl_port, rx_freq=options.rx_freq, samp_rate_rx=options.samp_rate_rx, soapy_rx_device=options.soapy_rx_device, stream_args=options.stream_args, tune_args=options.tune_args, udp_IP=options.udp_IP, udp_port=options.udp_port, waterfall_file_path=options.waterfall_file_path)
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: File “/usr/bin/satnogs_fsk_ax25.py”, line 92, in init
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: tune_args, settings, samp_rate_rx, “fc32”)
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: File “/usr/lib/python3/dist-packages/soapy/soapy_swig.py”, line 166, in make
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: return _soapy_swig.source_make(nchan, device, dev_args, stream_args, tune_args, other_settings, sampling_rate, type)
Mai 04 14:53:16 SATNOGS satnogs-client[2461]: RuntimeError: SoapySDR::Device::make() no match
Mai 04 14:53:20 SATNOGS satnogs-client[2461]: satnogsclient.observer.observer - ERROR - No waterfall data file found

rtl_test --> works

satnogs_fsk_ax25.py --soapy-rx-device=“driver=rtlsdr” --antenna=RX --samp-rate-rx=2.048e6 --rx-freq=444000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat -> works

config:
Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1.2-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “3.8.1.0~rc1-2”,
“satnogs-config”: “0.10.1”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “SATNOGS”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971059200,
“available”: 785698816,
“percent”: 19.1,
“used”: 117633024,
“free”: 465973248,
“active”: 248897536,
“inactive”: 175296512,
“buffers”: 27529216,
“cached”: 359923712,
“shared”: 6496256,
“slab”: 60559360
},
“disk”: {
“total”: 15014416384,
“used”: 3755352064,
“free”: 10601582592,
“percent”: 26.2
}
},
“configuration”: {
“enable_iq_dump”: true,
“iq_dump_filename”: “iqdump”,
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rf_gain”: “12”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtl-sdr”,
“satnogs_station_elev”: “424”,
“satnogs_station_id”: “808”,
“satnogs_station_lat”: “47.89”,
“satnogs_station_lon”: “13.75”
}
}
------------[ copy end ]-------------

Probably typo, it should be “driver=rtlsdr” not “driver=rtl-sdr” as described in https://wiki.satnogs.org/SatNOGS_Client_Setup. If not please let us know where did you find this value in order to fix it.

1 Like

It works! Thank you :slight_smile:

1 Like