Error Installing satnogs on Desktop

I am getting this stange error while trying to install on my Desktop to replace my Pi.

TASK [satnogs-setup : Install Ansible repository keys] *************************
fatal: [satnogs]: FAILED! => {"changed": false, "cmd": "/usr/bin/apt-key adv --keyserver --recv 93C4A3FD7BB9C367", "msg": "Error fetching key 93C4A3FD7BB9C367 from keyserver:", "rc": 1, "stderr": "Warning: apt-key output should not be parsed (stdout is not a terminal)\ngpg: key 93C4A3FD7BB9C367: public key \"[User ID not found]\" imported\ngpg: Total number processed: 1\ngpg:               imported: 1\ngpg: WARNING: nothing exported\ngpg: no valid OpenPGP data found.\ngpg: Total number processed: 0\n", "stderr_lines": ["Warning: apt-key output should not be parsed (stdout is not a terminal)", "gpg: key 93C4A3FD7BB9C367: public key \"[User ID not found]\" imported", "gpg: Total number processed: 1", "gpg:               imported: 1", "gpg: WARNING: nothing exported", "gpg: no valid OpenPGP data found.", "gpg: Total number processed: 0"], "stdout": "Executing: /tmp/apt-key-gpghome.OGjScgo1eV/ --keyserver --recv 93C4A3FD7BB9C367\n", "stdout_lines": ["Executing: /tmp/apt-key-gpghome.OGjScgo1eV/ --keyserver --recv 93C4A3FD7BB9C367"]}

Any help? I want to get this desktop working for my station so I can take my Pi and use it for another station.

Well I can’t get this to work and I also tried to even skip it and and the next step that adds keys errors.

So yeah not sure I am going to get a second station up anytime soon.


Have you tried the other methods, without Ansible?
It may be easier.


There is technically no method with out ansible.

I have installed satnogs-client on two Ubuntus already without using Ansible,
what do you mean by “There is technically no method”.

What kind of Desktop do you have?

1 Like

Because that way is deprecated and unsupported. And also it’s more complicated when on debain it should just work.

Hey, did you have any luck with this? I’m having a similar issue. It appears related to the ansible pgp key retrieval. This line from the ansible install is failing:

sudo apt-key adv --keyserver --recv-keys 93C4A3FD7BB9C367

The key doesn’t seem to be found.

I finally got it. Had to add the key in a different manner.

curl -sL "" | sudo apt-key add