Debian Buster - Ansible SatNOGS client install

Is the current version of https://wiki.satnogs.org/SatNOGS_Client_Ansible currently working for Debian 10? Have tried branch master & stable.

  • It already installs Gnuradio 3.8, but the Flowgraphs like “satnogs_fm_demod.py” were removed
  • Observer does not find the scripts to do any observastions.
  • Station 38 therefore offline for the moment :slight_smile:
2 Likes

Yeah, it does work, but only stable. In fact, we test Ansible on Debian Buster before flashing and final testing to RPi because it is faster.

Only stable branch is currently stable (what a surprise!). master branch is in a broken state until flowgraphs are compiled into a package. Flowgraphs have recently been moved into a new repository and will be maintained and packaged separately from gr-satnogs which makes SCM and contributions much more clean and flexible.

3 Likes

Thank you for the update :slight_smile:
Maybe a note in the steps at https://wiki.satnogs.org/SatNOGS_Client_Ansible to do

git clone --single-branch --branch stable https://gitlab.com/librespacefoundation/satnogs/satnogs-client-ansible.git

instead of

https://gitlab.com/librespacefoundation/satnogs/satnogs-client-ansible.git
…which defaults to master would be nice.

My satnogs station is based on amd64/debian and is 40km away from home and I had no luck to downgrade from master to stable.

1 Like

@hb9fxq_myrig I added a git checkout stable line to the wiki, I hope that’s good too.

https://wiki.satnogs.org/SatNOGS_Client_Ansible

4 Likes

Anyway, stable seems also broken, mixes Gnuradio 3.8 with old flowgraphs…

I thought stable was installing gnuradio 3.7 still. You sure 3.8 isn’t from before?

Tried again with a clean Debian 10 VM -> Stable does install 3.8.0.0. - Will not work.

1 Like

Agreed, the package gr-satnogs 2.0-1 seems broken to me when installed on a fresh pre-built Pi3 image previously updated with satnogs-setup (experiemental=True) to the latest master.

The installation of gr-satnogs 2.0-1 and libgnuradio-satnogs 2.0-1 was performed manually with

sudo apt-get remove gr-satnogs libgnuradio-satnogs

wget http://download.opensuse.org/repositories/home:/librespace:/satnogs/Raspbian_10/armhf/gr-satnogs_2.0-1_armhf.deb
wget http://download.opensuse.org/repositories/home:/librespace:/satnogs/Raspbian_10/armhf/libgnuradio-satnogs_2.0-1_armhf.deb

sudo dpkg -i libgnuradio-satnogs_2.0-1_armhf.deb
sudo dpkg -i gr-satnogs_2.0-1_armhf.deb

Executing a flowgraph (satnogs_fsk_ax25.py in this example) failed with the following error:

AttributeError: 'source_sptr' object has no attribute 'set_overall_gain'

gr_satnogs_errorlog.txt (1.4 KB)

This bug was fixed in gr-satnogs@0ba9e0e, so gr-satnogs master is fixed.

According to this the stable branch seems broken to me currently due to the potentially broken gr-satnogs 2.0-1 release and the unstable branch/experimental=True is missing the satnogs-flowgraphs package. The latter can be fixed by a manual installation of satnogs-flowgraphs.

edit: Added details on environment.

2 Likes

Note that on a station following the stable branch of satnogs-client-ansible gr-satnogs will be installed in version 1.5.1-1 (see stable@satnogs-client-ansible:/satnogs-radio/defaults/main.yml), so the conclusion that the stable branch is broken in my previous post was wrong.

My problem with gr-satnogs 2.0-1 was caused by having installed an incompatible (too new) version of gr-soapy (ec2eb8e@gr-soapy instead of the required gr-soapy 2.0) due to a breaking change in the upcoming unreleased version of gr-soapy.

1 Like

Since ~ 2020-02-08 the stable repositories (home:librespace:satnogs) contain a gnuradio package 3.8.0.0-6, so this gets installed instead of gnuradio 3.7 provided by debian 10/buster (and required by gr-satnogs 1.5.1). This could be the reason why stable might be broken (I didn’t try to reproduce myself).
If this is the case, apt-pinning gnuradio to 3.7.* should solve the issue. Add the following to /etc/apt/preferences.d/satnogs (untested):

Package: gnuradio
Pin: version 3.7.*
Pin-Priority: 1001

An alternative solution might be: Prevent installation of newer packages from a third-party repository
@Acinonyx : should this be added to satnogs-client-ansible?^

I pinned gnuradio so the issue should be fixed now. Only new installations should have been affected or installations where a manual update was performed. Updates through satnogs-setup should not have been affected since apt dist-upgrade does not resolve package conflicts automatically.

4 Likes

Thank you - after manual cleanup / downgrade an reinstalling I can confirm stable for Buster is working again :+1::+1::+1:

3 Likes

Trying to install Satnogs on a raspberry pi running Openwebrx, I followed Ansible Client tutorial, but at the end I have this error message:

pi@openwebrx:~/satnogs-client-ansible $ ansible-playbook -i production/inventory -K site.yml
SUDO password:
Executing playbook site.yml

  • satnogs-setups -
    Gathering Facts…
    [WARNING]: Failure using method (v2_runner_on_unreachable) in callback plugin
    (<ansible.plugins.callback.unixy.CallbackModule object at 0xb52c6eb0>):
    ‘CallbackModule’ object has no attribute ‘delegated_vars’

      to retry, use: --limit @/home/pi/satnogs-client-ansible/site.retry
    
  • Play recap -
    satnogs : ok=0 changed=0 unreachable=1 failed=0

Any idea?

73’s from EA5WA Juan Carlos