ConnectionError message and others

Running Satnogs on PI 4, the station is visible on the network. Running: “systemctl status satnogs-client”, getting error messages (photo attached). Also attached is info on “satnogs-setup” and “journalctl…”).

Help appreciated, Stefan VE4SW

Is this temporary ? From time to time there is performance issues on, this looks bad in the logs but resolves itself when it comes back up. Status page here.
If it is persistant, there is some issue with the network connection or lan that prevents dns working properly.
What is the result of running ping from the rpi ?


Ping looks fine, and error message is not related to network performance issues, as far as I can tell.

Stefan VE4SW

Do note that by “network performance” I mean specifically the https service on
Also there has been odd resolve issues in the past where the -client gets stuck and not resolving, restarting the client/host has solved many of these.
Even if this command works curl -SL -o 1895.json the -client might still have cached some nonsense dns and refuse to get the jobs.


The issue still persists with no change after reboots/restarts.


Doubt it, but could this possibly be an IPv4 vs IPv6 thing?

One easy thing to try is point your DNS to something other what your LAN is serving up. I use Google DNS so my rpi4’s /etc/resolve.conf is


Not that this would cause the errors in the logs … but also wondering about your gain value set to ‘10’, make sure that’s an allowable gain setting for your SDR. My RTL-SDR blog v3 lists these:

pi@raspberrypi:/etc$ rtl_test
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 20201226

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6

Thank you!

Yes, that was one of the first things I tried. Changed the DNS, no success, however. Yes, the gain for the RTL-SDR has been changed to the available value, no impact on the error message…


Did you try the curl command btw ?

And if you want to eliminate ipv6, add this to /boot/cmdline.txt line with console, root and all that:

On a plain debian 12 raspberry I get this with ip a

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether dc:a6:32:8d:3b:f5 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute eth0
       valid_lft 55061sec preferred_lft 44261sec
    inet6 fe80::6182:9dfa:259e:d483/64 scope link
       valid_lft forever preferred_lft forever

where inet6 is ipv6 address.