Com port fails to open, and no motor control

Hello All ,
This is my first post on here so please accept my apologies if this post is in the wrong place, and admin, please feel free to move it.

I am trying to build myself a Rotator using the Arduino Uno and CNC shield V3 (4988 drivers) with 2 stepper motors.
The firmware was obtained from Quartapound / satnogs-rotator-firmware · GitLab
I am using Windows 10 and Hamlib-w32-4.5.5 along with GPredict.
The hardware seems to function as expected , that is I apply 12V to the CNC board and when I plug in the USB lead from the Arduino both motors rotate and eventually come to a stop. If I depress the momentary switches for the endstops the motors slow to a stop then reverse 2 revolutions before coming to rest.
I have configured GPredict interface module as described and created the batch file
rotctld -m 203 -r com4 -s 9600 -T 127.0.0.1 -t 4533 -C timeout=500 -C retry=0 -vvvvvvvv > pause

So, I first run as an administrator “rotctld” which opens in a command window then I run GPredict and further open the "Antenna Control "panel and engage my interface,
from there I can set the Az and El (as defined by the circle) then the antenna position indicator (defined by the +) which then tracks to the circle , The motors do not move at this point.
I hope I have got all the above correct ,
As the motors do not turn as I would expect I have done some investigation and found the com port is failing to open this was discovered by sending the command from rotctl \send_cmd GS the return message displayed included a line which stated "write_block: port not open.
I can not figure out why this is and am open to any ideas from you guys,
My com speed is 9600 (on com 4) as defined in the device manager these match the "easycom.h " file which looks to be V3 so I set the Rotator type to “203” in my Hamlib batch file which resides in the Bin directory.
I have the CNC drive enable jumper installed
Any help would be much appreciated , Thankyou for reading this .
Best regards

Hi, I’m not running it under windows, but linux natively and under docker.
The models according to the rotctld installed with docker-hamlib, iirc I have used 202.

   201  Hamlib                 EasycommI               20191206.0      Beta          ROT_MODEL_EASYCOMM1
   202  Hamlib                 EasycommII              20191206.0      Beta          ROT_MODEL_EASYCOMM2
   204  Hamlib                 EasycommIII             20201203.0      Alpha         ROT_MODEL_EASYCOMM3

The -t and -T could be left out as the defaults are a good start.
Not sure, but I usually see the com ports referred to in uppercase, like COM4 (not com4).
Read the output of rotctld, it should tell you what is going on, althou it is quite spammy at that verbose level.

Hi,
Many thanks for the reply, I changed the “com” from upper to lower but I will change it back and amend the module number to 204, Thanks for the info.

BTW, Impressive Bio on QRZ you have , I have the Yaesu “Earthstation” too, I love it .
Nearly finished my U3 also.

73s G7NSJ

For testing I usually run rotctl (without the d) and type the commands manually, skip all the intermediate layers. When I know I have a working setup I launch rotctld and connect to it with rotctl -m 2 -r localhost (this works as a client for the daemon) and verify that it is working. You can probably use that command straight away in your case, better to have control of what is happening and less layers in between when testing. use ? for a help page.

Thanks, the QRZ page of mine is a bit outdated thou (:
I switched to IC-910 as it has a bit better rigctl support, but none of the radios is perfect by any stretch of the imagination. Also a bit more antennas as one would expect :smiley:

Hi,
Well I changed things around abit as mentioned and removetd the -T and -t and also tried all 3 module numbers and an still getting the same result “write_block : port not open” but I think it may be referring to port 4533 and not the com port , I will further investigate later today .
I can program the Arduino via the same COM4 on the same laptop so I suspect the com port is ok
As you said below

What would be the command to achieve this , ( Ah the Log File :smiley: )
I am at work now and dont have access to the project.

If all fails I think it may be easier to install GPredict and Hamlib on the Raspberry Pi which I am running the Satnogs SW on , I just wanted to test the motors etc on the bench as a start and work from there .

Thanks for the info

Having spent a bit more time at it, It definately appears I am missing the network port, Hopefully I have correctly attached the snapshot of the GS command.

under linux, if the tcp port is busy, like rotctld or something else already running on it, you will get this error (with -vvv) and it will just quit. I’m guessing windows will do pretty much the same.

binding failed (trying next interface): Network error 98: Address already in use
main: bind error - no available interface

My suggestion is this:
rotctl -m 202 -r COM4 -s 9600 -vvvvv
use command p to get position.

iirc hamlib is pretty benign and does not hog the comport, but any other terminal will. everything else using it will need to be closed.
according to the list of rotators you should use 202 or 204, I don’t think there’s much difference between the two at this stage.

connecting with a terminal directly to the COM4 ans issuing AZ EL should also get you position…