Client does not start: Exception: SATNOGS_STATION_ID not configured


#1

Installed the Raspbian image, after minor configurations to incorporate it to my home network (hostname, wifi configuration, few standard packages) I started the SatNOGS configuration itself.

After running the configuration and checking the client status it seems it is unable to start

journalctl -u satnogs-client.service

feb 17 12:15:02 mucrux systemd[1]: Started SatNOGS client.
feb 17 12:15:03 mucrux satnogs-client[10466]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unk
feb 17 12:15:04 mucrux systemd[1]: Stopping SatNOGS client…
feb 17 12:15:04 mucrux systemd[1]: Stopped SatNOGS client.
feb 17 12:15:04 mucrux systemd[1]: Started SatNOGS client.
feb 17 12:15:04 mucrux satnogs-client[10507]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unk
feb 17 12:15:06 mucrux satnogs-client[10507]: Traceback (most recent call last):
feb 17 12:15:06 mucrux satnogs-client[10507]: File “/var/lib/satnogs/bin/satnogs-client”, line 6, in
feb 17 12:15:06 mucrux satnogs-client[10507]: from satnogsclient.main import main
feb 17 12:15:06 mucrux satnogs-client[10507]: File "/var/lib/satnogs/local/lib/python2.7/site-packages/satnogsclient/_
feb 17 12:15:06 mucrux satnogs-client[10507]: raise Exception(‘SATNOGS_STATION_ID not configured.’)
feb 17 12:15:06 mucrux satnogs-client[10507]: Exception: SATNOGS_STATION_ID not configured.
feb 17 12:15:06 mucrux systemd[1]: satnogs-client.service: Main process exited, code=exited, status=1/FAILURE
feb 17 12:15:06 mucrux systemd[1]: satnogs-client.service: Unit entered failed state.
feb 17 12:15:06 mucrux systemd[1]: satnogs-client.service: Failed with result ‘exit-code’.
feb 17 12:15:06 mucrux systemd[1]: satnogs-client.service: Service hold-off time over, scheduling restart.
feb 17 12:15:06 mucrux systemd[1]: Stopped SatNOGS client.
feb 17 12:15:06 mucrux systemd[1]: Started SatNOGS client.
feb 17 12:15:06 mucrux satnogs-client[10547]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unk
feb 17 12:15:08 mucrux satnogs-client[10547]: Traceback (most recent call last):
feb 17 12:15:08 mucrux satnogs-client[10547]: File “/var/lib/satnogs/bin/satnogs-client”, line 6, in
feb 17 12:15:08 mucrux satnogs-client[10547]: from satnogsclient.main import main

Running sudo satnogs-setup and viewing the configuration the result is

hamlib_utils_rot_enabled: False
│ satnogs_api_token: bc9c8f507e2eac63a2cba69c1a6206e1beec836b
│ satnogs_network_api_url: https://network.satnogs.org/api/
│ satnogs_rx_device: rtlsdr
│ satnogs_station_elev: 40
│ satnogs_station_id: LU7DID

So the station id is configured.

Any ideas or hints would be very much appreciated.

Thanks, Pedro LU7DID


#2

It has to be the number assigned to your Groundstation, not a call sign. Please do never show your stations API key on the internet in any chat or forum! You need a new one, now! :wink:


#3

@lu7did as @DL4PD said please don’t share your api key as this can give access to anyone to upload and change things in network related to your station and its observations.

I’ve removed it, so you will need to change to a new one. You can get a new one by visiting your dashboard page, by clicking on your avatar in the network site, and asking for the API key.

In your case it should be 499


#4

Got the message, and I did already changed the API key.

In my discharge I would say that neither the purpose of the API token nor the origin of the ID are particularly clear in the documentation, at least the initial; perhaps the deep knowledge on the system makes both obvious, but not for me yesterday. Now with the explanation it’s clear 499 is an ID and LU7DID the NAME.

It won’t hurt to disclaim somewhere in the initial documentation not to exposse the API key as well; while installing the documentation being read is confined mostly to the initial documentation.

Thanks anyway and my excuses for any trouble caused.

73 de Pedro, LU7DID


#5

No trouble at all. Thanks for the feedback about the documentation, I’m going to open an issue about it.


#6

As @fredy said: no trouble at all!
If you find some time after setting up your station successfully: feel free to make changes to the documents where you found pit-falls! That would be awesome! :smiley:


#7

Sure, you bet! Do you have a link to suggest on where to start, the whole site is daunting to start peeking & poking on where is the documentation and how to access to it to edit; just few basic clues and I’ll do it, it’s just a couple of words next to the definition table in the initial setup.

73 de Pedro LU7DID


#8

Just register for an account! After that you will be able to edit anything in the wiki :wink:


#9

As @DL4PD suggested feel free to start with the wiki. You can login in by clicking the “person” icon on the right of the wiki navigation bar using your SatNOGS credentials. :slight_smile:


#10

Thank you, done.

73 de Pedro, LU7DID