Client does not find uhd firmware (B210)

This is the client log:
Okt 03 22:18:42 satnogs satnogs-client[345]: - DEBUG - Initial frequency: 437025000
Okt 03 22:18:42 satnogs satnogs-client[345]: - DEBUG - Rigctld msg: 437035229
Okt 03 22:18:42 satnogs satnogs-client[345]: [WARNING] [B200] EnvironmentError: IOError: Could not find path for image: usrp_b200_fw.hex
Okt 03 22:18:42 satnogs satnogs-client[345]: Using images directory:
Okt 03 22:18:42 satnogs satnogs-client[345]: Set the environment variable ‘UHD_IMAGES_DIR’ appropriately or follow the below instructions to download the images package.
Okt 03 22:18:42 satnogs satnogs-client[345]: Please run:
Okt 03 22:18:42 satnogs satnogs-client[345]: “/lib/arm-linux-gnueabihf/uhd/utils/”

The usrp images are located in /usr/share/uhd/images. I did set the UHD_IMAGES_DIR variable “export UHD_IMAGES_DIR=/usr/share/uhd/images” in .profile and printenv result is “UHD_IMAGES_DIR=/usr/share/uhd/images”
I tried to run a script manually: --soapy-rx-device=“driver=uhd” --antenna=TX/RX --samp-rate-rx=2e6 --rx-freq=145950000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat
That works, the firmware images loads into the B210, the green led lights up, after ctrl-c the files audio-out.ogg & waterfall.dat are there.
I tried “sudo …” and get the same EnvironmentError like satnogs-client.

I could not find any useful hint with the big search engine. Running out of ideas now.

73, Norbert

This seems weird. I am running a couple of stations with B210, B200 etc without an issue.

Please supply the output of “Advanced > Debug”

Also: Do you use the rpi image?

I ran into this when swapping in a B200 mini yesterday… Not sure if it is a regression. @Acinonyx may know?

Welcome, @norbert! Here is a quick fix for your station, but note it will probably be overwritten when applying any changes through satnogs-setup.

Edit /etc/default/satnogs-client and drop the following line at the end for the images dir to be picked up:


then sudo systemctl restart satnogs-client

1 Like

SATNOGS_LOG_LEVEL *Define SatNOGS client log level [DEBUG] SENTRY_DSN Define SatNOGS client Sentry DSN [d50342fb75aa8f3945e2f846b77a0cdb7c7d2275]
SENTRY_ENABLED Enable SatNOGS client Sentry error monitoring [False]

I already changed client log level to DEBUG. Now I enabled error monitoring too.

Your hint definately changed something. The [B200] environment error is gone. But it seems that no one tries to load the B200 firmware and the rx led stays off now.

Next try with error monitoring enabled…

Yes, I use the satnogs rpi image from April 2020 + updates.

Ok, after successful observations with the rtlsdr I tried the Ettus B210 again. I don’t know why, but now SatnogsClient can access the B210 (green led on). But the spectrum shown on satnogs-monitor does barely show noise (random dots or squares) and the waterfall shows only violett horizontal lines.

That’s a problem for wednesday. Good night!

Edit: The observation shows cw signals - Who was that? - and data packets on the waterfall. The keying is audible in the fm demodulated audio file.

73, DL8LAQ