Can control rig with hamlib but not GPREDICT

I’m using a Raspbery Pi 3B+ with latest stock Rasperrian. I installed hamlib2-3.0.1+b1 and required support through “Add/Remove Software”. I can run rigctl from a command line and sucessfully control my Yaesu FT857. I configure GPREDICT using the FT857 example in the manual using the default localhost and port.
When I follow the steps in the user manual on pg 57 to start tracking nothing happens I enable Engage. The FT857 frequencies never change.

I have aslo read the Yaesu FT-847 post and added -t 4532 to the rigctl command. It didn’t help.

Any hints?

The 847 and 857 are very different radios, so don’t let information about the 847 confuse you.

The 857 should work fine either as an RX only type device or the 817/857/897 type. Note thet you need to run rigctld (with a d) to have the server running, not just rigctl.


1 Like

I was running rigctl without the d. It works now.
I was also able to get my rtl-sdr V3 running as a receiver through Gqrx.
Thanks for the great software

Cool, thanks for the update.