Auto-scheduler schedules unlisted satellites

For some reason auto-scheduler is scheduling passes for satellites that aren’t in my or my priorities_223.txt file. At one point I was scheduling passes for them but have since removed them. They’re showing as being scheduled by me, not someone else. Is there some other source that’s used for the satellites to schedule?


Jon WB2MNF sysop for W2MMD

Sounds like it has stored in memory the old list. Random guess, have you restarted the script after changing the satellites?

does it warn with: Could not read priority file priorities_223.txt. ?
could you share the exact commandline ?
are you running the tag 0.2, current master or older ?

Yes, and new satellites added to the script are added to the pass list. But older satellites not in the script are also added to the pass list.

Here’s the command line: /home/pi/env/bin/python /home/pi/env/bin/ -s 223 -d 24 -P /home/pi/env/bin/priorities_223.txt -w 600 -z -T

I did not get the error you mentioned.

The -T is superfluous - we’re no longer in testing mode.

The version returned is 0.2

You probably want to use this option: -f, --only-priority Schedule only priority satellites (from -P file)

Edit: not sure if I understand the source code correctly, but this option might be default True. I do get different results with and without it on my station though.

1 Like

As @mfalkvidd said, you also need the -f to only select from priority file.
I recommend updating to master, v0.2 is some 90 odd commits behind master and doesn’t deal with the frequency misuse transmitters for example.
git checkout master && git pull --ff-only should do the trick, if there’s no changes made to the source.
if you run it under venv, activate that and do a reinstall: source env/bin/activate && pip install .
The above instructions vary depending on how you installed it in the first place.

1 Like

Thanks to both of you. The -f function seems to have solved most of the issue. I don’t understand what satellites would be scheduled other than those in the priorities file so I don’t know why that parameter is necessary but it’s probably in the docs somewhere.

There’s still one anomaly remaining - scheduling for satellite 25544 (the ISS) seems to also or instead schedule for 39444 (Funcube). I can remove the ISS since we’re currently not receiving well on 2 meters.

The git command returned the error “fatal: not a git repository (or any of the parent directories): .git”. I don’t remember how I installed it - I used whatever is on the current documentation page.

But it’s mostly working now and not scheduling passes for satellites that we can’t receive anyway. My primary remaining problem is that we’re using SatNOGS to command PST Rotator thru the hamlib interface and it’s banging each individual degree change to the rotator. I need to find the code where the rotator commands originate and increase the rotation increment. Changing it in satnogs setup doesn’t work.



You sure it’s not a mixup of transmitter uuid’s ?

you are referring to SATNOGS_ROT_THRESHOLD ?

it is used here.

aha, then perhaps after activating the venv pip install git+ without the @0.2 tag

1 Like

I understand that the parameter might seem illogical, but there is a history to it.

The main use case when the auto scheduler was created was to let the user maximize utilization of their station.

For most users (including mysel), this is still the main use case.

Later, the priority feature was added. This allows the user to give priority to the satellite they are most interested in. As the name suggests, it gives priority, it does not exclude.

Even later, a new feature was added to exclude satellites that haven’t been given a specific priority. This opened up to some less common use cases, whis probably is the reason you are using the auto scheduuler. But the main use case is still to maximize utilization.

So that’s why the parameter is necessary for your use case. The majority of users do not use it.

Thanks -

There might be a mixup of the IDs. I solved that issue by removing the 2 meter antenna (which isn’t working well, which is why I wanted to eliminate those satellites) from the station config.

Yes, that’s the parameter but it doesn’t appear to be being used when control is being passed to a remote hamlib site. Where’s that code located on the Pi? I can do some digging now that I know where the code is.

That git command got the same error. Perhaps I didn’t load it using Git - I don’t remember how I did the initial setup.

Thanks again

The info on -f is helpful - thanks. But without the user scheduling priorities what satellites ARE scheduled? How are they selected? If there’s an online answer feel free to point me to that reference.


All passes for satellites that transmit on frequencies that the station is configured for are scheduled.

When there are multiple alternatives, I think the scheduling just uses first come first served. Same situation would apply when using a priority list, if multiple satellites in the priority list happen to pass at the same time. So there is not really any difference in the algorithm.