Audio issues on new system

I have a Wimo TA-1 antenna, with about 6 foot of coax going to my wide band LNA
this is connected to my RTL-SDR bloc v3. I have enabled the bias T via software in satnogs.

However, all of my audio observations sound like static. I have tried to set the RF gain in the advanced options. First, I set to to 8.7 dB. That didn’t make a difference, so I changed it to 0.0.

Can folks take a look at and give me some additional suggestions?

thank you

-Kevin (KK4YEL)


you should hide your API key.

I’m having issues using with Bias-T on the new system : are you sure yours is working with the above settings ? I just tried them on my setup and I don’t get 5V when I do.


@9v1rm looks like the newest commits to gr-soapy will fix your issue with bias-t, looking forward for the update. Currently it neither worked with my HackRF but i expect it to be fixed in the next version

Thank you. I have checked (before bringing it outside) and the system was functioning as expected. Just double checked, and at least the command line

~/rtl_biast/build/src $ ./rtl_biast -b 1
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner


So I thought having pre and post scripts like this would make the thing turn on and off appropriately?

am I wrong ? I guess I could go out there in the middle of a pass and disconnect and verify voltage,

Are you hinting that the static and saturated audio is from a lack of gain because the LNA is not on?

OK, so for starters - there is no actual USB demodulation flow-graph in gr-satnogs. This means that the default flow-graph (which is FM) will get picked instead. What you’re hearing on that observation is pretty usual for FM-demodulated noise. Turn the squelch off on any FM receiver and you’ll get the same thing.

Even when using a preamplifer, setting the gain to nothing is a bad idea. You are, in effect, deafening your receiver. You need to have some level of gain set in the RTLSDR regardless of whether you have a preamp or not. If you have too little gain set, your SDR will be ‘internally noise limited’ - that is, you are being limited by the sensitivity of the SDR. What your really want is for your receive system to be just barely externally noise limited. This means you want just enough gain that the noise from the local environment (and there will be noise…) is just above the noise floor of your receive system.

You can test this by (while looking at your RF spectrum with something like GQRX) terminating the input of the LNA with a 50 ohm load, then unplug the load and plug in the antenna. If you see the noise floor rise just slightly, then you have your gain set about right. If you see no significant noise floor increase, then wind the gain up. If the noise floor rises a lot, then maybe wind back the gain a bit. You don’t want to have too much gain set, otherwise you may end up generating intermodulation products.

1 Like


There are multiple ways to set the Bias-T :

  • The one I was initially referring to was the one using the SATNOGS_DEV_ARGS.
  • It works fine when when using the command line and the ./rtl_biast -b 1 command. This seems to be the test you did when taking the picture with your fluke.
  • The good news is that adding the command in your SATNOGS_PRE_OBSERVATION_SCRIPT does seem to work (at least here). This wasn’t the recommended way of doing (using the SATNOGS_DEV_ARGS is) so I initially ignored it. It seems you do however have a mistake in yours as it should be exactly as your SATNOGS_POST_OBSERVATION_SCRIPT with the exception of -b 1 instead of -b 0

73 Martin 9V1RM

yes, I saw that cut and paste error, and it is corrected now. Thank you. I will try to determine the proper level of RF gain using @vk5qi method above. I have to study gqrx man a bit first.

@vk5qi is there a way to convert the ogg from a SSB pass using sox, and then load that into SDR# and be able to demodulate it that way ?

@swood5858c3 I have the same setup as you, but do not have the same results. What value are you using for your RF gain on the v3 RTL-SDR?

My setup has varied quite a bit as I’ve tried to optimize and tweak. Turns out I was chasing a bad BNC to SMA adapter cable from my antenna for a bit and blaming the LNA or FM filter. I probably messed the cable up when putting it on the roof or taking it back down, etc. Anyway, when it was working with both the LNA and filter in place, my RTL-SDR’s gain was set to 7.7 or 8.7. Currently, I’ve removed all the extra RF cable, LNA, and FM filter and have the SDR sitting about 6 inches from the antenna’s feed. I’m using a 25ft active USB cable and the SDR’s gain set to 48.0. I was just setting it up this way to remove points of failure and I liked the results so much I decided to just leave it.

Hmm. I just have the RTL-SDR v3 hooked directly to the RTL LNA (fed power via the Bias T), and then 3 feet of cable run into the antenna. I would hope that would be short enough. I have set the gain to 12.5 but that doesn’t seem to help much. I could just try the RTL-SDR by itself. I do not have the FM filter.
thanks for your reply.

No, the ogg file is post-demodulation. You would have to enable the IQ saving, (in the advanced options in satnogs-setup), and then process the IQ file through something like GQRX to be able to do USB demodulation.

1 Like

I would definitely try it w/o the LNA since your cable run is so short. I’m not that familiar with the turnstile antennas, but my QFH is a DC short so I had to turn off the bias-t power when removing the LNA or risk ruining the SDR.

1 Like

yes, I made sure the biasT was off, thank you

What problem are you trying to solve? I looked through your recent NOAA observations and they don’t look bad at all.

@swood5858c3 FM voice sats like AO-91 or 92

Looks like you got it worked out?

I believe so. thank you