'Applying' during SatNOGS client setup crashes on Raspi 3

I have been trying to install SatNOGS client on my raspberry pi 3 using the instructions (SatNOGS Client Setup - SatNOGS WikiReflashing_and_reinstalling.28recommended.29). I can go through the basic configuration steps no problem but when I select ‘apply’, I see several messages from the configuration process, but the pi always reboots on its own after a while. I don’t think that is the expected behavior and after reboot the satnogs-client.service is dead.

I have tried several times, with different SD cards (and sizes), power cables etc., always with the same result. Anyone has had a similar experience and/or knows what the problem might be?

Thank you in advance.

That’s strange behavior. Some questions that may help:

  1. Which model of raspberry pi 3 do you have?
  2. Could you generate a support report and paste it here, to generate it go to AdvancedSupport and wait for the report to be generated, this may take some minutes.
  3. One random suggestion that may help, can you perform manual upgrade before getting into satnogs-setup and hit apply. For doing so, please run the command sudo apt update and then the command sudo apt upgrade. After finishing with upgrade, try again to hit apply.
1 Like

Might be worth checking if the Pi is getting sufficient power. Dealing with the Low Voltage Warning on the Raspberry Pi - Pi My Life Up
The apply might cause the Pi to draw more power than the power supply can handle, causing a reboot and corrupted file system.


Start a separate terminal that is ssh’d into the device. Then run dmesg -Tw and leave that running. Then when it barfs/reboots you may see what happened (in case it doesn’t get saved to disk). It does sound power related to me, at first glance. What USB power source are you using?

Thank you for the help with the initial issue. I am not sure what I did to resolve it but it worked for a while got some observations in. I resinstalled with fresh SD card and did add another power supply, so it might have been a power issue to begin with. I got it to work for a while and got some observations, but now have been consistently getting the error:

raspberrypi satnogs-client[376]: satnogsclient.scheduler.tasks - ERROR - 400 Client Error: Bad Request for url: https://network.satnogs.org

I have tried reinstalling, entered the API key several times (copy + paste), including generating a new one, but nothing worked.

Any suggestions?

Here is the support info:

------------[ copy here ]------------
“versions”: {
“satnogs-client”: “1.6”,
“satnogs-client-ansible”: “202109022142”,
“satnogs-flowgraphs”: “1.4-1”,
“gr-satnogs”: “”,
“gr-soapy”: “”,
“gnuradio”: “”,
“satnogs-config”: “0.12”
“state”: {
“is-applied”: true,
“pending-tags”: null
“system”: {
“date”: “2022-05-03T21:27:52.256605+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.103-v7+”,
“version”: “#1529 SMP Tue Mar 8 12:21:37 GMT 2022”,
“machine”: “armv7l”,
“processor”: “”
“memory”: {
“total”: 968052736,
“available”: 792375296,
“percent”: 18.1,
“used”: 105508864,
“free”: 519266304,
“active”: 219422720,
“inactive”: 161640448,
“buffers”: 38576128,
“cached”: 304701440,
“shared”: 6483968,
“slab”: 49938432
“disk”: {
“total”: 30440230912,
“used”: 3494240256,
“free”: 25654804480,
“percent”: 12.0
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “50”,
“satnogs_station_id”: “2644”,
“satnogs_station_lat”: “55.792042”,
“satnogs_station_lon”: “-4853991”
------------[ copy end ]-------------

It seems that something is wrong here. I guess it should be -4.853991 instead of -4853991