Ansible Install fails due to callback error

I can’t install from the satnogs image, as I have other requirements on the Pi it will be running on. As such I’m tying to use the latest Raspio 64 bit beta, which has worked flawlessly so far. However I have tried to install the client via pip. While this installs, it doesn’t install the satnogs-setup script (not anywhere on the machine)
So I figured, after 4 hours of trying to find the error, that I’d try the Ansible install.
However this throws this error:
Executing playbook site.yml

  • satnogs-setups -
    Gathering Facts…
    [WARNING]: Failure using method (v2_runner_on_unreachable) in callback plugin
    (<ansible.plugins.callback.unixy.CallbackModule object at 0x7fb59a72b0>):
    ‘CallbackModule’ object has no attribute ‘delegated_vars’

    to retry, use: --limit @/home/pi/satnogs-client-ansible/site.retry

  • Play recap -
    satnogs : ok=0 changed=0 unreachable=1 failed=0

Scooting about on google for another hour I can find nothing that helps me solve the issue. This turned up on a 32 bit distro too, so it’s not confied to the 64 bit variant.

Anyone seen this?

I’m struggling a little wirth this install not following the image-install route - normally I have no issues but there seem to be very few breadcrumbs for those of us taking the path less followed.

Well,
Editing ansible.cfg and entering “host_key_checking=false”
and changing production/inventory/hosts to show
ansible_ssh_pipelining: to false
let the install complete as expected, with some warnings around satnogs-setup

Now I’m fighting with Soapy not having any modules to load… we fight on…

1 Like