Ansible_distribution Error. Client installation on Ubuntu 16.04

client

#1

Hi,
Im trying to install the satnogs client in Ubuntu 16.04
I have ansibile version 2.7.8.

After enabling ssh, run the ansible-playbook command:
~/satnogs-client-ansible$ ansible-playbook -i production/inventory -K site.yml

Then I received an error with the following text:

TASK [common : Check distribution] *************************************************************************************************************************************************************************
fatal: [satnogs]: FAILED! => {
_ “assertion”: “ansible_distribution == distribution and ansible_distribution_release == distribution_release”, _
_ “changed”: false, _
_ “evaluated_to”: false, _
_ “msg”: “This role requires Debian stretch.”_
}
to retry, use: --limit @/home/seteclab/satnogs-client-ansible/site.retry

I really would like, if anyone can tell me what I’m doing wrong

Thanks


#2

Hello,

We have same problem too. I tried to setup both Ubuntu 16.04 and 18.04. However, I could not pass that error. Most probably, we just missing a small part but we will see. Hopefully, someone solved the problem.

Thanks.


#3

Unfortunately Ubuntu is not currently supported as gr-satnogs needs a specific version of gnuradio. So, for now we suggest you use debian stretch.

There is plan to support ubuntu but it’s low priority task for now. Of course, you are more than welcome to contribute on supporting ubuntu.


#4

mmm I understand. thanks for the information, can you tell me more about how to contribute on supporting ubuntu?