Switch from RTL-SDR to Funcube Pro+ dongle


#1

Hello community,

This is my fist post so sorry if the question is already answered, in that case please leave me a pointer to the answer.

I have activated my SATNOGS station on a RPi3 leveraging a standard image (satnogs-client-0.5.3, gr-satnogs-1.2-1). I use a RTL-SDR dongle and rotated X-yagi antennas. Over the Easter weekend I have optimized the gain settings (20dB in the 70cm mast-based LNA pre-amp and on the dongle: 12dB RF-gain, 0dB IF gain and 0dB BB-gain) with 12m high quality cabling from mast to shack.

First results are quite encouraging: Station 236 observations

I now would like to exchange the RTL-SDR dongle for my Funcube Pro+ dongle as I expect much better results from that receiver. I learned that gr-osmocom can be leveraged for this, but was unable to find an explanation on how to do that. Is it merely a different setting for SATNOGS_RX_DEVICE and re-tweaking the gain settings, or should it be done in a different manner?

Thank you for any support!

Ralph


#2

cc’ing @surligas and @csete that would know about the oscmocom support for fcd pro+


#3

Gr-osmosdr support is just fine, assuming that gr-fcdproplus is included int he installation. The problem is with gain mappings.

Different devices have different gain stages. To get the list of available gain stages and ranges requires an interaction between the application and gr-osmosdr, but this is not possible in the GRC scripts used in gr-satnogs, where the gain stages are defined statically.

Anyway, there is a chance that it will work since the Funcube Dongle also has 3 gain stages: LNA, mixer and IF. These will probably map to RF, IF and BB in the GRC script.

PS: There have been some permission problems with using the Funcube Dongles on recent linux systems. It looks like we need to review the udev rules and policies. I do not have any more info at this time.

Alex


#4

Thank you for the quick response!

What I am looking for it the practical guidance of how to configure for the Funcube Pro+ dongle.

Should I simply replace the value “rtlsdr” for “fcd” in the SATNOGS_RX_DEVICE entry of satnogs-setup and re-tweak the gain parameters, or is it done in a different way?

Ralph


#5

Gains can be explicitly overwritten using the appropriate command line arguments. If you can provide me the sampling rate and some nice default values for the gains, I can integrate the support for the Funcube asap.


#6

As per the website of the developer the Funcube Pro+ has a sampling rate of 192 KHz.

See also the Qthid tool by @csete

Happy to experiment with the gain settings once the dongle is activated in the SatNOGS client and report back.


#7

The first two stages are ON/OFF, the BB gain is 0-59 but the device goes crazy if you set ti to 30 or more.


#8

@surligas Would it be possible for any of you guys to explain step by step how to configure fcdp+ with the satnogs clients please?

Thanks


#9

I would also welcome such explanation, as so far I am using the RTL-SDR dongle. I would be specifically interested to learn how to configure it for the standard RPi Ansible-based installation.

The current set-up works OK with the RTL-SDR dongle, but I would expect even better results with the Funcube Pro+ dongle.


#10

Because of the 192ksps sample rate, all flowcharts would have to be altered to interpolate to a higher sample rate. The minimum sample rate used in the gr-satnogs flowcharts if 500ksps.


#11

Initially we had a problem with the sampling rate of the funcube dongle. Now all of our flowgraphs (except APT demodulator) make use of the polyphase arbitrary resampler. So I think we can support it, with minor changes. At the python/hw_settings.py of gr-satnogs there is a dictionary used as lookup table, where the client grabs the information regarding the corresponding SDR device. You can do some tweaks there and check if it works for you. if it does, let me know.