Satnogs newbie setup problem

Hi–I assembled a pi3 and RTL-SDR dongle and all fine with pi programming until the final setup, with "sudo satnogs-setup " it fails on trying to access the gitlab.com host so I am stuck. I have been through the earlier parts a few time and it seems to be correct. Any ideas appreciated. John

Assume you’ve done the business with the RPI image and you’re on the command line either with ssh or directly. So you type sudo satnogs-setup and it goes to a URL in the command line?

Hi @cessna210!

Is still the access to gitlab an issue when you run sudo satnogs-setup?

I think there were a couple of issues on gitlab when you posted, so maybe now is solved. If not then probably is something else we need to solve.

1 Like

Hi Fredy–I gave up trying, it would not let me past the sudo satnogs-setup. but I will try again during this week when I can make time–so thx for the heads up. John

2 Likes

This is what I get each time I ty the sarongs-setup. Pretty sure everything up to that point is correct!!! John

1 Like

That’s very strange…
In sudo satnogs-setup there is the Show option. Could you please select it and copy paste it here. WARNING please hide/remove your API Key (satnogs_api_token)!!! Also make sure you have scrolled with the up/down arrows to include all the values.

Can you also verify that rpi has internet access? If yes please try this command:
wget https://gitlab.com/librespacefoundation/satnogs/satnogs-client-ansible.git

1 Like