RTL-SDR.com wideband LNA w/RTL-SDR.com dongle bias-t

Ok, found your station.

Not much to be determined there, though. Have you measured for voltage coming out of the RTL-SDR V3 dongle when the observation is occuring? What LNA are you using?

The only way to know for sure that the bias-t is not turning on is to measure the voltage at the dongle.

There is no voltage showing. It’s not turning on.

are you able to turn it on and off with the rtl-sdr.com software switch?

If no, are you able to turn it on using the arguments rtl=0,bias=1 in gqrx?

If the answer is no to both of these, then you probably have a dud dongle. It IS a genuine RTL-SDR V3 dongle, correct (the silver ones with 2 screws on the endcaps)?

Yes, it turns on when I run the software switch manually. I haven’t tested in Gqrx since I don’t have an X server running on this Raspberry Pi. If I take the RTL SDR v3 and plug into another system with Gqrx, it enables fine.

Yes, it’s a genuine RTL SDR v3. I have about 10 of them here.

Are you using the exact same DEV_ARGS? No spaces or anything like that? If you answer yes, then I am out of ideas.

@K3RLD Thanks. I have tried a variety of values… current value is:

rtl,buffers=32,buflen=16384,bias=1

I even replaced the previous LNA with the RTL SDR blog Wideband LNA.

Still getting blue waterfalls with very weak signals. It was definitely better with it not connected.

If there is no voltage coming out of the dongle, there is no point in leaving the LNA attached (unless you power it externally), and the color of the waterfalls are meaningless.

I vaguely remember seeing a note somewhere that, when using additional options, the receiver index must be specified explicitly. E.g.

rtl=0,buffers=32,buflen=16384,bias=1

You have me slightly excited. I’m a dinner w/ the family, I’ll give that a try when we get home.

1 Like

So I put that in last night, and let it run for 30-40 observations. Same issue :frowning:

Any updates on this? Did anyone confirm that the updated bias-t guide works? I’m trying it right now and it doesn’t seem to play ball with satnogs client (seems like nothing happens, but then again I’m not certain the signal was good either). I can enable bias-t manually and that works, but I’m not sure that those dev args work.

I used what is listed in the wiki (exactly is in the wiki, as I am the one that added it to the wiki). It works fine for me. You are running rasbian buster, correct?

Excellent, thanks for the confirmation and reply. Apologies for not responding sooner.

I realized just now that I am running stretch. It’s been a few months since I’ve installed this ground station, so that must be it. I’ll update it right now. Thanks!

1 Like

Built a new install with buster and I didn’t really notice any difference with and without LNA, so I’ve removed it for now.

I’ll build another satnogs client just for testing. Meanwhile, I’ll get an externally powered LNA, like nooelec one. Thanks for your help!

Update: I have successfully managed to get the bias-t working from the above guide. Thank you!

After my external bias-t power port decided to break I was forced to give guide this another shot :slight_smile: I can confirm it works now, here’s a link to NOAA 18 observation, which I think is pretty good considering I’m using a scanner antenna (and not whole sky is visible from this location).

5 Likes

Following through your wiki instructions.
With the current update of the Satnogs client the SATNOGS_DEV_ARGS option doesn’t appear under the Advanced menu.
Would it now be called the ‘Pre-observation script’?
Cheers
James

No, the device arguments are not the same as a pre observation script. And what I’ve found is that using a pre-obs script doesn’t work because the sdr is “reset” as soon as satnogs starts the observation, thus turning the bias-t off.

Having said that, I haven’t attempted using the bias-t since updating, so not sure how to proceed (I will look at this when I have some time, hopefully tonight).

–Roy
K3RLD

As per other discussion.
SATNOGS_DEV_ARGS
is found under the Rado - Radio settings, part of the Advanced menu.
Need to scroll down to see it.
Cheers
James

Odd, I don’t have “radio - radio settings”. Running client 1.0…